Results 1 to 4 of 4

Thread: No 'Keyboard" or "Touchpad" entries in Plasma > System Settings > Input Devices

  1. #1

    Default No 'Keyboard" or "Touchpad" entries in Plasma > System Settings > Input Devices

    My system: Leap 15.3 with Plasma 5.18.6
    My problem: In System Settings > Hardware > Input Devices there are no entries for "Keyboard" and "Touchpad" (see the screenshot). How do I tell Plasma that I have both on my laptop so that I can get the entries in Input Devices back so that I can configure both the keyboard (essential, as I need German, Hebrew and Greek keyboard layouts) and the touchpad?
    Background: I deleted the folders .cache, .config, .kde4, .local in my home folder because when selecting "Disable Touchpad when mouse is plugged in" the touchpad would never be enabled when the mouse was unplugged. I hoped that this would be cured when I started with new config files. (This may have been a stupid idea but it's too late now.) Before the deletion of those folders the appropriate entries used to there. Keyboard and touchpad both work.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,016
    Blog Entries
    3

    Default Re: No 'Keyboard" or "Touchpad" entries in Plasma > System Settings > Input Devices

    Quote Originally Posted by opensuseinmanila View Post
    Background: I deleted the folders .cache, .config, .kde4, .local in my home folder because ...
    Were you logged into KDE at that time (when you deleted the)? If so, that's likely to be part of your problem.

    I suggest that you logout from KDE. Then use CTRL-ALT-F1 to get a command line, and login there. And then:
    Code:
    /bin/rm -rf .cache .config .local .kde4
    Then logout from the command line session, use CTRL-ALT-F7 to get back to the graphic screen, and login again to KDE. That should recreate those folders with the default settings.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  3. #3

    Default Re: No 'Keyboard" or "Touchpad" entries in Plasma > System Settings > Input Devices

    Thanks for the reply. I did delete the config files in IceWM (I had done it before and did not have issues). Logging back into to Plasma I discovered the problem. Logging out and back in again or even rebooting the machine did not help yesterday -- until this morning (Manila time). A good night's rest helped; both entries are back. I don't understand it this, but the problem is gone.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,016
    Blog Entries
    3

    Default Re: No 'Keyboard" or "Touchpad" entries in Plasma > System Settings > Input Devices

    When you logout from KDE, some applications remain running for a while. And maybe those caused the problem. The reboot terminates them.

    I'm glad you have things back working.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •