Results 1 to 4 of 4

Thread: Ugly fonts under Wayland

  1. #1

    Default Ugly fonts under Wayland

    I have a fairly recent installation of Microos/KDE.

    Everything seems to be running nicely under Wayland, with one exception: in most (but not all) applications, I have very ugly fonts. To demonstrate this, I have added to screen captures: on with the LibreOffice writer menu bar under Wayland and one with the same bar under X11.

    With Wayland: https://www.dropbox.com/s/z12pohrpl2...aland.png?dl=0
    Wit X11: https://www.dropbox.com/s/ds1tqup5y9mpvos/X11.png?dl=0

    It may be relevant to know that, as I am using Microos, my applications are installed via Flatpak.

    Any suggestion on how I can improve the situation with Wayland so that I can switch completely to Wayland?

    May thanks in advance.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,953

    Question Re: Ugly fonts under Wayland

    Quote Originally Posted by kdvgent View Post
    I have a fairly recent installation of Microos/KDE.
    Do you mean the openSUSE MicroOS? – https://microos.opensuse.org/
    Quote Originally Posted by kdvgent View Post
    It may be relevant to know that, as I am using Microos, my applications are installed via Flatpak.
    Looking at the openSUSE MicroOS Portal – <https://en.opensuse.org/Portal:MicroOS> – I was unsure if, Flatpak is a good way to go but, the “openSUSE MicroOS as a desktop” entry on GitHub <https://opensuse.github.io/openSUSE-...tting_started/> indicates that, Flatpak is the recommend method for application installation …
    • Please note the warning at the top of the GitHub page.

    Possibly, a couple of Wayland font related packages are missing – which could be tricky to fix given, the philosophy taken during the design of openSUSE MicroOS.

    You may have to submit an openSUSE MicroOS Bug Report via the main Web Page – <https://microos.opensuse.org/> – it's a specific section of the openSUSE Bugzilla – login is the same as for this Forum.

  3. #3

    Default Re: (Resolved) Ugly fonts under Wayland

    Thank you very much for your help.

    I have indeed read that the KDE branch of the MicroOS desktop version is not actively maintained. But I took my chances (MicroOS is based on Tumbleweed and I have very good experiences with the KDE version of Tumbleweed) and mostly, things are OK. I had to install a few packages via pkcon and to use occasionally tukit. Examples are the installation of HPLIP and the configuration of my printer and setting up the connection to some network drive. The latter one very likely can also be done completely at the user level, but I have not (yet) figured out how.

    I kept looking for clues on how to solve the issue of the ugly fonts in flatpak, but the closest thing to a possible solution was a suggestion (https://www.reddit.com/r/Fedora/comm...n_flatpak_gtk/) on how to solve a similar problem with Kinoite (a close cousin of MicroOS).

    But yesterday I issued a "flatpak update" command that updated, between others, LibreOffice. And, to my surprise, when I switched back to Wayland for a last check before trying out the suggestion I mentioned above, the issue was gone.

    So for the moment, I am perfectly happy with my MicroOS/KDE desktop.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: (Resolved) Ugly fonts under Wayland

    Quote Originally Posted by kdvgent View Post
    Thank you very much for your help.

    I have indeed read that the KDE branch of the MicroOS desktop version is not actively maintained. But I took my chances (MicroOS is based on Tumbleweed and I have very good experiences with the KDE version of Tumbleweed) and mostly, things are OK. I had to install a few packages via pkcon and to use occasionally tukit. Examples are the installation of HPLIP and the configuration of my printer and setting up the connection to some network drive. The latter one very likely can also be done completely at the user level, but I have not (yet) figured out how.

    I kept looking for clues on how to solve the issue of the ugly fonts in flatpak, but the closest thing to a possible solution was a suggestion (https://www.reddit.com/r/Fedora/comm...n_flatpak_gtk/) on how to solve a similar problem with Kinoite (a close cousin of MicroOS).

    But yesterday I issued a "flatpak update" command that updated, between others, LibreOffice. And, to my surprise, when I switched back to Wayland for a last check before trying out the suggestion I mentioned above, the issue was gone.

    So for the moment, I am perfectly happy with my MicroOS/KDE desktop.
    Thanks for the update. This may help others who come searching. If you like you can create a "how to" post to outline the above.

    https://forums.opensuse.org/forumdis...How-To-and-FAQ
    openSUSE Leap 15.4; KDE Plasma 5

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •