Results 1 to 3 of 3

Thread: Upgrade MICROOS with pkcon fails

  1. #1

    Default Upgrade MICROOS with pkcon fails

    Update: Apparently the system upgrade has happened. The error happened during cleaning up things after the upgrade. I do not know if there are any leftovers from the transactional update on my disks, but things seem to work OK.

    I have a one week old MICROOS/KDE installation. Everything works fine.

    As I saw today that there are a number of updates, I tried to upgrade my system via "sudo pkcon upgrade-system" but unfortunately, the upgrade fails.

    Getting system upgrades [ ] (0%)
    (pkcon:9039): GLib-CRITICAL **: 09:06:01.167: g_variant_new_string: assertion 'string != NULL' failed
    [=========================]
    Testing changes [=========================]
    Finished [ ] (0%)
    The following packages have to be installed:
    liblilv-0-0-0.24.10-1.8.x86_64 C library to make use of LV2 plugins
    libserd-0-0-0.30.10-2.2.x86_64 A lightweight C library for RDF syntax
    libsord-0-0-0.16.8-1.5.x86_64 A lightweight C library for storing RDF data in memory
    libsratom-0-0-0.6.8-1.3.x86_64 A library for serialising LV2 atoms to/from RDF
    pipewire-modules-0_3-0.3.42-1.1.x86_64 Modules For PipeWire, A Multimedia Framework
    The following packages have to be obsoleted:
    pipewire-modules-0.3.40-1.1.x86_64 Modules For PipeWire, A Multimedia Framework
    The following packages have to be updated:
    MicroOS-release-20211218-1335.1.x86_64 openSUSE MicroOS
    MicroOS-release-appliance-20211218-1335.1.x86_64 openSUSE MicroOS
    gstreamer-plugin-pipewire-0.3.42-1.1.x86_64 Gstreamer Plugin for PipeWire
    hplip-3.21.10-2.1.x86_64 HP's Printing, Scanning, and Faxing Software
    hplip-hpijs-3.21.10-2.1.x86_64 Printer drivers for HP printers and all-in-one devices
    hplip-sane-3.21.10-2.1.x86_64 SANE backends for HP scanners and all-in-one devices
    hwinfo-21.80-1.1.x86_64 Hardware Library
    iputils-20211215-1.1.x86_64 IPv4 and IPv6 Networking Utilities
    kernel-default-5.15.8-1.1.x86_64 The Standard Kernel
    libImath-3_1-29-3.1.3-1.1.x86_64 Vector/matrix library for OpenEXR
    libZXing1-1.2.0-2.1.x86_64 Library for processing 1D and 2D barcodes
    libblkid1-2.37.2-2.1.x86_64 Filesystem detection library
    libcolord2-1.4.5-4.1.x86_64 Library for managing color devices
    libfdisk1-2.37.2-2.1.x86_64 Filesystem detection library
    libgcrypt20-1.9.4-2.1.x86_64 The GNU Crypto Library
    libgstphotography-1_0-0-1.18.5-3.1.x86_64 GStreamer Streaming-Media Framework Plug-Ins
    libmount1-2.37.2-2.1.x86_64 Device mount library
    libncurses6-6.3.20211127-6.1.x86_64 Terminal control library
    libopenssl1_1-1.1.1l-4.1.x86_64 Secure Sockets and Transport Layer Security
    libostree-2021.6-1.1.x86_64 Git for operating system binaries
    libostree-1-1-2021.6-1.1.x86_64 Git for operating system binaries
    libp11-kit0-0.23.22-3.1.x86_64 Library to work with PKCS#11 modules
    libpango-1_0-0-1.50.1-1.1.x86_64 Library for Layout and Rendering of Text
    libpipewire-0_3-0-0.3.42-1.1.x86_64 A Multimedia Framework designed to be an audio and video server and more
    librav1e0-0.5.1+0-1.1.x86_64 AV1 encoder library
    libsensors4-3.6.0-8.1.x86_64 Hardware health monitoring library
    libsmartcols1-2.37.2-2.1.x86_64 Column-based text sort engine
    libupower-glib3-0.99.13-2.1.x86_64 Power Device Enumeration Framework - Library
    libuuid1-2.37.2-2.1.x86_64 Library to generate UUIDs
    libwireplumber-0_4-0-0.4.5-2.1.x86_64 Session / policy manager implementation for PipeWire
    libxxhash0-0.8.1-1.1.x86_64 Shared library for xxHash - a non-cryptographic hash algorithm
    login_defs-4.9-3.1.noarch The login.defs configuration file
    nano-6.0-1.1.x86_64 Pico editor clone with enhancements
    ncurses-utils-6.3.20211127-6.1.x86_64 Tools using the new curses libraries
    openssl-1_1-1.1.1l-4.1.x86_64 Secure Sockets and Transport Layer Security
    p11-kit-0.23.22-3.1.x86_64 Library to work with PKCS#11 modules
    p11-kit-tools-0.23.22-3.1.x86_64 Library to work with PKCS#11 modules -- Tools
    pam-1.5.2-5.1.x86_64 A Security Tool that Provides Authentication for Applications
    pam_unix-1.5.2-5.1.x86_64 PAM module for standard UNIX authentication
    patterns-base-base-20200505-28.1.x86_64 Base System
    patterns-base-bootloader-20200505-28.1.x86_64 Bootloader
    patterns-base-minimal_base-20200505-28.1.x86_64 Minimal Appliance Base
    patterns-base-x11-20200505-28.1.x86_64 X Window System
    pipewire-0.3.42-1.1.x86_64 A Multimedia Framework designed to be an audio and video server and more
    pipewire-alsa-0.3.42-1.1.x86_64 PipeWire media server ALSA support
    pipewire-pulseaudio-0.3.42-1.1.x86_64 PipeWire PulseAudio implementation
    pipewire-spa-plugins-0_2-0.3.42-1.1.x86_64 Plugins For PipeWire SPA
    pipewire-spa-tools-0.3.42-1.1.x86_64 The PipeWire SPA Tools
    pipewire-tools-0.3.42-1.1.x86_64 The PipeWire Tools
    polkit-default-privs-1550+20211214.daf2765-1.1.noarch SUSE PolicyKit default permissions
    runc-1.1.0~rc1-1.1.x86_64 Tool for spawning and running OCI containers
    shadow-4.9-3.1.x86_64 Utilities to Manage User and Group Accounts
    terminfo-base-6.3.20211127-6.1.x86_64 A terminal descriptions database
    typelib-1_0-Pango-1_0-1.50.1-1.1.x86_64 Introspection bindings for pango, a library for text layout and rendering
    upower-0.99.13-2.1.x86_64 Power Device Enumeration Framework
    util-linux-2.37.2-2.1.x86_64 A collection of basic system utilities
    util-linux-systemd-2.37.2-2.1.x86_64 A collection of basic system utilities
    wireplumber-0.4.5-2.1.x86_64 Session / policy manager implementation for PipeWire
    wireplumber-audio-0.4.5-2.1.x86_64 Session / policy manager implementation for PipeWire (audio support)
    xen-libs-4.16.0_02-2.1.x86_64 Xen Virtualization: Libraries
    xfsprogs-5.14.2-1.1.x86_64 Utilities for managing the XFS file system
    xorg-x11-server-21.1.2-1.1.x86_64 X
    xorg-x11-server-Xvfb-21.1.2-1.1.x86_64 Virtual Xserver Xvfb
    yast2-logs-4.4.30-1.1.x86_64 Scripts for handling YAST logs
    Proceed with changes? [N/y] y

    [=========================]
    Getting system upgrades [ ] (0%)
    (pkcon:9039): GLib-CRITICAL **: 09:06:26.141: g_variant_new_string: assertion 'string != NULL' failed
    [=========================]
    Querying [=========================]
    Downloading packages [=========================]
    Requesting data [=========================]
    Testing changes [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Installing packages [=========================]
    Installing updates [=========================]
    Cleaning up packages [=========================]
    Finished [=========================]
    Fatal error: Error removing file /var/cache/PackageKit/[Invalid UTF-8]/metadata/repo-oss-[Invalid UTF-8]-x86_64/packages/liblilv-0-0-0.24.10-1.8.x86_
    64.rpm: No such file or directory

    Any suggestions?

    Many thanks in advance.

    Last edited by kdvgent; 20-Dec-2021 at 01:29. Reason: Problem "solved"

  2. #2
    Join Date
    Sep 2012
    Posts
    7,855

    Default Re: Upgrade MICROOS with pkcon fails

    Quote Originally Posted by kdvgent View Post
    Code:
    [=========================] Getting system upgrades [ ] (0%) (pkcon:9039): GLib-CRITICAL **: 09:06:26.141: g_variant_new_string: assertion 'string != NULL' failed [=========================] Querying [=========================] Downloading packages [=========================] Requesting data [=========================] Testing changes [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Installing packages [=========================] Installing updates [=========================] Cleaning up packages [=========================] Finished [=========================]

    As far as I can tell, updates have been installed.
    Code:
    Fatal error: Error removing file /var/cache/PackageKit/[Invalid UTF-8]/metadata/repo-oss-[Invalid UTF-8]-x86_64/packages/liblilv-0-0-0.24.10-1.8.x86_
    64.rpm: No such file or directory

    Is it literal output? Check your repository names, may be you do have invalid characters?

  3. #3

    Default Re: Upgrade MICROOS with pkcon fails

    Yes, the updates were applied.

    My repos:

    # zypper lr -u
    Repository priorities are without effect. All enabled repositories share the same priority.

    # | Alias | Name | Enabled | GPG Check | Refresh | URI
    --+-----------------------------+-----------------------------+---------+-----------+---------+------------------------------------------------------
    --------------------
    1 | openSUSE-MicroOS-20211214-0 | openSUSE-MicroOS-20211214-0 | No | ---- | ---- | hd:/?device=/dev/disk/by-id/usb-SanDisk_Cruzer_224282
    0C9FC0F962-0:0-part2
    2 | repo-debug | openSUSE-Tumbleweed-Debug | No | ---- | ---- | http://download.opensuse.org/debug/tumbleweed/repo/os
    s/
    3 | repo-non-oss | openSUSE-Tumbleweed-Non-Oss | Yes | ( p) Yes | Yes | http://download.opensuse.org/tumbleweed/repo/non-oss/
    4 | repo-oss | openSUSE-Tumbleweed-Oss | Yes | ( p) Yes | Yes | http://download.opensuse.org/tumbleweed/repo/oss/
    5 | repo-source | openSUSE-Tumbleweed-Source | No | ---- | ---- | http://download.opensuse.org/source/tumbleweed/repo/o
    ss/
    6 | repo-update | openSUSE-Tumbleweed-Update | Yes | ( p) Yes | Yes | http://download.opensuse.org/update/tumbleweed/

    Maybe I should remove the first repo (the USB stick I used for the installation)?

    Thanks for helping.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •