Page 3 of 3 FirstFirst 123
Results 21 to 29 of 29

Thread: 2nd Monitor Shutoff upon grub to Leap on During Boot

  1. #21
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,968
    Blog Entries
    1

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by linuxvinh View Post
    it seems like kernel updates toggle on/off DC by default, so perhaps amdgpu.dc was 0 before and a recent update toggled it to 1.
    That sounds exactly right. Looking at https://en.wikipedia.org/wiki/List_o...ocessing_units I was able to translate Hawaii PRO 290 to a Radeon R5/R7/R9 200 series device using GCN2, while most others of the series are either GCN2 or Terascale. I remember reading a discussion a while back in a bug report or the factory mailing list that the AMD driver developers were wanting to deprecate or remove support for GCN 1 & 2 from the amdgpu driver. It wouldn't surprise me if that didn't happen, and instead, amdgpu.dc default was changed to enabled, leaving users of older products to need to explicitly disable it.

    Next time you need to discuss a graphics problem, please provide a device ID instead of or in addition to a description. This can be done several ways:
    • inxi -Gay
    • inxi -Ga
    • inxi -Gxxy
    • inxi -Gxx
    • inxi -Gxxxy
    • inxi -Gxxx
    • lspci -nnk | grep -A3 VGA
    The inxi -y option produces better formatting, but isn't available in Leap's ancient inxi version unless inxi is first run with the -U switch to upgrade it.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  2. #22

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by mrmazda View Post
    That sounds exactly right. Looking at https://en.wikipedia.org/wiki/List_o...ocessing_units I was able to translate Hawaii PRO 290 to a Radeon R5/R7/R9 200 series device using GCN2, while most others of the series are either GCN2 or Terascale. I remember reading a discussion a while back in a bug report or the factory mailing list that the AMD driver developers were wanting to deprecate or remove support for GCN 1 & 2 from the amdgpu driver. It wouldn't surprise me if that didn't happen, and instead, amdgpu.dc default was changed to enabled, leaving users of older products to need to explicitly disable it.

    Next time you need to discuss a graphics problem, please provide a device ID instead of or in addition to a description. This can be done several ways:
    • inxi -Gay
    • inxi -Ga
    • inxi -Gxxy
    • inxi -Gxx
    • inxi -Gxxxy
    • inxi -Gxxx
    • lspci -nnk | grep -A3 VGA

    The inxi -y option produces better formatting, but isn't available in Leap's ancient inxi version unless inxi is first run with the -U switch to upgrade it.
    Thank you, @mrmazda!

    In the interest of completeness and in case someone finds this thread...

    Code:
    % inxi -Ga 
    Graphics:
      Device-1: AMD Hawaii PRO [Radeon R9 290/390] vendor: XFX Pine  
      driver: amdgpu v: 5.9.20.21.10 bus ID: 0a:00.0 chip ID: 1002:67b1  
      Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: amdgpu,ati  
      unloaded: fbdev,modesetting,vesa display ID: :0 screens: 1  
      Screen-1: 0 s-res: 4480x1440 s-dpi: 96 s-size: 1185x381mm (46.7x15.0")  
      s-diag: 1245mm (49")  
      Monitor-1: HDMI-A-0 res: 1920x1200 hz: 60 dpi: 94  
      size: 518x324mm (20.4x12.8") diag: 611mm (24.1")  
      Monitor-2: DVI-D-1 res: 2560x1440 hz: 60 dpi: 109  
      size: 597x336mm (23.5x13.2") diag: 685mm (27")  
      OpenGL:renderer: AMD Radeon R9 200 Series  
      v: 4.5.14735 Core Profile Context 21.10 compat-v: 4.6.14735  
      direct render: Yes
    
    Code:
    % inxi -Gxxx 
    Graphics:
      Device-1: AMD Hawaii PRO [Radeon R9 290/390] vendor: XFX Pine  
      driver: amdgpu v: 5.9.20.21.10 bus ID: 0a:00.0 chip ID: 1002:67b1  
      Display: x11 server: X.Org 1.20.3 compositor: kwin_x11 driver: amdgpu,ati  
      unloaded: fbdev,modesetting,vesa resolution:1: 1920x1200~60Hz  
      2: 2560x1440~60Hz s-dpi: 96  
      OpenGL:renderer: AMD Radeon R9 200 Series  
      v: 4.5.14735 Core Profile Context 21.10 compat-v: 4.6.14735  
      direct render: Yes
    
    Code:
    # lspci -nnk|grep -A3 VGA 
    0a:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Hawaii PRO [Radeon R9 290/390] [1002:67b1] 
            Subsystem: XFX Pine Group Inc. Device [1682:9295] 
            Kernel driver in use: amdgpu 
            Kernel modules: radeon, amdgpu
    

  3. #23

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by mrmazda View Post
    That sounds exactly right. Looking at https://en.wikipedia.org/wiki/List_o...ocessing_units I was able to translate Hawaii PRO 290 to a Radeon R5/R7/R9 200 series device using GCN2, while most others of the series are either GCN2 or Terascale. I remember reading a discussion a while back in a bug report or the factory mailing list that the AMD driver developers were wanting to deprecate or remove support for GCN 1 & 2 from the amdgpu driver. It wouldn't surprise me if that didn't happen, and instead, amdgpu.dc default was changed to enabled, leaving users of older products to need to explicitly disable it.
    Support for GCN 1 & 2 in amdgpu driver is still experimental. So user needs some tinkering for it.
    User may stay with default Radeon driver.

  4. #24
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,968
    Blog Entries
    1

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by Svyatko View Post
    Support for GCN 1 & 2 in amdgpu driver is still experimental.
    Mageia apparently doesn't think so:
    https://bugs.mageia.org/show_bug.cgi?id=28154#c105
    The amdgpu driver has been around too long, and the GCN 1 & 2 cards have been around too long, to believe there will further development directed specifically at those old GPUs. It's unlikely developers are using those old cards any more, which would leave it up to users to discover any problems, and report them to developers who may provide corrective patches. That's the only sense in which "experimental" may apply. The amdgpu driver works fine on my GCN 1 & 2 GPUs.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  5. #25

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by mrmazda View Post
    Mageia apparently doesn't think so:
    https://bugs.mageia.org/show_bug.cgi?id=28154#c105
    The amdgpu driver has been around too long, and the GCN 1 & 2 cards have been around too long, to believe there will further development directed specifically at those old GPUs. It's unlikely developers are using those old cards any more, which would leave it up to users to discover any problems, and report them to developers who may provide corrective patches. That's the only sense in which "experimental" may apply. The amdgpu driver works fine on my GCN 1 & 2 GPUs.
    AFAIK VGA output is not supported with amdgpu for GCN 1 & 2. AMD removes from support pre-GCN4 chips.
    "Experimental feature" means here "AMD managers refuse to take responsibility for amdgpu + GCN 1 & 2".

  6. #26
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,968
    Blog Entries
    1

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by Svyatko View Post
    AFAIK VGA output is not supported with amdgpu for GCN 1 & 2. AMD removes from support pre-GCN4 chips.
    I wasn't aware. I guess I hadn't tried plugging a VGA cable into a Kaveri until I saw this.
    Code:
    # inxi -GSayz
    System:
      Kernel: 5.3.18-59.27-default x86_64 bits: 64 compiler: gcc v: 7.5.0
        parameters: BOOT_IMAGE=/boot/vmlinuz root=LABEL=<filter> noresume
        ipv6.disable=1 net.ifnames=0 mitigations=auto consoleblank=0 5
        radeon.cik_support=0 amdgpu.cik_support=1 video=1440x900@60 debug rd.debug
      Desktop: Trinity R14.0.10 tk: Qt 3.5.0 info: kicker wm: Twin 3.0 vt: 7
        dm: TDM Distro: openSUSE Leap 15.3
    Graphics:
      Device-1: AMD Kaveri [Radeon R7 Graphics] vendor: ASRock driver: amdgpu
        v: kernel alternate: radeon bus-ID: 00:01.0 chip-ID: 1002:1313
        class-ID: 0300
      Display: x11 server: X.Org 1.20.3 driver: loaded: amdgpu,ati
        unloaded: fbdev,modesetting,vesa display-ID: :0 screens: 1
      Screen-1: 0 s-res: 2560x3720 s-dpi: 120 s-size: 541x787mm (21.3x31.0")
        s-diag: 955mm (37.6")
      Monitor-1: DVI-D-0 res: 1920x1200 hz: 60 dpi: 94
        size: 519x324mm (20.4x12.8") diag: 612mm (24.1")
      Monitor-2: DisplayPort-0 res: 2560x1440 hz: 60 dpi: 109
        size: 598x336mm (23.5x13.2") diag: 686mm (27")
      Monitor-3: HDMI-A-0 res: 2560x1080 hz: 60 dpi: 97
        size: 673x284mm (26.5x11.2") diag: 730mm (28.8")
      OpenGL: renderer: AMD KAVERI (DRM 3.39.0 5.3.18-59.27-default LLVM 11.0.1)
        v: 4.6 Mesa 20.2.4 direct render: Yes
    #
    Xorg goes nuts if I try to substitute a VGA cable for any of the others, no matter what I have or not on the Grub linu line. Xorg reports a connection to the VGA, but nothing gets output to the VGA display, and the modes of the others get dropped to 1024x768. VGA all by itself connected produces a PC that can only be used by remote login.
    "Experimental feature" means here "AMD managers refuse to take responsibility for amdgpu + GCN 1 & 2".
    Understandable, based on my observation. After all, the amdgpu drivers were designed for non-antique GPUs, while analog video output has long been proven inferior to digital. It's been included on some newer PCs only for backward compatibility with ancient displays.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  7. #27
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,968
    Blog Entries
    1

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by mrmazda View Post
    Xorg goes nuts if I try to substitute a VGA cable for any of the others, no matter what I have or not on the Grub linu line.
    I have a second Kaveri Radeon R7 PC. It's happy to use VGA, but refuses to use both HDMI and DVI at the same time:
    Code:
    # inxi -GMSayz
    System:
      Kernel: 5.3.18-150300.59.49-default x86_64 bits: 64 compiler: gcc v: 7.5.0
        parameters: BOOT_IMAGE=/boot/vmlinuz root=LABEL=<filter> noresume
        ipv6.disable=1 net.ifnames=0 mitigations=auto consoleblank=0
        radeon.cik_support=0 amdgpu.cik_support=1
      Desktop: Trinity R14.0.11 tk: Qt 3.5.0 info: kicker wm: Twin 3.0 vt: 7
        dm: TDM Distro: openSUSE Leap 15.3
    Machine:
      Type: Desktop Mobo: ASUSTeK model: A88X-PRO v: Rev X.0x serial: <filter>
        UEFI: American Megatrends v: 2603 date: 03/10/2016
    Graphics:
      Device-1: AMD Kaveri [Radeon R7 Graphics] vendor: ASUSTeK driver: amdgpu
        v: kernel alternate: radeon ports: active: DP-1,DVI-D-1,VGA-1 empty: none
        bus-ID: 00:01.0 chip-ID: 1002:130f class-ID: 0300
      Display: x11 server: X.Org v: 1.20.3 driver: X: loaded: amdgpu gpu: amdgpu
        display-ID: :0 screens: 1
      Screen-1: 0 s-res: 2560x3390 s-dpi: 120 s-size: 541x717mm (21.3x28.2")
        s-diag: 898mm (35.4")
      Monitor-1: DVI-D-0 mapped: DVI-D-1 pos: middle model: Dell P2012H
        serial: <filter> built: 2012 res: 1600x900 hz: 60 dpi: 92 gamma: 1.2
        size: 443x249mm (17.4x9.8") diag: 508mm (20") ratio: 16:9 modes:
        max: 1600x900 min: 720x400
      Monitor-2: DisplayPort-0 mapped: DP-1 pos: primary,bottom
        model: Acer K272HUL serial: <filter> built: 2018 res: 2560x1440 hz: 60
        dpi: 109 gamma: 1.2 size: 598x336mm (23.5x13.2") diag: 686mm (27")
        ratio: 16:9 modes: max: 2560x1440 min: 720x400
      Monitor-3: VGA-0 mapped: VGA-1 pos: primary,top model: Lenovo L2251x Wide
        serial: <filter> built: 2011 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
        size: 474x296mm (18.7x11.7") diag: 559mm (22") ratio: 16:10 modes:
        max: 1680x1050 min: 720x400
      OpenGL:
        renderer: AMD KAVERI (DRM 3.39.0 5.3.18-150300.59.49-default LLVM 11.0.1)
        v: 4.6 Mesa 20.2.4 direct render: Yes
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

  8. #28

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by mrmazda View Post
    I have a second Kaveri Radeon R7 PC. It's happy to use VGA, but refuses to use both HDMI and DVI at the same time:
    Try to use Carrizo APU - AVX2, GCN3, etc.: https://www.asus.com/microsite/mb/carrizo/
    https://en.wikipedia.org/wiki/List_o...ocessing_units
    May help with DVI + HDMI if you need it.

  9. #29
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,968
    Blog Entries
    1

    Default Re: 2nd Monitor Shutoff upon grub to Leap on During Boot

    Quote Originally Posted by Svyatko View Post
    The BIOS is newer than that listed, but $58 is a lot to spend on a test box with a flaky motherboard. New the A8-7680 is $137. I can still use 3 displays at once with it, just one must be on VGA, one on DisplayPort, and one on either HDMI or DVI. It's intriguing to think about, but I have 3 newer PCs with correspondingly newer CPUs/IGPs that support DP, HDMI & DVI all at once: G4600 (2017), I3-7100T (2017) & I5-11400 (2021), besides the Kaveri in post #26.
    Reg. Linux User 211409 *** multibooting since 1992
    Primary: 15.3, TW, 15.1 & 13.1 on Haswell @earthlink.net
    Secondary: eComStation (OS/2) &15.2 on i965P/Radeon
    Tertiary: Debian, Fedora, Mageia, more on Rocket Lake & older Intel, AMD, NVidia....

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •