Page 1 of 8 123 ... LastLast
Results 1 to 10 of 74

Thread: Sound stopped working

  1. #1

    Default Sound stopped working

    Hello, I'm running Tumbleweed with kernel 5.14.14-2-default with the KDE spin. My problem is that sound stopped working. As far as I can tell it stopped when recovering from a problematic pipewire update. I dual boot other linux systems and spimd works on them.


    When I initially had the problem, yast showed that there was no driver for the sound card. I used yast to fix that and now it is showing devices with drivers.


    The KDE sound applet shows an error message of "No output or input devices found."


    Looking at other forum entries, I see the following:
    Code:
    bopper:/home/jc # zypper se -si pulse pipe
    Loading repository data...
    Reading installed packages...
    
    
    
    S  | Name                       | Type    | Version                           | Arch   | Repository
    ---+----------------------------+---------+-----------------------------------+--------+-----------------------------
    i  | alsa-plugins-pulse-32bit   | package | 1.2.5-1.2                         | x86_64 | Main Repository (OSS)
    i  | alsa-plugins-pulse-32bit   | package | 1.2.5-1.2                         | x86_64 | openSUSE:Tumbleweed
    i  | gstreamer-plugin-pipewire  | package | 0.3.39-2.3                        | x86_64 | packman
    i  | gstreamer-plugin-pipewire  | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | libpipeline1               | package | 1.5.3-1.5                         | x86_64 | Main Repository (OSS)
    i+ | libpipeline1               | package | 1.5.3-1.5                         | x86_64 | openSUSE:Tumbleweed
    i+ | libpipewire-0_3-0          | package | 0.3.39-2.3                        | x86_64 | packman
    i+ | libpipewire-0_3-0          | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i  | libpipewire-0_3-0-32bit    | package | 0.3.39-2.3                        | x86_64 | packman
    i  | libpipewire-0_3-0-32bit    | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | libpulse-mainloop-glib0    | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
    i+ | libpulse-mainloop-glib0    | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
    i+ | libpulse0                  | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
    i+ | libpulse0                  | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
    i  | libpulse0-32bit            | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
    i  | libpulse0-32bit            | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
    i+ | pipewire                   | package | 0.3.39-2.3                        | x86_64 | packman
    i+ | pipewire                   | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i  | pipewire-alsa              | package | 0.3.39-2.3                        | x86_64 | packman
    i  | pipewire-alsa              | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i  | pipewire-libjack-0_3-32bit | package | 0.3.39-2.3                        | x86_64 | packman
    i  | pipewire-libjack-0_3-32bit | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | pipewire-media-session     | package | 0.4.1+4~git20211111.e4b49a306-2.1 | x86_64 | home:X0F:branches:multimedia
    i+ | pipewire-modules           | package | 0.3.39-2.3                        | x86_64 | packman
    i+ | pipewire-modules           | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i  | pipewire-pulseaudio        | package | 0.3.39-2.3                        | x86_64 | packman
    i  | pipewire-pulseaudio        | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | pipewire-spa-plugins-0_2   | package | 0.3.39-2.3                        | x86_64 | packman
    i+ | pipewire-spa-plugins-0_2   | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | pipewire-spa-tools         | package | 0.3.39-2.3                        | x86_64 | packman
    i+ | pipewire-spa-tools         | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | pipewire-tools             | package | 0.3.39-2.3                        | x86_64 | packman
    i+ | pipewire-tools             | package | 0.3.39-2.3                        | x86_64 | Packman Repository
    i+ | pulseaudio-bash-completion | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
    i+ | pulseaudio-bash-completion | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
    i+ | pulseaudio-utils           | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
    i+ | pulseaudio-utils           | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
    i  | pulseaudio-utils-32bit     | package | 15.0-4.1                          | x86_64 | Main Repository (OSS)
    i  | pulseaudio-utils-32bit     | package | 15.0-4.1                          | x86_64 | openSUSE:Tumbleweed
    bopper:/home/jc #
    Code:
    systemctl --user list-unit-files | grep -i "pipe|pulse"
    returns nothing
    Code:
    pactl info | grep -i server
    returns
    Server String: /run/user/1000/pulse/native
    Server Protocol Version: 35
    Server Name: PulseAudio (on PipeWire 0.3.39)
    Server Version: 15.0.0
    Code:
    jc@bopper:~> systemctl --machine=bopper@localhost --user list-unit-files | grep -i "pipe|pulse" 
    Failed to connect to bus: Host is down
    Failed to list unit files: Transport endpoint is not connected
    pavucontrol shows no input or output devices.


    I'm fairly experienced with linux but have very limited current experience with opensuse and have no ideas on how to proceed. Please advise/

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: Sound stopped working

    Quote Originally Posted by featherfoot View Post
    Hello, I'm running Tumbleweed with kernel 5.14.14-2-default with the KDE spin. My problem is that sound stopped working. As far as I can tell it stopped when recovering from a problematic pipewire update. I dual boot other linux systems and spimd works on them.

    Code:
    systemctl --user list-unit-files | grep -i "pipe|pulse"
    returns nothing
    Code:
    pactl info | grep -i server
    returns
    Server String: /run/user/1000/pulse/native
    Server Protocol Version: 35
    Server Name: PulseAudio (on PipeWire 0.3.39)
    Server Version: 15.0.0
    Code:
    jc@bopper:~> systemctl --machine=bopper@localhost --user list-unit-files | grep -i "pipe|pulse" 
    Failed to connect to bus: Host is down
    Failed to list unit files: Transport endpoint is not connected
    Run the command like this (with egrep)...
    Code:
    systemctl --user list-unit-files | egrep -i "pipe|pulse"

    I'm fairly experienced with linux but have very limited current experience with opensuse and have no ideas on how to proceed. Please advise/
    I have seen similar issues reported (other distros) due to some apparent regression with pipewire-media-session, but not sure if they relate specifically to your situation.

    What does the following command return?
    Code:
    systemctl --user status pipewire
    Last edited by deano_ferrari; 15-Nov-2021 at 00:07.
    openSUSE Leap 15.4; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: Sound stopped working

    BTW, follow the sound troubleshooting advice outlined here...
    https://en.opensuse.org/SDB:Audio_troubleshooting

    Run the alsa-info.sh diagnostic script as described in the guide as well, let it upload the output to an online server, and share the URL that it provides here.
    openSUSE Leap 15.4; KDE Plasma 5

  4. #4

    Default Re: Sound stopped working

    Kind regards

    raspu

  5. #5

    Default Re: Sound stopped working

    Code:
    jc@bopper:~> systemctl --user list-unit-files | egrep -i "pipe|pulse"
    pipewire-media-session.service                                 enabled   enabled
    pipewire-pulse.service                                         disabled  disabled
    pipewire.service                                               disabled  disabled
    pipewire-pulse.socket                                          enabled   enabled
    pipewire.socket                                                enabled   enabled
    jc@bopper:~>  
    
    
    

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: Sound stopped working

    Quote Originally Posted by featherfoot View Post
    Code:
    jc@bopper:~> systemctl --user list-unit-files | egrep -i "pipe|pulse"
    pipewire-media-session.service                                 enabled   enabled
    pipewire-pulse.service                                         disabled  disabled
    pipewire.service                                               disabled  disabled
    pipewire-pulse.socket                                          enabled   enabled
    pipewire.socket                                                enabled   enabled
    jc@bopper:~>  
    
    
    
    That checks out as expected.... and the other commands/output?
    openSUSE Leap 15.4; KDE Plasma 5

  7. #7

    Default Re: Sound stopped working

    bopper:/home/jc # cat /proc/asound/version
    Advanced Linux Sound Architecture Driver Version k5.14.14-3-default.
    bopper:/home/jc # cat /proc/asound/modules
    0 snd_hda_intel
    1 snd_hda_intel
    2 snd_usb_audio
    Code:
    bopper:/home/jc # cat /proc/asound/cards
     0 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xf6080000 irq 76
     1 [Generic        ]: HDA-Intel - HD-Audio Generic
                          HD-Audio Generic at 0xf6700000 irq 78
     2 [Camera         ]: USB-Audio - USB 2.0 Camera
                          Sonix Technology Co., Ltd. USB 2.0 Camera at usb-0000:07:00.3-1, high speed
    bopper:/home/jc #
    Code:
    bopper:/home/jc # lspci | grep -i audio
    06:00.1 Audio device: NVIDIA Corporation GP107GL High Definition Audio Controller (rev a1)
    08:00.3 Audio device: Advanced Micro Devices, Inc. [AMD] Family 17h (Models 00h-0fh) HD Audio Controller
    bopper:/home/jc #
    
    

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: Sound stopped working

    That's not what was requested. From post #2...
    Code:
    systemctl --user status pipewire
    and the alsa-info.sh diagnostic utility (refer troubleshooting guide post #3).
    openSUSE Leap 15.4; KDE Plasma 5

  9. #9

    Default Re: Sound stopped working

    j
    Code:
    c@bopper:~> systemctl --user status pipewire
    Code:
     pipewire.service - PipeWire Multimedia Service
         Loaded: loaded (/usr/lib/systemd/user/pipewire.service; disabled; vendor preset: disabled)
         Active: active (running) since Wed 2021-11-17 18:04:38 EST; 1h 15min ago
    TriggeredBy:  pipewire.socket
       Main PID: 4955 (pipewire)
          Tasks: 2 (limit: 4915)
         Memory: 2.4M
            CPU: 20ms
         CGroup: /user.slice/user-1000.slice/user@1000.service/session.slice/pipewire.service
                 └─4955 /usr/bin/pipewire
    
    Nov 17 18:04:38 bopper systemd[4418]: Started PipeWire Multimedia Service.
    jc@bopper:~>
    The ALSA info output is at
    HTML Code:
    http://alsa-project.org/db/?f=15dba988cbb8561221c66cf3a28a6f67cbfc1375

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,113
    Blog Entries
    1

    Default Re: Sound stopped working

    The alsa-info.sh output suggests no obvious issues.

    FWIW, I did find this reddit thread discussing similar audio device issues as you report. It might relate to the recent "alsa-ucm-conf" regression (version 1.2.5) perhaps. Bug report...
    https://bugzilla.opensuse.org/show_bug.cgi?id=1187079
    You can check the installed version with...
    Code:
    rpm -qi alsa-ucm-conf
    openSUSE Leap 15.4; KDE Plasma 5

Page 1 of 8 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •