Results 1 to 10 of 10

Thread: Set up static IP on Wicked Service

  1. #1

    Default Set up static IP on Wicked Service

    I am struggling to set up a static IP on Wicked Service, which is required in the steps to complete this guide (as it provides ifup).

    When I change to Wicked from NetworkManager and set a dynamic IP address, the wifi connects and I am able to access the internet. This is not the case when I set a static IP. I chose the same IP as the output from:
    Code:
    nmcli dev show wlo1
    
    and used that subnet mask (all from IPv4). Output from
    Code:
    sudo ifup wlo1
    returns a status of up for both dynamic and static IP addresses.

    Where could I be going wrong? Also, the network and sharing icon is no longer visible on the KDE taskbar after the switch to Wicked.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,943

    Default Re: Set up static IP on Wicked Service

    Hello and welcome to the openSUSE forums.

    Please when do allways (of course whenever possible) what you computer shows. So when youi say you do
    Code:
    sudi ifup wlo1
    then we do not want to see your conclusion, but we want to see the unabridged and unaltered output. Including the prompt/command line, the output and the next prompt line.

    Then when you are using wicked, you are not using NetworkManager, thus you can not expect that NM shows the user useful (if any ) icons on his/her desktop.

    Next is a standard way of attacking network problems (all to be done as root of couse).
    ===================
    You check from bottom to top:

    1. Is the NIC up with an IP address?
      Code:
      ip addr
    2. Can you connect to another system on your LAN?
      Code:
      ping -c1 <IP-address of your router>
      (I hope you know that address)
    3. Do you have a default route to the Internet?
      Code:
      ip route
      and/or
      Code:
      ip -6 route
    4. Can you connect to a system on the internet?
      Code:
      ping -c1 195.135.221.161
      and/or
      Code:
      ping -c1 2001:67c:2178:8::161
    5. Can you resolve host/domain names?
      Code:
      ping -c1 forums.opensuse.org


    Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.

    So start with 1. and do not hesitate to post the output here to get help on the interpretation.
    Henk van Velden

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,944

    Default Re: Set up static IP on Wicked Service

    Quote Originally Posted by siya View Post
    Also, the network and sharing icon is no longer visible on the KDE taskbar after the switch to Wicked.
    Right-Click the KDE Plasma System Tray arrow on the Panel – choose the setup – check if the entry for Network has been deactivated.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,943

    Default Re: Set up static IP on Wicked Service

    I may add that when you say you used the same IP address as was used when using NetworkManager, that might not be a good idea. When you used (with NM) HDCP, you got the IP address from the pool of the DHCP server (probably your router). You can not use that address as a fixed address, because that may clash when your router gives that address to another system in your LAN. You must choose a fixed P address inside the subnet, but outside the pool of the DHCP server.
    Henk van Velden

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,944

    Exclamation Re: Set up static IP on Wicked Service

    Quote Originally Posted by siya View Post
    I am struggling to set up a static IP on Wicked Service, which is required in the steps to complete this guide (as it provides ifup).
    You seem to have a WLAN (WiFi) interface – wlo1 – please check that, you have the “iw” and “wireless-tools” package installed.
    • Please note that, the package “iw” contains the tools needed to manage wireless devices supported by the current Linux Kernel –

    Code:
        iw is a nl80211 based CLI configuration utility for wireless devices. It
        supports almost all new drivers that have been added to the kernel
        recently.
    • The “wireless-tools” package contains tools which are being deprecated.

    The advice you need is in this openSUSE SDB: <https://en.opensuse.org/SDB:WiFi> and, this section <https://en.opensuse.org/SDB:WiFi#How...NetworkManager>.
    • Please note that, this SDB uses the deprecated tools.

    The syntax of the “iw” command is here – <https://wireless.wiki.kernel.org/en/...cumentation/iw>.

  6. #6

    Default Re: Set up static IP on Wicked Service

    Quote Originally Posted by hcvv View Post
    Hello and welcome to the openSUSE forums.

    Please when do allways (of course whenever possible) what you computer shows. So when youi say you do
    Code:
    sudi ifup wlo1
    then we do not want to see your conclusion, but we want to see the unabridged and unaltered output. Including the prompt/command line, the output and the next prompt line.

    Then when you are using wicked, you are not using NetworkManager, thus you can not expect that NM shows the user useful (if any ) icons on his/her desktop.

    Next is a standard way of attacking network problems (all to be done as root of couse).
    (redacted)
    Thank you. The output for
    Code:
    sudo ifup wlo1
    is
    Code:
    wlo1            up
    
    I opened up the ifcfg-wlo1 file and got output of
    Code:
    IPADDR='[IP ADDRESS]/21'
    BOOTPROTO='static'
    STARTMODE='auto'
    WIRELESS_ESSID='[SSID]'
    WIRELESS_AUTH_MODE='eap'
    WIRELESS_MODE='managed'
    WIRELESS_WPA_PASSWORD='[PASSWORD]'
    WIRELESS_WPA_IDENTITY='[IDENTITY]'
    WIRELESS_CA_CERT=''
    WIRELESS_EAP_MODE='PEAP'
    WIRELESS_EAP_AUTH='mschapv2'
    WIRELESS_AP_SCANMODE='1'
    output for 1 is:
    Code:
    3: wlo1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
        link/ether [LINK] brd ff:ff:ff:ff:ff:ff
        altname wlp3s0
        inet [IP ADDR]/21 brd [ADDR] scope global wlo1
           valid_lft forever preferred_lft forever
        inet6 [IP ADDR]/64 scope link  
           valid_lft forever preferred_lft forever
    
    I do not know the address of the router.

    output for 3 is:
    Code:
    [IP ADDR]/16 dev docker0 proto kernel scope link src [IP ADDR] linkdown  
    [IP ADDR]/21 dev wlo1 proto kernel scope link src [IP ADDR]
    
    output for 4 is:
    Code:
    ping: connect: Network is unreachable
    
    output for 5 is:
    Code:
    ping: forums.opensuse.org: Name or service not known
    
    I've got no idea what a lot of these mean.

  7. #7
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,943

    Default Re: Set up static IP on Wicked Service

    The recipe says:
    Take care. As soon a one step fails, that must be resolved first. It is useless to go to the next step before it is resolved.
    So at least half of what you post is only confusing!

    Then, I asked to include the prompt/command line and the new prompt line together with the output. No again we have bits and pieces without context.
    So not:
    ==============
    THis is the output youi asked at number 6
    Code:
    some output
    ==============
    but
    ==============
    Code:
    boven:~ # ip addr
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether ec:8e:b5:da:0d:0d brd ff:ff:ff:ff:ff:ff
        inet 10.0.0.154/24 brd 10.0.0.255 scope global eth0
           valid_lft forever preferred_lft forever
        inet6 2001:980:91a0:1:ee8e:b5ff:feda:d0d/64 scope global dynamic mngtmpaddr noprefixroute 
           valid_lft 4091sec preferred_lft 3121sec
        inet6 fe80::ee8e:b5ff:feda:d0d/64 scope link 
           valid_lft forever preferred_lft forever
    3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
        link/ether 94:e9:79:76:e6:cd brd ff:ff:ff:ff:ff:ff
    boven:~ #
    Henk van Velden

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,943

    Default Re: Set up static IP on Wicked Service

    And when you do not even know the address of your router, you probably have not filled it then in in YaST > Network Settings when defining your default gateway. Thus you have no route to go outside your LAN.
    And did you fill in de DNS server part of the Network Settings Configuration?

    Then you seem to worry about someone seeing the IP address you use. This will make the discussion pretty difficult. When we talk about the IP address you used and you ten say [ADDRESS] and when you the talk about the adddress of the router and call that again [ADDRESS}, we are stuck.
    Is that really so vulnerable?

    I have the idea that you did not fill in half of what is needed (and that maybe wrong). As long as you only say that you tried to configure your system with a fixed IP address using wicked in YaST, but without any deatail, we, that can not look over your shoulder, are pretty helpless in trying to help.
    Last edited by hcvv; 29-Nov-2021 at 04:19.
    Henk van Velden

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,944

    Cool Re: Set up static IP on Wicked Service

    Quote Originally Posted by siya View Post
    I do not know the address of the router.
    Then, setup with DHCP to query the IP addresses of the Router – if it's a fairly modern Router, normally there will an IPv6 and an IPv4 address assigned to the Router …
    • But, beware – it may well be that, the Router's IP addresses will change over time – which is why modern systems setup with DHCP …

  10. #10
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,944

    Talking Re: Set up static IP on Wicked Service

    Quote Originally Posted by hcvv View Post
    Then you seem to worry about someone seeing the IP address you use.
    We haven't asked siya if she or he has enabled WiFi (WLAN) encryption and, even more important, which encryption …
    • For any given WLAN (WiFi), only the SSID is visible – the IP address is only obtainable when a connection is attempted and, a DHCP query is executed.
    • And, if “Use only known MAC addresses” is enabled at the Router, attempts to gain access to the WLAN by unknown parties will fail …
    • MAC – “Media Access Control” …

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •