Results 1 to 5 of 5

Thread: HPLIP No Longer Works on 15.3

  1. #1

    Unhappy HPLIP No Longer Works on 15.3

    I hadn't printed anything since I upgraded from 15.2 a couple weeks ago. Tonight I decided to print some documents. The printer is an HP Deskjet 2755 Printer, which worked fine under 15.2, including the scanner.

    I attempted to print an image of a document from Gwenview. The document went to the printer queue, but did not print. Examining the printer queue, I see it said "Paused - rendering complete". I had no idea why it paused, this never happened before.

    I clicked the arrow button for resume printing. Instead of printing, I get a prompt saying that Cups requires authentication and asking for my user password. I entered that and closed the popup. Nothing happened. I click the arrow button again and this time I get the same password prompt, but it wants the root password.

    I search all over hell on Google - nothing about this behavior.

    I find the HP instructions on installing Hplip and notice that they say the user has to be added to the lp and sys groups. So I do that - except there is no sys group in openSUSE Leap 15.3.

    I go to the Opensuse page on installing an HP printer. It references hp-setup and hp-plugin. I run hp-setup: it gives me a traceback and says "ImportError: libcrypto.so.43: cannot open shared object file: No such file or directory".

    So now I have a printer that accepts print jobs but can't print.

    What can I do to fix this?


  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: HPLIP No Longer Works on 15.3

    Can you show us the output from
    Code:
    zypper se -s hplip libcrypto
    openSUSE Leap 15.4; KDE Plasma 5

  3. #3

    Thumbs up Re: HPLIP No Longer Works on 15.3

    OK, I fixed it myself. I ripped out the existing Hplip which was hplip-3.20.11. I installed the openSUSE version I found on openSUSE Software which was allegedly for 15.3, but that didn't help. So I downloaded the SUSE 15.3 3.21.10 version from the HP site. Reinstalling that using HP's automatic install worked OK - it even uninstalled the openSUSE version of hplip. I then had to go into Yast Printers and select the new driver over the old one and check the "enable printing" box which was unchecked (which I find weird.)

    Now everything prints as it used to, with no prompts for passwords. hp-check runs and finds no errors or warnings. Scanner works, too.

    So for anyone having issues with hplip, I'd suggest getting the latest SUSE 15.3 version from the HP site. Don't bother with the openSUSE software.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    24,120
    Blog Entries
    1

    Default Re: HPLIP No Longer Works on 15.3

    Quote Originally Posted by dickhack View Post
    OK, I fixed it myself. I ripped out the existing Hplip which was hplip-3.20.11. I installed the openSUSE version I found on openSUSE Software which was allegedly for 15.3, but that didn't help. So I downloaded the SUSE 15.3 3.21.10 version from the HP site. Reinstalling that using HP's automatic install worked OK - it even uninstalled the openSUSE version of hplip. I then had to go into Yast Printers and select the new driver over the old one and check the "enable printing" box which was unchecked (which I find weird.)

    Now everything prints as it used to, with no prompts for passwords. hp-check runs and finds no errors or warnings. Scanner works, too.

    So for anyone having issues with hplip, I'd suggest getting the latest SUSE 15.3 version from the HP site. Don't bother with the openSUSE software.
    Thanks for the update. (There was a similar recent thread describing a similar resolution.)
    openSUSE Leap 15.4; KDE Plasma 5

  5. #5

    Default Re: HPLIP No Longer Works on 15.3

    OpenSuse 15.3 works with HPLIP 3.21.6 and newer:

    HPLIP 3.21.6 - This release has the following changes:
    Added support for following new Distro's:

    Fedora 34
    Ubuntu 21.04
    OpenSuse 15.3
    Debian 10.9
    HPLIP 3.21.10 is available with Experimental "Printing" repo: https://download.opensuse.org/reposi.../Printing.repo

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •