Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: zupper update show "The following 2 package updates will NOT be installed"

  1. #1
    Join Date
    Oct 2021
    Location
    Podunk
    Posts
    101

    Default zupper update show "The following 2 package updates will NOT be installed"

    when try update opensuse 15.3, (cinnamon 4.6.7, kernel 5.3.18-59.27-default), using next commands:

    Code:
    sudo zypper ref
    sudo zypper up
    give me next results (messages):
    Code:
    The following 8 items are locked and will not be changed by any action:
     Installed:
      kernel-firmware-nvidia libdrm_nouveau2 nvidia-computeG04 nvidia-gfxG04-kmp-default nvidia-glG04 suse-prime x11-video-nvidiaG04 xf86-video-nouveau
    
    The following 2 package updates will NOT be installed:
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang
    
    The following product update will NOT be installed:
      "openSUSE Leap 15.3"
    
    The following 7 packages are going to be upgraded:
      autoyast2-installation libjavascriptcoregtk-4_0-18 libwebkit2gtk3-lang libwebkit2gtk-4_0-37 typelib-1_0-JavaScriptCore-4_0 typelib-1_0-WebKit2-4_0
      webkit2gtk-4_0-injected-bundles
    why this happen, did that mean the distro is crashed and i need to reinstall it again?
    knowledge seeker

  2. #2
    Join Date
    Sep 2012
    Posts
    7,873

    Default Re: zupper update show "The following 2 package updates will NOT be installed"

    There was Leap respin released and it was not quite clean which explains "product update will not be installed". There should be update that fixes it. As for gstreamer, show output of
    Code:
    zypper se -xs gstreamer-plugins-ugly
    zypper lr -d

  3. #3
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    758

    Default Re: zupper update show "The following 2 package updates will NOT be installed"

    I have the some of the same issue - I suspect that the version we have installed is newer than the one that is in the repos now.
    That has happened before - an older version slipped in. - you can always force install them with zypper in -f gstreamer-plugins-ugly-lang openSUSE Leap 15.3.
    Code:
    The following package update will NOT be installed:
      gstreamer-plugins-ugly-lang
    
    The following product update will NOT be installed:
      "openSUSE Leap 15.3"
    OpenSUSE 15.4 with VirtualBox VM's (XP, 10, 11, Ubuntu MATE 22.04, Manjaro, 15.4, Tumbleweed)
    Pi4 with OpenSUSE 15.4
    Unix since 1974 (pdp-11, Interdata, AT&T, Tandy, Convergent, Sun, IBM, NCR, and HP)
    Linux since 1995 (Mandrake, Fedora, CentOS, OpenSUSE)

  4. #4
    Join Date
    Oct 2021
    Location
    Podunk
    Posts
    101

    Default Re: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by arvidjaar View Post
    There was Leap respin released and it was not quite clean which explains "product update will not be installed". There should be update that fixes it. As for gstreamer, show output of
    Code:
    zypper se -xs gstreamer-plugins-ugly
    zypper lr -d
    am new with opensuse (less than week), and do not care about last version of software (search for stable environment for daily use). so in my case is it ok if neglect updates and only run "zupper patch".

    your code output next:
    Code:
    ~> zypper se -xs gstreamer-plugins-ugly
    Loading repository data...
    Reading installed packages...
    
    S | Name                   | Type       | Version            | Arch   | Repository
    --+------------------------+------------+--------------------+--------+-------------------------------------------------------------
    i | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.2 | x86_64 | (System Packages)
    v | gstreamer-plugins-ugly | package    | 1.16.3-3.3.1       | x86_64 | Main Repository
    v | gstreamer-plugins-ugly | package    | 1.16.3-3.3.1       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.3 | x86_64 | Packman Repository
      | gstreamer-plugins-ugly | srcpackage | 1.16.3-3.3.1       | noarch | Update repository with updates from SUSE Linux Enterprise 15
      | gstreamer-plugins-ugly | srcpackage | 1.16.3-pm153.3.5.3 | noarch | Packman Repository
      | gstreamer-plugins-ugly | srcpackage | 1.16.3-pm153.3.5.2 | noarch | Packman Repository
    Code:
    ~> zypper lr -d
    #  | Alias                                 | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                     | Service
    ---+---------------------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------+--------
     1 | Atom                                  | Atom Editor                                                                                 | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://packagecloud.io/AtomEditor/atom/el/7/x86_64                                     | 
     2 | download.nvidia.com-$releasever       | nVidia Graphics Drivers                                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.3                                          | 
     3 | ftp.gwdg.de-openSUSE_Leap_$releasever | Packman Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/                      | 
     4 | openSUSE-Leap-15.3-1                  | openSUSE-Leap-15.3-1                                                                        | No      | ----      | ----    |   99     | NONE   | hd:/?device=/dev/disk/by-id/usb-Kingston_DT_microDuo_001A4D5E4020DDB40000000D-0:0-part2 | 
     5 | repo-backports-debug-update           | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/                          | 
     6 | repo-backports-update                 | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                                | 
     7 | repo-debug                            | Debug Repository                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/                     | 
     8 | repo-debug-non-oss                    | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/                 | 
     9 | repo-debug-update                     | Update Repository (Debug)                                                                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                                | 
    10 | repo-debug-update-non-oss             | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/                            | 
    11 | repo-non-oss                          | Non-OSS Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/                       | 
    12 | repo-oss                              | Main Repository                                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/                           | 
    13 | repo-sle-debug-update                 | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                                | 
    14 | repo-sle-update                       | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                                      | 
    15 | repo-source                           | Source Repository                                                                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/                    | 
    16 | repo-update                           | Main Update Repository                                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss/                                      | 
    17 | repo-update-non-oss                   | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/non-oss/                                  |
    when i just run zupper lu give me next results (did install them will solve the problem?):
    Code:
    ~> sudo zypper lu
    Loading repository data...
    Reading installed packages...
    S | Repository         | Name                         | Current Version                      | Available Version                    | Arch
    --+--------------------+------------------------------+--------------------------------------+--------------------------------------+-------
    v | Packman Repository | gstreamer-plugins-bad        | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | gstreamer-plugins-bad-lang   | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | noarch
    v | Packman Repository | gstreamer-plugins-libav      | 1.16.2-pm153.2.5                     | 1.16.2-pm153.2.6                     | x86_64
    v | Packman Repository | gstreamer-plugins-ugly       | 1.16.3-pm153.3.5.2                   | 1.16.3-pm153.3.5.3                   | x86_64
    v | Packman Repository | gstreamer-plugins-ugly-lang  | 1.16.3-pm153.3.5.2                   | 1.16.3-pm153.3.5.3                   | noarch
    v | Packman Repository | libavcodec57                 | 3.4.9-pm153.1.1                      | 3.4.9-pm153.1.2                      | x86_64
    v | Packman Repository | libavcodec58_134             | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libavfilter7_110             | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libavformat57                | 3.4.9-pm153.1.1                      | 3.4.9-pm153.1.2                      | x86_64
    v | Packman Repository | libavformat58_76             | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libavresample4_0             | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libavutil55                  | 3.4.9-pm153.1.1                      | 3.4.9-pm153.1.2                      | x86_64
    v | Packman Repository | libavutil56_70               | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libgstadaptivedemux-1_0-0    | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstbadaudio-1_0-0         | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstbasecamerabinsrc-1_0-0 | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstcodecparsers-1_0-0     | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstisoff-1_0-0            | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstmpegts-1_0-0           | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstphotography-1_0-0      | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstsctp-1_0-0             | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgsturidownloader-1_0-0    | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstwayland-1_0-0          | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libgstwebrtc-1_0-0           | 1.16.3-pm153.3.6.2                   | 1.16.3-pm153.3.6.3                   | x86_64
    v | Packman Repository | libopencore-amrnb0           | 0.1.5-pm153.1.7                      | 0.1.5-pm153.1.8                      | x86_64
    v | Packman Repository | libopencore-amrwb0           | 0.1.5-pm153.1.7                      | 0.1.5-pm153.1.8                      | x86_64
    v | Packman Repository | libpostproc55_9              | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | librtmp1                     | 2.4.20151223.fa8646d-pm153.1.9       | 2.4.20151223.fa8646d-pm153.1.10      | x86_64
    v | Packman Repository | libswresample2               | 3.4.9-pm153.1.1                      | 3.4.9-pm153.1.2                      | x86_64
    v | Packman Repository | libswresample3_9             | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libswscale4                  | 3.4.9-pm153.1.1                      | 3.4.9-pm153.1.2                      | x86_64
    v | Packman Repository | libswscale5_9                | 4.4-pm153.2.7                        | 4.4-pm153.2.8                        | x86_64
    v | Packman Repository | libvo-amrwbenc0              | 0.1.3-pm153.1.6                      | 0.1.3-pm153.1.7                      | x86_64
    v | Packman Repository | libx264-161                  | 0.161+git20200912.d198931a-pm153.2.2 | 0.161+git20200912.d198931a-pm153.2.3 | x86_64
    v | Packman Repository | libx265-199                  | 3.5-pm153.2.3                        | 3.5-pm153.2.4                        | x86_64
    v | Packman Repository | libxvidcore4                 | 1.3.7-pm153.1.6                      | 1.3.7-pm153.1.7                      | x86_64
    knowledge seeker

  5. #5
    Join Date
    Oct 2021
    Location
    Podunk
    Posts
    101

    Default Re: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by larryr View Post
    I have the some of the same issue - I suspect that the version we have installed is newer than the one that is in the repos now.
    That has happened before - an older version slipped in. - you can always force install them with zypper in -f gstreamer-plugins-ugly-lang openSUSE Leap 15.3.
    Code:
    The following package update will NOT be installed:
      gstreamer-plugins-ugly-lang
    
    The following product update will NOT be installed:
      "openSUSE Leap 15.3"
    when search about "gst-plugins-ugly Plugins" find it codecs package. and i do not have problem with media.
    i new (just start with opensuse), so i just try understand from you(English my second lang.). if we already installed new version than the one that on repos, so there's no need to use force install the old version that on repos. or if i did not install the old version that will effect badly on the distro by some how?
    knowledge seeker

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,241

    Default AW: zupper update show "The following 2 package updates will NOT be installed"

    When I update, I will get a greater packman Update:
    Code:
    .
    .
    .
    .
    .
    .
    The following 168 packages are going to be upgraded:
      aften alac_decoder alsa-plugins-dca autopano-sift-C avidemux3 avidemux3-qt5 avidemux3-qt5-lang b5i2iso ccd2iso cdi2iso cpvts crafty dcadec dcaenc discord-rpc-devel dvdbackup dvdinfo dvgrab easymp3gain
      easymp3gain-lang faac faad2 ffmpeg2theora ffmpeg-4 ffmpeg-4-libavcodec-devel ffmpeg-4-libavdevice-devel ffmpeg-4-libavfilter-devel ffmpeg-4-libavformat-devel ffmpeg-4-libavresample-devel
      ffmpeg-4-libavutil-devel ffmpeg-4-libpostproc-devel ffmpeg-4-libswresample-devel ffmpeg-4-libswscale-devel gstreamer-plugins-bad gstreamer-plugins-bad-chromaprint gstreamer-plugins-bad-devel
      gstreamer-plugins-bad-fluidsynth gstreamer-plugins-bad-lang gstreamer-plugins-bad-orig-addon gstreamer-plugins-libav gstreamer-plugins-ugly gstreamer-plugins-ugly-lang gstreamer-plugins-ugly-orig-addon
    .
    .
    .
    .

    And I have update today in the afternoon.......
    Maybe all packages are not build as you wanted to update.

    But all giving an warning:
    Code:
    Additional rpm output:
    warning: /var/cache/zypp/packages/packman/Multimedia/x86_64/ffmpeg2theora-0.30-pm153.3.5.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 1abd1afb: NOKEY
    Last edited by Sauerland; 04-Nov-2021 at 13:26.

  7. #7
    Join Date
    Sep 2012
    Posts
    7,873

    Default Re: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by naive2021 View Post
    Code:
    S | Name                   | Type       | Version            | Arch   | Repository
    --+------------------------+------------+--------------------+--------+-------------------------------------------------------------
    i | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.2 | x86_64 | (System Packages)
    v | gstreamer-plugins-ugly | package    | 1.16.3-3.3.1       | x86_64 | Main Repository
    v | gstreamer-plugins-ugly | package    | 1.16.3-3.3.1       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.3 | x86_64 | Packman Repository
    Version 1.16.3-pm153.3.5.2 is less (older) than 1.16.3-3.3.1, but two packages come from different vendor (Packman vs. SUSE). Zypper does not switch vendors by default so it informs you that it will not install "newer" version. You need to decide whether you want to keep Packman or switch to SUSE version. You can force vendor switch by using full version:
    Code:
    zypper in gstreamer-plugins-ugly.1.16.3-3.3.1

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,079

    Default Re: AW: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by Sauerland View Post
    ... But all giving an warning:
    Code:
    Additional rpm output:
    warning: /var/cache/zypp/packages/packman/Multimedia/x86_64/ffmpeg2theora-0.30-pm153.3.5.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 1abd1afb: NOKEY
    Had that on TW a week or two back.

    Fixed by deleting current key then a zypper cc and ref and accept the new packman key.
    Code:
    rpm -e gpg-pubkey-1abd1afb-54176598 && zypper cc --all && zypper ref
    There was some discussion here: https://lists.links2linux.de/piperma...er/016866.html if you follow that thread back.
    Regards, Paul

  9. #9
    Join Date
    Oct 2021
    Location
    Podunk
    Posts
    101

    Default Re: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by arvidjaar View Post
    Version 1.16.3-pm153.3.5.2 is less (older) than 1.16.3-3.3.1, but two packages come from different vendor (Packman vs. SUSE). Zypper does not switch vendors by default so it informs you that it will not install "newer" version. You need to decide whether you want to keep Packman or switch to SUSE version. You can force vendor switch by using full version:
    Code:
    zypper in gstreamer-plugins-ugly.1.16.3-3.3.1
    "1.16.3-pm153.3.5.2" older than "1.16.3-3.3.1", even the first is 3.5.2.

    i just install pack-man to get codecs (to make media works). is there's way to general set suse repos. as default vendor, without lose the codecs that come from pack-man(before backman the media did not work)?
    knowledge seeker

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,241

    Default AW: zupper update show "The following 2 package updates will NOT be installed"

    Code:
    i | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.2 | x86_64 | (System Packages)
    .
    .
    v | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.3 | x86_64 | Packman Repository
    There is an Update in Packman, so please show:
    Code:
    zypper up
    Here it was installed as shown before:
    Code:
    S  | Name                              | Type  | Version            | Arch   | Repository
    ---+-----------------------------------+-------+--------------------+--------+-----------
    i+ | gstreamer-plugins-ugly            | Paket | 1.16.3-pm153.3.5.3 | x86_64 | Packman
    i+ | gstreamer-plugins-ugly-lang       | Paket | 1.16.3-pm153.3.5.3 | noarch | Packman
    i+ | gstreamer-plugins-ugly-orig-addon | Paket | 1.16.3-pm153.3.5.3 | x86_64 | Packman

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •