Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: zupper update show "The following 2 package updates will NOT be installed"

  1. #11
    Join Date
    Oct 2021
    Location
    Podunk
    Posts
    101

    Default Re: AW: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by Sauerland View Post
    Code:
    i | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.2 | x86_64 | (System Packages)
    .
    .
    v | gstreamer-plugins-ugly | package    | 1.16.3-pm153.3.5.3 | x86_64 | Packman Repository
    There is an Update in Packman, so please show:
    Code:
    zypper up
    Here it was installed as shown before:
    Code:
    S  | Name                              | Type  | Version            | Arch   | Repository
    ---+-----------------------------------+-------+--------------------+--------+-----------
    i+ | gstreamer-plugins-ugly            | Paket | 1.16.3-pm153.3.5.3 | x86_64 | Packman
    i+ | gstreamer-plugins-ugly-lang       | Paket | 1.16.3-pm153.3.5.3 | noarch | Packman
    i+ | gstreamer-plugins-ugly-orig-addon | Paket | 1.16.3-pm153.3.5.3 | x86_64 | Packman
    output of your code is:

    Code:
    sudo zypper up
    Loading repository data...
    Reading installed packages...
    
    The following 8 items are locked and will not be changed by any action:
     Installed:
      kernel-firmware-nvidia libdrm_nouveau2 nvidia-computeG04 nvidia-gfxG04-kmp-default nvidia-glG04 suse-prime x11-video-nvidiaG04 xf86-video-nouveau
    
    The following 2 package updates will NOT be installed:
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang
    
    The following product update will NOT be installed:
      "openSUSE Leap 15.3"
    
    The following 36 packages are going to be upgraded:
      gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-libav gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libavcodec57 libavcodec58_134
      libavfilter7_110 libavformat57 libavformat58_76 libavresample4_0 libavutil55 libavutil56_70 libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0
      libgstcodecparsers-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0 libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0
      libopencore-amrnb0 libopencore-amrwb0 libpostproc55_9 librtmp1 libswresample2 libswresample3_9 libswscale4 libswscale5_9 libvo-amrwbenc0 libx264-161 libx265-199
      libxvidcore4
    
    36 packages to upgrade.
    Overall download size: 17.5 MiB. Already cached: 0 B. No additional space will be used or freed after the operation.
    Continue? [y/n/v/...? shows all options] (y): n
    so runing this update will solve the problem?
    is there's way to set suse repos. as default repo. without losing codec that i get from packman or effect on nvidia repo.?
    knowledge seeker

  2. #12
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,240

    Default AW: zupper update show "The following 2 package updates will NOT be installed"

    zypper up will not change any package to a version from another Repo.
    That why:
    Code:
    The following 2 package updates will NOT be installed:
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang
    Packages in another Repo with higher Version-Release number.......

    PS:
    You will get your update from packman:
    The following 36 packages are going to be upgraded:
    gstreamer-plugins-bad gstreamer-plugins-bad-lang gstreamer-plugins-libav gstreamer-plugins-ugly gstreamer-plugins-ugly-lang libavcodec57 libavcodec58_134
    libavfilter7_110 libavformat57 libavformat58_76 libavresample4_0 libavutil55 libavutil56_70 libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0 libgstbasecamerabinsrc-1_0-0
    libgstcodecparsers-1_0-0 libgstisoff-1_0-0 libgstmpegts-1_0-0 libgstphotography-1_0-0 libgstsctp-1_0-0 libgsturidownloader-1_0-0 libgstwayland-1_0-0 libgstwebrtc-1_0-0
    libopencore-amrnb0 libopencore-amrwb0 libpostproc55_9 librtmp1 libswresample2 libswresample3_9 libswscale4 libswscale5_9 libvo-amrwbenc0 libx264-161 libx265-199
    libxvidcore4
    You have only to accept the update.........
    Last edited by Sauerland; 04-Nov-2021 at 14:31.

  3. #13
    Join Date
    Oct 2021
    Location
    Podunk
    Posts
    101

    Default Re: AW: zupper update show "The following 2 package updates will NOT be installed"

    Quote Originally Posted by Sauerland View Post
    zypper up will not change any package to a version from another Repo.
    That why:
    Code:
    The following 2 package updates will NOT be installed:
      gstreamer-plugins-ugly gstreamer-plugins-ugly-lang
    Packages in another Repo with higher Version-Release number.......

    PS:
    You will get your update from packman:

    You have only to accept the update.........
    i just run the update, many thanks for you and for all community.

    knowledge seeker

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •