Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: The following product update will NOT be installed: "openSUSE Leap 15.3"

  1. #1

    Default The following product update will NOT be installed: "openSUSE Leap 15.3"

    Zypper update is complaining about non-updatable product. What does it mean? Tried different things with no luck: the message is completely stuck:

    The following product update will NOT be installed:
    "openSUSE Leap 15.3"


    Code:
    white-angel:~ # cat /etc/os-release  
    NAME="openSUSE Leap" 
    VERSION="15.3" 
    ID="opensuse-leap" 
    ID_LIKE="suse opensuse" 
    VERSION_ID="15.3" 
    PRETTY_NAME="openSUSE Leap 15.3" 
    ANSI_COLOR="0;32" 
    CPE_NAME="cpe:/o:opensuse:leap:15.3" 
    BUG_REPORT_URL="https://bugs.opensuse.org" 
    HOME_URL="https://www.opensuse.org/" 
    white-angel:~ # zypper up 
    Loading repository data... 
    Reading installed packages... 
    
    The following item is locked and will not be changed by any action:
     Available: 
      ibus 
    
    The following package update will NOT be installed:
      bash-lang 
    
    The following product update will NOT be installed:
      "openSUSE Leap 15.3"
    Nothing to do.
    white-angel:~ # zypper lr 
    Repository priorities in effect:                                                                                                                      (See 'zypper lr -P' for details) 
          90 (raised priority)  :  1 repository 
          99 (default priority) : 17 repositories 
    
    #  | Alias                       | Name                                                                                        | Enabled | GPG Check | Refresh 
    ---+-----------------------------+---------------------------------------------------------------------------------------------+---------+-----------+-------- 
     1 | NVIDIA                      | NVIDIA                                                                                      | Yes     | (r ) Yes  | Yes 
     2 | devel_tools_scm             | Software configuration management (openSUSE_Leap_15.3)                                      | Yes     | (r ) Yes  | Yes 
     3 | google-chrome               | google-chrome                                                                               | Yes     | (r ) Yes  | Yes 
     4 | pacman                      | pacman                                                                                      | Yes     | (r ) Yes  | Yes 
     5 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | Yes     | (r ) Yes  | Yes 
     6 | repo-backports-update       | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes 
     7 | repo-debug                  | Debug Repository                                                                            | Yes     | (r ) Yes  | Yes 
     8 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                                                  | Yes     | (r ) Yes  | Yes 
     9 | repo-debug-update           | Update Repository (Debug)                                                                   | Yes     | (r ) Yes  | Yes 
    10 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                                          | Yes     | (r ) Yes  | Yes 
    11 | repo-non-oss                | Репозиторий Non-OSS                                                                         | Yes     | (r ) Yes  | Yes 
    12 | repo-oss                    | Основной репозиторий                                                                        | Yes     | (r ) Yes  | Yes 
    13 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | Yes     | (r ) Yes  | Yes 
    14 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes 
    15 | repo-source                 | Source Repository                                                                           | Yes     | (r ) Yes  | Yes 
    16 | repo-update                 | Основной репозиторий обновлений                                                             | Yes     | (r ) Yes  | Yes 
    17 | repo-update-non-oss         | Репозиторий обновлений (Non-Oss)                                                            | Yes     | (r ) Yes  | Yes 
    18 | shells                      | Shell Implementations (openSUSE_Leap_15.3)                                                  | Yes     | (r ) Yes  | Yes
    

  2. #2

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    Unlocking ibus makes no difference so it's not the cause. Also zypper dup does nothing

    Code:
    white-angel:~ # zypper dup 
    Loading repository data... 
    Reading installed packages... 
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more informat
    ion about this command. 
    Computing distribution upgrade... 
    
    The following item is locked and will not be changed by any action:
     Available: 
      ibus 
    Nothing to do.
    


  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,930

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    When you want to tell us what your repos are, we need the URLs, not only names and aliases, because these are local to your system (and can be anything).
    Code:
    zypper lr -d
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,930

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    And please do not do such a zypper dup without knowing what it should do. It could make things worse.
    Henk van Velden

  5. #5

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    Code:
    zypper lr -u     
    Действующие приоритеты репозиториев:                                                                                                                    (Подробнее см. "zypper lr -P") 
          90 (повышенный приоритет)   :  1 репозиторий 
          99 (приоритет по умолчанию) : 17 репозиториев 
    
    #  | Alias                       | Name                                                                                        | Enabled | GPG Check    | Refresh    | URI 
    ---+-----------------------------+---------------------------------------------------------------------------------------------+---------+--------------+------------+--------------------------------------
    ------------------------------------------- 
     1 | NVIDIA                      | NVIDIA                                                                                      | Да      | (r ) Да      | Да         | https://download.nvidia.com/opensuse/
    leap/15.3 
     2 | devel_tools_scm             | Software configuration management (openSUSE_Leap_15.3)                                      | Да      | (r ) Да      | Да         | https://download.opensuse.org/reposit
    ories/devel:/tools:/scm/openSUSE_Leap_15.3/ 
     3 | google-chrome               | google-chrome                                                                               | Да      | (r ) Да      | Да         | https://dl.google.com/linux/chrome/rp
    m/stable/x86_64 
     4 | pacman                      | pacman                                                                                      | Да      | (r ) Да      | Да         | https://mirror.yandex.ru/opensuse/pac
    kman/openSUSE_Leap_15.3 
     5 | repo-backports-debug-update | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | Да      | (r ) Да      | Да         | https://download.opensuse.org/update/
    leap/15.3/backports_debug/ 
     6 | repo-backports-update       | Update repository of openSUSE Backports                                                     | Да      | (r ) Да      | Да         | https://download.opensuse.org/update/
    leap/15.3/backports/ 
     7 | repo-debug                  | Debug Repository                                                                            | Да      | (r ) Да      | Да         | https://download.opensuse.org/debug/d
    istribution/leap/15.3/repo/oss/ 
     8 | repo-debug-non-oss          | Debug Repository (Non-OSS)                                                                  | Да      | (r ) Да      | Да         | https://download.opensuse.org/debug/d
    istribution/leap/15.3/repo/non-oss/ 
     9 | repo-debug-update           | Update Repository (Debug)                                                                   | Да      | (r ) Да      | Да         | https://download.opensuse.org/debug/u
    pdate/leap/15.3/oss/ 
    10 | repo-debug-update-non-oss   | Update Repository (Debug, Non-OSS)                                                          | Да      | (r ) Да      | Да         | https://download.opensuse.org/debug/u
    pdate/leap/15.3/non-oss/ 
    11 | repo-non-oss                | Репозиторий Non-OSS                                                                         | Да      | (r ) Да      | Да         | https://download.opensuse.org/distrib
    ution/leap/15.3/repo/non-oss/ 
    12 | repo-oss                    | Основной репозиторий                                                                        | Да      | (r ) Да      | Да         | https://download.opensuse.org/distrib
    ution/leap/15.3/repo/oss/ 
    13 | repo-sle-debug-update       | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | Да      | (r ) Да      | Да         | https://download.opensuse.org/debug/u
    pdate/leap/15.3/sle/ 
    14 | repo-sle-update             | Update repository with updates from SUSE Linux Enterprise 15                                | Да      | (r ) Да      | Да         | https://download.opensuse.org/update/
    leap/15.3/sle/ 
    15 | repo-source                 | Source Repository                                                                           | Да      | (r ) Да      | Да         | https://download.opensuse.org/source/
    distribution/leap/15.3/repo/oss/ 
    16 | repo-update                 | Основной репозиторий обновлений                                                             | Да      | (r ) Да      | Да         | https://download.opensuse.org/update/
    leap/15.3/oss 
    17 | repo-update-non-oss         | Репозиторий обновлений (Non-Oss)                                                            | Да      | (r ) Да      | Да         | https://download.opensuse.org/update/
    leap/15.3/non-oss/ 
    18 | shells                      | Shell Implementations (openSUSE_Leap_15.3)                                                  | Да      | (r ) Да      | Да         | https://download.opensuse.org/reposit
    ories/shells/openSUSE_Leap_15.3/
    


  6. #6
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,930

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    Hm, does not look bad to me. The only thing that wonders me is that the Packman URL has no mentioning of 15.3.

    BTW, next time you show command and output here, precede the command with LANG=C. That will make it better understandable in the English section here. Example:
    Code:
    LANG=C zypper lr -d
    But that works for every command.
    Henk van Velden

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,015
    Blog Entries
    3

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    Quote Originally Posted by cy6erGn0m View Post
    Zypper update is complaining about non-updatable product. What does it mean? Tried different things with no luck: the message is completely stuck:

    The following product update will NOT be installed:
    "openSUSE Leap 15.3"
    I'm pretty sure that's a mistake (but not your mistake). Perhaps a bug report is warranted. Apart from that, I would not worry about it.

    Running "zypper -v up" (for verbose output), I get (among other things):
    Code:
    The following product update will NOT be installed:
      openSUSE Leap 15.3  15.3-2
    Yesterday, they released an updated install iso for Leap 15.3. As a test, I downloaded that iso, and did a test install (to a virtual machine).

    The newly installed system describes itself as 15.3-2. I think that's what your message is coming from.

    On the newly installed system, I tried running "Yast online update". And that gave me some conflicts.
    Code:
    Problem: the installed product:Leap-15.3-2.x86_64 requires 'product(Leap) = 15.3-2', but this requirement cannot be provided
     Solution 1: Following actions will be done:
      do not install patch:openSUSE-2021-820-1.noarch
      do not install patch:openSUSE-2021-863-1.noarch
     Solution 2: downgrade of product:Leap-15.3-2.x86_64 to product:Leap-15.3-1.x86_64
     Solution 3: break product:Leap-15.3-2.x86_64 by ignoring some of its dependencies
    I'm pretty sure that is complaining about the same problem, but from the other direction.

    Somebody goofed, but it doesn't seem very important.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    30,930

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    Quote Originally Posted by nrickert View Post

    Somebody goofed, but it doesn't seem very important.
    Good explanation. But as that remastering of Leap will take place on a regular base in the future, I think it is better to make a bug report. Else it will stay as it is and we will have questions abut in the forums in the future.

    So please somebody that experiences it
    Henk van Velden

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,015
    Blog Entries
    3

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    Quote Originally Posted by hcvv View Post
    Good explanation. But as that remastering of Leap will take place on a regular base in the future, I think it is better to make a bug report. Else it will stay as it is and we will have questions abut in the forums in the future.

    So please somebody that experiences it
    I will file a bug report shortly.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

  10. #10

    Default Re: The following product update will NOT be installed: "openSUSE Leap 15.3"

    zypper -v doesn't show anything interesting... however, running install for the product shows the following:

    Code:
    # zypper in product:Leap-15.3-2.x86_64 
    Loading repository data... 
    Reading installed packages... 
    Resolving package dependencies... 
    
    The following product is going to be upgraded:
      openSUSE Leap 15.3  15.3-1 -> 15.3-2 
    
    The following package is going to be downgraded:
      openSUSE-release 
    
    1 package to downgrade. 
    Overall download size: 598.2 KiB. Already cached: 0 B. After the operation, additional 626.0 B will be used. 
    Continue? [y/n/v/...? shows all options] (y): 
    


    What's wrong with openSUSE-release?

    Code:
    # zypper search -iv openSUSE-release  
    Loading repository data... 
    Reading installed packages... 
    
    S  | Name                              | Type    | Version          | Arch   | ...
    ---+-----------------------------------+---------+------------------+--------+-...
    i+ | openSUSE-release                  | package | 15.3-lp153.149.1 | x86_64 | ...
    i  | openSUSE-release-appliance-custom | package | 15.3-lp153.149.1 | x86_64 | ...
    
    


    The system is pretty new so I wonder how I got the distribution broken so fast


Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •