Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: New Firefox update is broken

  1. #1

    Default New Firefox update is broken

    I have installed the new Firefox update (ver 91.2.0esr) and find that the browser hangs even when I attempt to open menus. I did a complete wipe of my entire system and freshly-installed openSuse Leap 15.3. Once again, I note that the new Firefox hangs even when I attempt to open drop down menus. Here are the details of my browser:

    Name Firefox
    Version 91.2.0esr
    Build ID 20210927140538
    Distribution ID openSUSE
    User Agent Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0
    OS Linux 5.3.18-59.27-default #1 SMP Tue Oct 5 10:00:40 UTC 2021 (7df2404)
    Application Binary /usr/lib64/firefox/firefox

    Has anyone else experienced this problem?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,999
    Blog Entries
    40

    Default Re: New Firefox update is broken

    I am not using that version of Firefox. ... but I am curious - when you say you did a complete wipe of your system, did you keep your old /home ?

    If you kept the old /home, did you remove (or move to a different location) the Firefox configuration information that would have been stored in /home? If you did not , then that could be the issue.

    If this is not a brand new /home, then maybe go to /home/aaroneal/.mozilla and change the name of .mozilla to .mozilla-old, then restart Firefox. Does that make a difference?

    Another way to test, is to create a brand new user, login as that user, and see if Firefox works for the new user.
    Last edited by oldcpu; 20-Oct-2021 at 19:50.

  3. #3

    Default Re: New Firefox update is broken

    Quote Originally Posted by oldcpu View Post
    I am not using that version of Firefox. ... but I am curious - when you say you did a complete wipe of your system, did you keep your old /home ?

    If you kept the old /home, did you remove (or move to a different location) the Firefox configuration information that would have been stored in /home? If you did not , then that could be the issue.

    If this is not a brand new /home, then maybe go to /home/aaroneal/.mozilla and change the name of .mozilla to .mozilla-old, then restart Firefox. Does that make a difference?

    Another way to test, is to create a brand new user, login as that user, and see if Firefox works for the new user.
    I did a complete wipe, retaining nothing from my earlier environment.

  4. #4

    Default Re: New Firefox update is broken

    FF works OK (but I hate Proton interface).

    Provide some info with

    Code:
    inxi -aFz
    Possibly you're using Wayland. Try X11.

  5. #5

    Default Re: New Firefox update is broken

    Quote Originally Posted by Svyatko View Post
    FF works OK (but I hate Proton interface).

    Provide some info with

    Code:
    inxi -aFz
    Possibly you're using Wayland. Try X11.
    I ran echo $XDG_SESSION_TYPE and discovered that I was, in fact, running Wayland. I have now logged on using Xorg and the browser works fine. Thanks for the suggestion!

    I'm a little mystified, however, that the earlier versions of the browser worked just fine in Wayland but this one does not.

  6. #6
    Join Date
    Jun 2008
    Location
    Southwest Virginia, USA
    Posts
    117

    Default Re: New Firefox update is broken

    In Tumbleweed the latest version, #93, froze on me from the get go. I deleted it and instead went into opi and installed Firefox ESR. Sweet. Stable as a rock.
    John
    Tumbleweed Home User
    Blue Ridge Mountains USA

  7. #7

    Default Re: New Firefox update is broken

    Yes I also had major problems with this update, described in this thread: https://forums.opensuse.org/showthre...s-system-theme

    Certain hardware combos will have this problem. Try adding the following line to .mozilla/firefox/###profile name###/prefs.js
    Code:
    user_pref("gfx.webrender.force-disabled", true);

  8. #8

    Default Re: New Firefox update is broken

    Quote Originally Posted by dhnels View Post
    Yes I also had major problems with this update, described in this thread: https://forums.opensuse.org/showthre...s-system-theme

    Certain hardware combos will have this problem. Try adding the following line to .mozilla/firefox/###profile name###/prefs.js
    Code:
    user_pref("gfx.webrender.force-disabled", true);
    And what renderer you are using with that setting?
    Check it with about:support page -> Graphics -> Compositing.

    Create bug report for Mozilla at https://bugzilla.mozilla.org.

  9. #9

    Default Re: New Firefox update is broken

    Quote Originally Posted by Svyatko View Post
    And what renderer you are using with that setting?
    Check it with about:support page -> Graphics -> Compositing.
    With gfx.webrender.force-disabled=true, Compositor = Basic.

    Can also workaround by setting gfx.webrender.software=true, then Compositor = WebRender (Software)

    All hardware options (webrender and opengl) fail on my system: super slow response then crashes. I did notice the firefox window refreshes almost instantly if I move the focus to another window and then back, otherwise 20-30 second delay.

  10. #10

    Default Re: New Firefox update is broken

    SOLVED!

    xorg driver was ancient "intel". Changed to "modesetting" and now firefox hw webrender works.

    I did a temporary switch (didn't want to delete old drivers) by putting my gpu [VendorID][DeviceID] in modesetting.ids:
    Code:
    echo "80860402" > /etc/X11/xorg_pci_ids/modesetting.ids

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •