Results 1 to 8 of 8

Thread: Printer Canon LBP611c does not work propely

  1. #1
    Join Date
    Oct 2021
    Location
    Ukraine
    Posts
    5

    Default Printer Canon LBP611c does not work propely

    If I use UFR II driver, I get a blank page from any source. If I use any other driver, I do not get any response from the printer at all.
    Please, help.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,621

    Default AW: Printer Canon LBP611c does not work propely

    Post:
    Code:
    zypper se -si cnrdrv cnrcups
    Can you get a testpage in Yast-----Hardware---Printers or cups:
    Code:
    localhost:631

  3. #3
    Join Date
    Oct 2021
    Location
    Ukraine
    Posts
    5

    Default Re: AW: Printer Canon LBP611c does not work propely

    Quote Originally Posted by Sauerland View Post
    Post:
    Code:
    zypper se -si cnrdrv cnrcups
    Can you get a testpage in Yast-----Hardware---Printers or cups:
    Code:
    localhost:631
    Code:
     S  | Name               | Type    | Version | Arch   | Repository 
    ---+--------------------+---------+---------+--------+------------------
     i+ | cnrdrvcups-ufr2-uk | package | 5.40-1  | x86_64 | (System Packages)
    With the testpage I have the same problem.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,621

    Default AW: Printer Canon LBP611c does not work propely

    You have unzipped the linux-UFRII-drv-v540-uken-21.tar.gz, go to the /linux-UFRII-drv-v540-uken/PPD/RPM/ directory and install all rpms......

    Please do not quote the question, post the whole commandline with the output and not only the output.......

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,621

    Default AW: Printer Canon LBP611c does not work propely

    This are Redhad rpms, so have you installed:
    jbigkit
    libbeecrypt-devel
    libbeecrypt6
    libgcrypt-devel
    libgcrypt20

    Goto the directory with the cnrdrvcups-ufr2-uk-5.40-1.x86_64.rpm, open an terminal in that directory and as root:

    Code:
    zypper in -f ./cnrdrvcups-ufr2-uk-5.40-1.x86_64.rpm
    Not needed, because the ppd for LBP611c is inside the above rpm.
    Also got o the directory where the ppd.pms are stored and as root:
    Code:
    zypper in -f ./*.rpm
    Does it work?
    Last edited by Sauerland; 19-Oct-2021 at 01:36.

  6. #6
    Join Date
    Oct 2021
    Location
    Ukraine
    Posts
    5

    Default Re: Printer Canon LBP611c does not work propely

    jbigkit
    libbeecrypt-devel
    libbeecrypt6
    libgcrypt-devel
    libgcrypt20
    just have been installed.

    Code:
    
    zypper se -si cnrdrv cnrcups                             
    Loading repository data... 
    Reading installed packages... 
    
    S  | Name                | Type    | Version | Arch   | Repository 
    ---+---------------------+---------+---------+--------+------------------ 
    i+ | cnrcupsiradv6860zk  | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc3822zk | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc3826zk | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc3830zk | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc3835zk | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc568zk  | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc5840zk | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsiradvc5860zk | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsirc1533izk   | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsirc1538izk   | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsirc3222zk    | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsirc3226zk    | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupslbp1533czk   | package | 5.40-1  | noarch | (System Packages) 
    i+ | cnrcupslbp1538czk   | package | 5.40-1  | noarch | (System Packages) 
    i+ | cnrcupslbp720czk    | package | 5.40-1  | noarch | (System Packages) 
    i+ | cnrcupslbp722czk    | package | 5.40-1  | noarch | (System Packages) 
    i+ | cnrcupsmf1538czk    | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsmf830czk     | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrcupsmf832czk     | package | 5.30-1  | noarch | (System Packages) 
    i+ | cnrdrvcups-ufr2-uk  | package | 5.40-1  | x86_64 | (System Packages)
    
    I do not understand this:
    Also got o the directory where the ppd.pms are stored and as root:
    And I still have a blank page.

  7. #7
    Join Date
    Oct 2021
    Location
    Ukraine
    Posts
    5

    Default Re: Printer Canon LBP611c does not work propely

    In addition, I have also printer Canon LBP223dw which was connected in the same way, through the LAN. It works fine and without the UFR II driver -- through CQUE (https://www.canon.co.uk/support/cons...ll&language=en).

  8. #8
    Join Date
    Oct 2021
    Location
    Ukraine
    Posts
    5

    Default Re: Printer Canon LBP611c does not work propely

    Thanks for the help.

    I solved my problem. During the verification (./configure) of the cups-filter source, I received the message that there aren't some image libraries in my system: libjpeg, libpng, libtiff, etc. Employing YaST Software Management, I installed the packages, which contain all required libraries. The solution was checked on another computer with a "clear" OpenSUSE Leap 15.2.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •