Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

  1. #11

    Default Re: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    See "man localectl" to set it globally. Setting it in ~/.profile will do it at login.

    Gene

  2. #12

    Default Re: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    Quote Originally Posted by Gene_S View Post
    See "man localectl" to set it globally. Setting it in ~/.profile will do it at login.
    Thanks, I tried it, but it is not getting much better now.

    I did some more research and found hints, that maybe some parts of the system do not work well with my en_DE locale.
    So I decided to switch to de_DE. I changed my KDE Settings to German as my primary language and also in Yast. Also I used

    Code:
    localectl set-locale LANG=de_DE.utf8
    localectl set-locale de_DE.utf8
    
    I wasn't sure, which one is right, so I tried both. locale.conf looks good:

    Code:
    Arnes-PC:~ # cat /etc/locale.conf
    LANG=de_DE.utf8
    But after a reboot, I am still on en_DE:

    Code:
    arne@Arnes-PC:~> env | grep -E 'LANG|LC_'      
    LANGUAGE=de:en_US 
    LC_MONETARY=en_DE.UTF-8 
    LANG=en_DE.UTF-8 
    LC_MEASUREMENT=en_DE.UTF-8 
    LC_TIME=en_DE.UTF-8 
    LC_COLLATE=en_DE.UTF-8 
    LC_NUMERIC=en_DE.UTF-8 
    arne@Arnes-PC:~> cat .profile | grep LANG 
    # in the variable RC_LANG. 
    #export LANG=de_DE.UTF-8        # uncomment this line for German output 
    #export LANG=fr_FR.UTF-8        # uncomment this line for French output 
    #export LANG=es_ES.UTF-8        # uncomment this line for Spanish output 
    arne@Arnes-PC:~> cat .bashrc | grep LANG        
    # here, since multilingual X sessions would not work properly if LANG is over- 
    arne@Arnes-PC:~>  
    arne@Arnes-PC:~> sudo env | grep -E 'LANG|LC_' 
    [sudo] password for root:  
    LANGUAGE=de:en_US 
    LC_MONETARY=en_DE.UTF-8 
    LANG=en_DE.UTF-8 
    LC_MEASUREMENT=en_DE.UTF-8 
    LC_TIME=en_DE.UTF-8 
    LC_COLLATE=en_DE.UTF-8 
    LC_NUMERIC=en_DE.UTF-8 
    arne@Arnes-PC:~> sudo su - 
    Arnes-PC:~ # env | grep -E 'LANG|LC_' 
    LANG=POSIX 
    LC_CTYPE=de_DE.utf8 
    Arnes-PC:~ # cat /etc/profile | grep LANG
    Arnes-PC:~ #
    Any ideas how I can get to a consistent de_DE locale?

  3. #13
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,233

    Default AW: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    en_DE is no locale....
    only de_DE or en_EN......

  4. #14
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,233

    Default AW: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct


  5. #15
    Join Date
    Sep 2012
    Posts
    7,868

    Default Re: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    Quote Originally Posted by abruenin View Post
    But after a reboot, I am still on en_DE
    For the second time - what desktop environment are you using? Do you observe the same if log in on console? Press Ctrl-Alt-F3, login, check locale.

  6. #16

    Default Re: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    Quote Originally Posted by arvidjaar View Post
    For the second time - what desktop environment are you using? Do you observe the same if log in on console? Press Ctrl-Alt-F3, login, check locale.
    I am using KDE. In console, everything is fine. So this is a problem with my KDE conf?

  7. #17

    Default Re: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    OK, in my KDE System Settings, Formats everything is set to en_DE. There is no Option to change it to de_DE.

  8. #18
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    7,233

    Default AW: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    OK, in my KDE System Settings, Formats everything is set to en_DE. There is no Option to change it to de_DE.
    What is set in Language (Sprache)?
    You can add there other languages






  9. #19

    Default Re: AW: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are corre

    Quote Originally Posted by Sauerland View Post
    What is set in Language (Sprache)?
    You can add there other languages
    Here are my settings. For German I only can choose en_DE, there is no de_DE option.






  10. #20

    Default Re: zypper dup gives /usr/bin/manpath: can't set the locale; make sure $LC_* and $LANG are correct

    For whatever reason, the option to choose de_DE locale has been back again and I have selected it. Unfortunately, I already did my daily zypper dup, so I need to wait until tomorrow until I can check if that helped.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •