Results 1 to 5 of 5

Thread: Fullscreen is a blackscreen

  1. #1

    Smile Fullscreen is a blackscreen

    Hello guys I hope you're all doing well.


    Every time I hit f11 or manually go into fullscreen in every video player my screen goes black and the sound keeps running. It does that with firefox, but also native
    media player like VLC so the problem comes from my system not the applications.

    Here's the output of inxi -Fxxz :


    System: Kernel: 5.14.5-1-default x86_64 bits: 64 compiler: gcc v: 11.2.1 Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2
    wm: kwin_x11 dm: SDDM Distro: openSUSE Tumbleweed 20210924
    Machine: Type: Desktop System: Gigabyte product: B450M DS3H v: N/A serial: <filter>
    Mobo: Gigabyte model: B450M DS3H-CF v: x.x serial: <filter> UEFI-[Legacy]: American Megatrends v: F50
    date: 11/27/2019
    CPU: Info: 6-Core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 rev: 0 cache:L2: 3 MiB
    flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 86238
    Speed: 2195 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz):1: 2195 2: 2199 3: 3593 4: 2045 5: 2194
    6: 3591 7: 3592 8: 2053 9: 2792 10: 2030 11: 2192 12: 3647
    Graphics: Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: Micro-Star MSI driver: nvidia v: 470.74 bus-ID: 06:00.0
    chip-ID: 10de:21c4
    Display: x11 server: X.org 1.20.13 compositor: kwin_x11 driver:loaded: nvidia unloaded: fbdev,modesetting,vesa
    alternate: nouveau,nv resolution: <missing: xdpyinfo>
    OpenGL:renderer: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 470.74 direct render: Yes
    Audio: Device-1: NVIDIA TU116 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus-ID: 06:00.1
    chip-ID: 10de:1aeb
    Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio vendor: Gigabyte driver: snd_hda_intel v: kernel
    bus-ID: 08:00.4 chip-ID: 1022:1487
    Sound Server-1: ALSA v: k5.14.5-1-default running: yes
    Sound Server-2: PulseAudio v: 15.0 running: no
    Sound Server-3: PipeWire v: 0.3.36 running: yes
    Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Gigabyte driver: r8169 v: kernel
    port: f000 bus-ID: 04:00.0 chip-ID: 10ec:8168
    IF: enp4s0 state: up speed: 100 Mbps duplex: full mac: <filter>
    IF-ID-1: docker0 state: down mac: <filter>
    Drives: Local Storage:total: 931.51 GiB used: 310.06 GiB (33.3%)
    ID-1: /dev/sda vendor: Samsung model: SSD 860 EVO 1TB size: 931.51 GiB speed: 6.0 Gb/s serial: <filter>
    Partition: ID-1: / size: 929.5 GiB used: 310.06 GiB (33.4%) fs: btrfs dev: /dev/sda2
    ID-2: /home size: 929.5 GiB used: 310.06 GiB (33.4%) fs: btrfs dev: /dev/sda2
    ID-3: /opt size: 929.5 GiB used: 310.06 GiB (33.4%) fs: btrfs dev: /dev/sda2
    ID-4: /var size: 929.5 GiB used: 310.06 GiB (33.4%) fs: btrfs dev: /dev/sda2
    Swap: ID-1: swap-1 type: partition size: 2 GiB used: 256 KiB (0.0%) priority: -2 dev: /dev/sda3
    Sensors: System Temperatures:cpu: 59.0 C mobo: N/A gpu: nvidia temp: 51 C
    Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
    Info: Processes: 310 Uptime: 23h 02m Memory: 15.55 GiB used: 3.46 GiB (22.3%) Init: systemd v: 249 runlevel: 5
    target: graphical.target Compilers:gcc: 11.2.1 alt: 11 Packages: 5900 rpm: 5884 flatpak: 16 Shell: Bash v: 5.1.8
    running-in: konsole inxi: 3.3.03

    I found nothing about black screen related to fullscreen with tag opensuse on the internet that's why I'm kindly asking you're help
    Thanks in advance and have a good day!


  2. #2

    Default Re: Fullscreen is a blackscreen

    Had what might be a related issue after NVIDIA driver update where there would be a black screen in openGL or Vulkan accelerated full screen apps.

    Switching from DVI to HDMI on external monitor resolved it for me.

  3. #3

    Default Re: Fullscreen is a blackscreen

    Quote Originally Posted by FrankyU2 View Post
    Had what might be a related issue after NVIDIA driver update where there would be a black screen in openGL or Vulkan accelerated full screen apps.

    Switching from DVI to HDMI on external monitor resolved it for me.
    ILL Nvidia driver bug. You may report it to Nvidia.

  4. #4

    Default Re: Fullscreen is a blackscreen

    I disabled compositor :
    On KDE Search bar -> Compositor -> Uncheck start Compositor at launch
    And it worked

  5. #5

    Default Re: Fullscreen is a blackscreen

    Quote Originally Posted by PlayItOnLinux View Post
    I disabled compositor :
    On KDE Search bar -> Compositor -> Uncheck start Compositor at launch
    And it worked
    It may work with XRender compositing.
    Also try OpenGL 3.1 instead of 2.0.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •