Results 1 to 8 of 8

Thread: Leap 15.3 - install codecs

  1. #1

    Default Leap 15.3 - install codecs

    Hello

    I have installed Leap 15.3 fine, but when I try to install the codecs using

    sudo zypper install opi
    opi codecs

    I get all sorts of errors, about repositories not existing and saying certain things are not there for VLC etc.

    Has anyone else had this problem? It all worked fine on 15.2. I have also tried the other ways (manually adding the repositories, and using YaST) and no matter what I do, it doesn't work.

    Thanks for any help.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,605

    Default Re: Leap 15.3 - install codecs

    I simply followed the instructions for 15.1 (https://forums.opensuse.org/showthre...nSUSE-Leap-15-) changing everything to 15.3 and then opened YaST, selected Repositories>Packman and selected the Switch system files to Packman option.

  3. #3
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    466

    Default Re: Leap 15.3 - install codecs

    Hi Kermit and welcome to the forum!

    Here is an inofficial guide explaining the code installation:
    https://opensuse-guide.org/codecs.php
    I am still on 15.2 so I can't reproduce. But it seems to have helped others already.

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,485

    Default AW: Leap 15.3 - install codecs

    I get all sorts of errors, about repositories not existing and saying certain things are not there for VLC etc.
    This does not help, we need the complete command line and errors......

  5. #5
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    836

    Default Re: Leap 15.3 - install codecs

    Quote Originally Posted by john_hudson View Post
    I simply followed the instructions for 15.1 (https://forums.opensuse.org/showthre...nSUSE-Leap-15-)
    If you really followed that guide and used "http://packman.inode.at/suse/openSUSE_Leap_15.1/" as repository address that will not work for two reasons:
    1. openSUSE_Leap_15.1 should be openSUSE_Leap_15.3
    2. the redirector "http://packman.inode.at" is, as far as i know, broken


    Try to use https://ftp.gwdg.de/pub/linux/misc/p...USE_Leap_15.3/ instead.

    If that does not help you need to show what you did (i.e. the commands you used) and what the results were (i.e. the errors reported by the system).

    Regards

    susejunky

  6. #6

    Default Re: Leap 15.3 - install codecs

    Thanks for the replies. This time, I followed the instructions on the link John_Hudson gave, making the appropriate changes as suggested by susejunky.

    Adding the repos - worked fine.

    Issuing this command:

    zypper install -f libxine2-codecs ffmpeg-3 dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs vlc-codec-gstreamer ogmtools libavcodec58


    Gave a few errors:



    localhost:/home/rmp # zypper install -f libxine2-codecs ffmpeg-3 dvdauthor gstreamer-plugins-bad gstreamer-plugins-bad-orig-addon gstreamer-plugins-base gstreamer-plugins-good gstreamer-plugins-good-extra gstreamer-plugins-libav gstreamer-plugins-qt5 gstreamer-plugins-ugly gstreamer-plugins-ugly-orig-addon vlc smplayer x264 x265 vlc-codecs vlc-codec-gstreamer ogmtools libavcodec58
    Loading repository data...
    Reading installed packages...
    Package 'gstreamer-plugins-qt5' not found.
    Forcing installation of 'gstreamer-plugins-bad-1.16.3-pm153.3.6.2.x86_64' from repository 'packman'.
    Forcing installation of 'ffmpeg-3-3.4.8-pm153.5.4.x86_64' from repository 'packman'.
    Forcing installation of 'gstreamer-plugins-ugly-1.16.3-3.3.1.x86_64' from repository 'Update repository with updates from SUSE Linux Enterprise 15'.
    Forcing installation of 'x265-3.5-pm153.2.2.x86_64' from repository 'packman'.
    Forcing installation of 'dvdauthor-0.7.2-bp153.1.21.x86_64' from repository 'Main Repository'.
    Forcing installation of 'gstreamer-plugins-libav-1.16.2-pm153.2.5.x86_64' from repository 'packman'.
    Forcing installation of 'ogmtools-1.5-bp153.1.15.x86_64' from repository 'Main Repository'.
    Forcing installation of 'x264-0.161+git20200912.d198931a-pm153.2.3.x86_64' from repository 'packman'.
    Forcing installation of 'libxine2-codecs-1.2.11-pm153.166.2.x86_64' from repository 'packman'.
    Forcing installation of 'vlc-3.0.13-bp153.1.1.x86_64' from repository 'Main Repository'.
    Forcing installation of 'vlc-codec-gstreamer-3.0.13-bp153.1.1.x86_64' from repository 'Main Repository'.
    'vlc-codecs' not found in package names. Trying capabilities.
    Forcing installation of 'gstreamer-plugins-bad-orig-addon-1.16.3-pm153.3.6.2.x86_64' from repository 'packman'.
    Forcing installation of 'gstreamer-plugins-base-1.16.3-4.3.1.x86_64' from repository 'Update repository with updates from SUSE Linux Enterprise 15'.
    Forcing installation of 'gstreamer-plugins-ugly-orig-addon-1.16.3-pm153.3.5.2.x86_64' from repository 'packman'.
    Forcing installation of 'gstreamer-plugins-good-1.16.3-3.6.1.x86_64' from repository 'Update repository with updates from SUSE Linux Enterprise 15'.
    Forcing installation of 'smplayer-20.4.2-bp153.1.17.x86_64' from repository 'Main Repository'.
    Forcing installation of 'gstreamer-plugins-good-extra-1.16.3-3.6.1.x86_64' from repository 'Update repository with updates from SUSE Linux Enterprise 15'.
    'libavcodec58' not found in package names. Trying capabilities.
    No provider of 'libavcodec58' found.
    Resolving package dependencies...
    3 Problems:
    Problem: the to be installed vlc-3.0.13-bp153.1.1.x86_64 conflicts with 'vlc-beta' provided by the to be installed vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64
    Problem: the to be installed ffmpeg-3-3.4.8-pm153.5.4.x86_64 requires 'libavutil55 = 3.4.8-pm153.5.4', but this requirement cannot be provided
    Problem: the to be installed gstreamer-plugins-libav-1.16.2-pm153.2.5.x86_64 requires 'libavcodec58_134(unrestricted)', but this requirement cannot be provided

    Problem: the to be installed vlc-3.0.13-bp153.1.1.x86_64 conflicts with 'vlc-beta' provided by the to be installed vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64
    Solution 1: Following actions will be done:
    do not install vlc-3.0.13-bp153.1.1.x86_64
    do not install vlc-codec-gstreamer-3.0.13-bp153.1.1.x86_64
    install vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install vlc-beta-20210925.861fb677f4-pm153.4.1.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    deinstallation of vlc-3.0.13-bp153.1.1.x86_64
    Solution 2: do not ask to install a solvable providing vlc-codecs

    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 1

    Problem: the to be installed ffmpeg-3-3.4.8-pm153.5.4.x86_64 requires 'libavutil55 = 3.4.8-pm153.5.4', but this requirement cannot be provided
    not installable providers: libavutil55-3.4.8-pm153.5.4.x86_64[packman]
    Solution 1: Following actions will be done:
    install libavutil55-3.4.8-pm153.5.4.x86_64 (with vendor change)
    SUSE LLC <https://www.suse.com/> --> http://packman.links2linux.de
    install libswresample2-3.4.8-pm153.5.4.x86_64 (with vendor change)
    SUSE LLC <https://www.suse.com/> --> http://packman.links2linux.de
    install libavformat57-3.4.8-pm153.5.4.x86_64 (with vendor change)
    SUSE LLC <https://www.suse.com/> --> http://packman.links2linux.de
    install libavcodec57-3.4.8-pm153.5.4.x86_64 (with vendor change)
    SUSE LLC <https://www.suse.com/> --> http://packman.links2linux.de
    Solution 2: do not install ffmpeg-3-3.4.8-pm153.5.4.x86_64
    Solution 3: break ffmpeg-3-3.4.8-pm153.5.4.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1

    Problem: the to be installed gstreamer-plugins-libav-1.16.2-pm153.2.5.x86_64 requires 'libavcodec58_134(unrestricted)', but this requirement cannot be provided
    not installable providers: libavcodec58_134-4.4-pm153.2.6.x86_64[packman]
    Solution 1: Following actions will be done:
    install libavcodec58_134-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libavfilter7_110-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libavformat58_76-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libavutil56_70-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libswresample3_9-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libpostproc55_9-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libswscale5_9-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    install libavresample4_0-4.4-pm153.2.6.x86_64 (with vendor change)
    openSUSE --> http://packman.links2linux.de
    Solution 2: do not install gstreamer-plugins-libav-1.16.2-pm153.2.5.x86_64
    Solution 3: break gstreamer-plugins-libav-1.16.2-pm153.2.5.x86_64 by ignoring some of its dependencies

    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c/d/?] (c): 1
    Resolving dependencies...
    Resolving package dependencies...

    The following 100 NEW packages are going to be installed:
    dvdauthor ffmpeg-3 gstreamer-libnice gstreamer-plugins-bad gstreamer-plugins-bad-lang
    gstreamer-plugins-bad-orig-addon gstreamer-plugins-good-extra gstreamer-plugins-libav
    gstreamer-plugins-ugly gstreamer-plugins-ugly-lang gstreamer-plugins-ugly-orig-addon
    libavdevice57 libavdevice58_13 libavfilter6 libavresample3 libcdio19 libdca0
    libde265-0 libebur128-1 libfaac0 libfaad2 libffms2-4 libfluidsynth1 libfreerdp2
    libgroupsock30 libgssdp-1_2-0 libgstadaptivedemux-1_0-0 libgstbadaudio-1_0-0
    libgstbasecamerabinsrc-1_0-0 libgstcodecparsers-1_0-0 libgstisoff-1_0-0
    libgstmpegts-1_0-0 libgstsctp-1_0-0 libgsturidownloader-1_0-0 libgstwayland-1_0-0
    libgstwebrtc-1_0-0 libgupnp-1_2-0 libgupnp-igd-1_0-4 libiec61883-0 libIexMath-2_2-23
    libImath-2_2-23 libiso9660-11 liblilv-0-0 libliveMedia94 liblrdf2 liblsmash2
    libluajit-5_1-2 libmms0 libmodplug1 libmpcdec5 libmpcdec6 libnice10 libofa0
    libopencore-amrnb0 libopencore-amrwb0 libopenh264-6 libpostproc54 librtmp1
    librubberband2 libSDL2-2_0-0 libserd-0-0 libshine3 libsord-0-0 libSoundTouch0
    libspandsp2 libsratom-0-0 libsrt1 libsrtp2-1 libswscale4 libtar1 libuchardet0
    libvapoursynth-50 libvapoursynth-script0 libvcdinfo0 libvidstab1_1 libvncclient0
    libvo-aacenc0 libvo-amrwbenc0 libwinpr2 libx264-161 libx265-199 libxine2
    libxine2-codecs libxvidcore4 libXvMC1 libzbar0 mpv mpv-bash-completion mpv-mpris
    ogmtools python3-vapoursynth smplayer smplayer-lang smplayer-skins
    update-desktop-files vlc-beta x264 x265 youtube-dl youtube-dl-bash-completion

    The following 6 packages are going to be REMOVED:
    vlc vlc-codec-gstreamer vlc-lang vlc-noX vlc-qt vlc-vdpau

    The following 12 packages are going to be upgraded:
    libavcodec57 libavcodec58_134 libavfilter7_110 libavformat57 libavformat58_76
    libavresample4_0 libavutil55 libavutil56_70 libpostproc55_9 libswresample2
    libswresample3_9 libswscale5_9






    Where I had to select and option to continue, I chose [1]. It does seem to work now, but I would like to understand the errors.

    Also, perhaps not directly connected but linked, VLC plays the video in one window and has the controls in another. How do I change this back to normal.... I've looked everywhere!! VLC reports version 20210925 (is that a beta version?)

    Thanks again.

  7. #7
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,605

    Default Re: Leap 15.3 - install codecs

    Quote Originally Posted by susejunky View Post
    If you really followed that guide and used "http://packman.inode.at/suse/openSUSE_Leap_15.1/" as repository address that will not work.
    Sorry I should have said that I used
    Code:
    zypper ar -f http://packman.jacobs-university.de/suse/openSUSE_Leap_15.3/ packman
    for the packman repository having encountered the problem.

  8. #8

    Default Re: Leap 15.3 - install codecs

    Quote Originally Posted by KermitXYZ View Post
    It does seem to work now, but I would like to understand the errors.
    great then - this all looks good.

    To understand the errors: by default, yast or zypper will not change the vendor of some package without warning, because this sometime means installing different other versions of programs, that are already installed. so it asks if you really want to change - in this case from suse-source to packman-source and it informs about what this will change in your programms.
    As you requested the new packages from packman, this is allright. you should check twice, if the changes would deinstall software, and you almost never break dependencies if you don't know what this means.

    daniel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •