Results 1 to 8 of 8

Thread: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

  1. #1

    Default failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    Just wanted to sudo zypper dup for 530 packages, now I am getting the error message: nothing provides libc.so.6(GLIBC_2.34

    Code:
    localhost:~> sudo zypper dup 
    [sudo] Passwort für root:  
    Metadaten von Repository 'GNOME:Factory' abrufen ......................................................................................[fertig] 
    Cache für Repository 'GNOME:Factory' erzeugen .........................................................................................[fertig] 
    Metadaten von Repository 'GNOME:Apps' abrufen .........................................................................................[fertig] 
    Cache für Repository 'GNOME:Apps' erzeugen ............................................................................................[fertig] 
    Repository-Daten werden geladen... 
    Installierte Pakete werden gelesen... 
    Warnung: Sie sind im Begriff, eine Distributionsaktualisierung mit allen aktivierten Repositorys durchzuführen. Vergewissern Sie sich, dass die
    se Repositorys kompatibel sind, bevor Sie fortfahren. Weitere Informationen zu diesem Kommando finden Sie unter 'man zypper'. 
    Distributions-Aktualisierungen werden verarbeitet... 
    9 Probleme: 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)(64bit)' bereit, das vom zu installierenden libgksu2-bin-2.0.13~pre1-5.44.x86_64 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)(64bit)' bereit, das vom zu installierenden libgksu2-0-2.0.13~pre1-5.44.x86_64 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)(64bit)' bereit, das vom zu installierenden gksu-2.0.2-2.87.x86_64 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)' bereit, das vom zu installierenden libnm0-32bit-1.32.10-457.4.x86_64 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)' bereit, das vom zu installierenden libgtk-4-1-4.4.0-76.2.i586 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)' bereit, das vom zu installierenden gnome-extensions-40.4-506.4.i586 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)' bereit, das vom zu installierenden gconf2-3.2.6-146.4.i586 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)' bereit, das vom zu installierenden gconf-polkit-3.2.6-146.4.i586 benötigt wird 
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)' bereit, das vom zu installierenden NetworkManager-openconnect-gnome-1.2.6-64.4.i586 benötigt wir
    d 
    
    Problem: nichts stellt 'libc.so.6(GLIBC_2.34)(64bit)' bereit, das vom zu installierenden libgksu2-bin-2.0.13~pre1-5.44.x86_64 benötigt wird 
     Lösung 1: Deinstallation von libgksu2-bin-2.0.13~pre1-5.34.x86_64 
     Lösung 2: veraltetes libgksu2-bin-2.0.13~pre1-5.34.x86_64 beibehalten 
     Lösung 3: libgksu2-bin-2.0.13~pre1-5.44.x86_64 durch Ignorieren einiger Abhängigkeiten brechen 
    
    Wählen Sie aus den obigen Lösungen mittels Nummer oder Sie (u)eberspringen, (w)iederholen oder brechen (a)b [1/2/3/u/w/a/d/?] (a): a
    
    
    


  2. #2
    Join Date
    Sep 2012
    Posts
    6,972

    Default Re: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    This is English speaking forum. Please run command in English locale to get English messages.

  3. #3

    Default Re: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    you are sure to upgrade you distro with factory- repos? this is experimental if you don know what your are at, be very cautious with that. IF you really want to do this, check the repository are matching as said with "Vergewissern Sie sich, dass die se Repositorys kompatibel sind, bevor Sie fortfahren." yours are not.

  4. #4

    Default Re: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    Tumbleweed = factory dong that over a year now on my Ryzen systems. The Asus TUG A17 Ryzen+Nvidia only works with Tumbleweed/Factory nearly right,

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,630

    Default AW: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    1. I do not know why people using factory Repos when they are using a Rolling Release Distribution? Only to get packages a few days earlier? factory Repos are also for the Developers to get bugreports before putting them into the Distribution.

    2. What does:
    Code:
    zypper se -si glibc

  6. #6

    Default Re: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    Code:
    1. I do not know why people using factory Repos when they are using a  Rolling Release Distribution? Only to get packages a few days earlier?  factory Repos are also for the Developers to get bugreports before  putting them into the Distribution.

    most probably because of some packages installed from https://software.opensuse.org/package/ that required some dependancy.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,101
    Blog Entries
    15

    Default Re: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    Quote Originally Posted by qwert.zuiop View Post
    Code:
    1. I do not know why people using factory Repos when they are using a  Rolling Release Distribution? Only to get packages a few days earlier?  factory Repos are also for the Developers to get bugreports before  putting them into the Distribution.

    most probably because of some packages installed from https://software.opensuse.org/package/ that required some dependancy.
    Hi
    Then that would be a bug, or a request to include the package in Tumbleweed... GNOME:Factory is development prior to release to Tumbleweed... one step removed, so likely to his issues.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: failed update requirement libc.so.6(GLIBC_2.34, nothing provides

    Update TW to get the newest glibc (and accompanying troubles).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •