Results 1 to 7 of 7

Thread: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

  1. #1

    Question Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    I am trying to set a Mandarin Chinese input method with traditional characters through zhuyin (bopomofo) on my OpenSuSE 15.3 with KDE.


    I found two different packages that were expected to do the job and installed them both: fcitx-zhuyin (1) and fcitx-chewing (2), each of which itself came with a few additional packages:

    (1) fcitx-zhuyin libkyotocabinet16 libpinyin-data libzhuyin13

    (2) chewing-data chewing-utils fcitx-chewing libchewing3


    The second also recommended an additional package chewing-utils and it got installed too. But there is still not a single input method for Chinese under Keyboard / Layout in my System Settings Module. The whole list of options seems completely messed up since there is Chinese, but under it only a plain Latin keyboard is offered.


    I had gotten it working in the past by installing iBus, but things got a little bit messy since that's not the default layout switcher in KDE. What's missing?

  2. #2
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    83

    Default Re: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    You need to install package: fcitx and it's dependencies,
    for bopomofo with fcitx-zhuyin,
    for an intelligent (auto-select word) bopomofo with fcitx-chewing.

    After packages installed, login again,
    fcitx will auto start,
    you can see it in system tray.

    Use Ctrl-space to toggle input-method or click on icon select input-method.

    Configure settings in systemsettings- Locale- Input method.

  3. #3

    Default Re: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    Quote Originally Posted by swyear View Post
    You need to install package: fcitx and it's dependencies,
    for bopomofo with fcitx-zhuyin,
    for an intelligent (auto-select word) bopomofo with fcitx-chewing.

    After packages installed, login again,
    fcitx will auto start,
    you can see it in system tray.

    Use Ctrl-space to toggle input-method or click on icon select input-method.

    Configure settings in systemsettings- Locale- Input method.

    你好, swyear !

    Really? I always thought that fcitx is the default keyboard switcher on OpenSuSE + KDE and was already installed.

    I installed the fcitx package and now I have a Fcitx Configuration program that I can start and add the inputs I want.

    However, after restart, I first had the plain US English keyboard only while trying to type in a text editor (not even US International which I'm using); in my tray I had the old layout switcher only which wasn't functional and at the end I couldn't switch or type anything. I think fcitx took over, but it didn't take into account the settings I had made to it or I wasn't able to switch between the layouts.

    After a while of checking into the settings, I had the old layouts + half of those added in the Fcitx Configuration appear in my old layout settings in the tray.

    After another restart, I have the old switcher working again without any of the new keyboards and without having done anything to restore it.

    So how do I start this fcitx and integrate it with KDE? Can I get it in the tray like the default layout switcher on KDE? And how do I choose whether I want my system to use fcitx or the old switcher?

  4. #4
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    461

    Default Re: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    Hi SusseLinuxx,

    a little OT, sorry. I have no idea of fcitx and zhuyin. But just in case, you may try using SCIM. I have found it years ago searching for a pinyin input. Havn't tried it for years. I'm still on 15.2 but it seems to be available on 15.3, too. May be worth a try.

    Have a lot of fun!

    kasi

  5. #5
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,653

    Default Re: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    Quote Originally Posted by kasi042 View Post
    Hi SusseLinuxx,

    a little OT, sorry. I have no idea of fcitx and zhuyin. But just in case, you may try using SCIM. I have found it years ago searching for a pinyin input. Havn't tried it for years. I'm still on 15.2 but it seems to be available on 15.3, too. May be worth a try.

    Have a lot of fun!

    kasi
    scim / skim was replaced in openSUSE years ago with iBus.
    iBus is also still available for openSUSE but has since been replaced by fcitx - which integrates a whole lot better with kde.

    Make sure once fcitx is installed to choose "configure" and select from available inputs and add the one you want to "current input"
    Also, remove any from "current input" that you do not want.
    Also, move to the top of the current input list the language/layout you want to use as your default.

  6. #6
    Join Date
    Jun 2008
    Location
    Taichung city,Taiwan
    Posts
    83

    Default Re: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    Quote Originally Posted by SusseLinuxx View Post
    你好, swyear !

    Really? I always thought that fcitx is the default keyboard switcher on OpenSuSE + KDE and was already installed.

    I installed the fcitx package and now I have a Fcitx Configuration program that I can start and add the inputs I want.

    However, after restart, I first had the plain US English keyboard only while trying to type in a text editor (not even US International which I'm using); in my tray I had the old layout switcher only which wasn't functional and at the end I couldn't switch or type anything. I think fcitx took over, but it didn't take into account the settings I had made to it or I wasn't able to switch between the layouts.

    After a while of checking into the settings, I had the old layouts + half of those added in the Fcitx Configuration appear in my old layout settings in the tray.

    After another restart, I have the old switcher working again without any of the new keyboards and without having done anything to restore it.

    So how do I start this fcitx and integrate it with KDE? Can I get it in the tray like the default layout switcher on KDE? And how do I choose whether I want my system to use fcitx or the old switcher?
    check your environment variables with
    Code:
    $env | grep fcitx
    GTK_IM_MODULE=fcitx
    XMODIFIERS=@im=fcitx
    QT_IM_MODULE=fcitx
    to see if something wrong.

  7. #7
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    461

    Default Re: Trying hard to add Chinese input method to my OpenSuSE 15.3 with KDE

    Quote Originally Posted by farcusnz View Post
    scim / skim was replaced in openSUSE years ago with iBus.
    iBus is also still available for openSUSE but has since been replaced by fcitx - which integrates a whole lot better with kde.
    Right, now I see what you mean. You can install scim but there is no QT5 package hence no fun using it.


    Quote Originally Posted by SusseLinuxx View Post
    So how do I start this fcitx and integrate it with KDE? Can I get it in the tray like the default layout switcher on KDE? And how do I choose whether I want my system to use fcitx or the old switcher?
    I've been trying around a bit with fcitx. Works after a couple of settings. Firstly, did you install the following packages:
    fcitx-qt5
    kf5-kcm-fcitx
    kf5-kcm-fcitx-icons

    Code:
    kasi@pluto:~> LANG=C zypper if fcitx-qt5 
    Loading repository data... 
    Reading installed packages... 
    
    
    Information for package fcitx-qt5: 
    ---------------------------------- 
    Repository     : Haupt-Repository (OSS) 
    Name           : fcitx-qt5 
    Version        : 1.2.2-lp152.5.8 
    Arch           : x86_64 
    Vendor         : openSUSE 
    Installed Size : 615.9 KiB 
    Installed      : Yes (automatically) 
    Status         : up-to-date 
    Source package : fcitx-qt5-1.2.2-lp152.5.8.src 
    Summary        : Fcitx QT5 Input Context 
    Description    :  
        A QT5 input context plugin of Fcitx IM Framework. 
    kasi@pluto:~> LANG=C zypper if kf5-kcm-fcitx 
    Loading repository data... 
    Reading installed packages... 
    
    
    Information for package kf5-kcm-fcitx: 
    -------------------------------------- 
    Repository     : Haupt-Repository (OSS) 
    Name           : kf5-kcm-fcitx 
    Version        : 0.5.5-lp152.5.5 
    Arch           : x86_64 
    Vendor         : openSUSE 
    Installed Size : 544.1 KiB 
    Installed      : Yes (automatically) 
    Status         : up-to-date 
    Source package : kcm5-fcitx-0.5.5-lp152.5.5.src 
    Summary        : KF5 control module for Fcitx 
    Description    :  
        KF5 control module for Fcitx. 
    
        You can config fcitx through "Configure Desktop" - "Locale" - Fcitx now. 
    
    kasi@pluto:~> LANG=C zypper if kf5-kcm-fcitx-icons 
    Loading repository data... 
    Reading installed packages... 
    
    
    Information for package kf5-kcm-fcitx-icons: 
    -------------------------------------------- 
    Repository     : Haupt-Repository (OSS) 
    Name           : kf5-kcm-fcitx-icons 
    Version        : 0.5.5-lp152.5.5 
    Arch           : noarch 
    Vendor         : openSUSE 
    Installed Size : 38.5 KiB 
    Installed      : Yes (automatically) 
    Status         : up-to-date 
    Source package : kcm5-fcitx-0.5.5-lp152.5.5.src 
    Summary        : Keyboard icons for kf5-kcm-fcitx 
    Description    :  
        This package provides systemsettings5 icons for fcitx in plasma5-workspace.
    
    
    

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •