Results 1 to 5 of 5

Thread: Multiple Problems After Upgrade to kernel 5.14

  1. #1

    Default Multiple Problems After Upgrade to kernel 5.14

    I use a Lenovo Legion laptop with an integrated graphics card and an Nvidia card. Yesterday I ran a zypper dup from kernel 5.6.14 to 5.14.1. With 5.6.14 I endured occaisonal random system power-offs usually upon trying to run a game through Steam. With 5.14.1, in addition to these random power-offs, prime-select no longer works and I cannot use my nvidia card at all; I am stuck using integrated Intel graphics. I upgraded to 5.14.6... same issues. I have scanned some threads from others who have had issues with this new kernel and from what I gather my best bet as a non-power user is to simply boot from a non-5.14 kernel until these issues with 5.14 are ironed out. How can I preserve my 5.6 kernel from being overwritten during future upgrades? Any insights? Here is my system information if that is at all useful for resolving my computer's issues. Thanks in advance for anyone who takes the time to help out.

    Output of inxi -F:
    Code:
    System:    Host: finalform Kernel: 5.14.6-1-default x86_64 bits: 64 Desktop: KDE Plasma 5.22.5 
               Distro: openSUSE Tumbleweed 20210927 
    Machine:   Type: Laptop System: LENOVO product: 81HG v: Lenovo Legion Y730-17ICH serial: <superuser required> 
               Mobo: LENOVO model: LNVNB161216 v: SDK0R32862 WIN serial: <superuser required> UEFI: LENOVO v: 8XCN34WW(V2.03) 
               date: 11/19/2019 
    Battery:   ID-1: BAT1 charge: 60.5 Wh (100.0%) condition: 60.5/76.5 Wh (79.2%) 
    CPU:       Info: 6-Core model: Intel Core i7-8750H bits: 64 type: MT MCP cache: L2: 9 MiB 
               Speed: 800 MHz min/max: 800/4100 MHz Core speeds (MHz): 1: 800 2: 3378 3: 842 4: 800 5: 800 6: 883 7: 991 8: 800 
               9: 1317 10: 3450 11: 2603 12: 1405 
    Graphics:  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] driver: i915 v: kernel 
               Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile] driver: N/A 
               Device-3: Chicony Integrated Camera (1280x720@30) type: USB driver: uvcvideo 
               Display: x11 server: X.org 1.20.13 driver: loaded: modesetting resolution: <missing: xdpyinfo> 
               OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 21.2.2 
    Audio:     Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel 
               Sound Server-1: ALSA v: k5.14.6-1-default running: yes 
               Sound Server-2: PipeWire v: 0.3.37 running: yes 
    Network:   Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi 
               IF: wlp0s20f3 state: up mac: 3c:f0:11:45:0e:34 
               Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
               IF: enp63s0 state: down mac: 9c:5a:44:10:95:15 
    Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb 
               Report: This feature requires one of these tools: hciconfig/bt-adapter 
    Drives:    Local Storage: total: 1.82 TiB used: 1.01 TiB (55.7%) 
               ID-1: /dev/nvme0n1 vendor: Western Digital model: WDS100T3X0C-00SJG0 size: 931.51 GiB 
               ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB 
    Partition: ID-1: / size: 80 GiB used: 24.48 GiB (30.6%) fs: btrfs dev: /dev/nvme0n1p2 
               ID-2: /boot/efi size: 511 MiB used: 5.1 MiB (1.0%) fs: vfat dev: /dev/nvme0n1p1 
               ID-3: /home size: 851.01 GiB used: 558.44 GiB (65.6%) fs: btrfs dev: /dev/nvme0n1p3 
               ID-4: /opt size: 80 GiB used: 24.48 GiB (30.6%) fs: btrfs dev: /dev/nvme0n1p2 
               ID-5: /tmp size: 80 GiB used: 24.48 GiB (30.6%) fs: btrfs dev: /dev/nvme0n1p2 
               ID-6: /var size: 80 GiB used: 24.48 GiB (30.6%) fs: btrfs dev: /dev/nvme0n1p2 
    Swap:      ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%) dev: /dev/sda1 
    Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A 
               Fan Speeds (RPM): N/A 
    Info:      Processes: 319 Uptime: N/A Memory: 31.09 GiB used: 2.45 GiB (7.9%) Shell: Bash inxi: 3.3.03
    Output of prime-select get-current
    Code:
    Driver configured: intel
    [bbswitch] NVIDIA card is OFF
    I fiddled with /etc/modprobe.d/50-bbswitch.conf in an attempt to force my gpu card to turn on on boot to no avail.

    Output of journalctl -b -1 | grep aile (it looks for bbswitch module but finds it not):

    Code:
    Sep 29 14:01:14 finalform systemd-modules-load[256]: Failed to find module 'bbswitch'
    Sep 29 14:01:17 finalform systemd[1]: haveged.service: Failed with result 'exit-code'.
    Sep 29 14:01:17 finalform lvm[612]:   /dev/nvme0n1: Failed to get external handle [udev].
    Sep 29 14:01:17 finalform lvm[612]:   /dev/sda: Failed to get external handle [udev].
    Sep 29 14:01:17 finalform lvm[612]:   /dev/nvme0n1p1: Failed to get external handle [udev].
    Sep 29 14:01:17 finalform lvm[612]:   /dev/sda1: Failed to get external handle [udev].
    Sep 29 14:01:17 finalform lvm[612]:   /dev/nvme0n1p2: Failed to get external handle [udev].
    Sep 29 14:01:17 finalform lvm[612]:   /dev/sda2: Failed to get external handle [udev].
    Sep 29 14:01:17 finalform lvm[612]:   /dev/nvme0n1p3: Failed to get external handle [udev].
    Sep 29 14:01:18 finalform kernel: thermal thermal_zone9: failed to read out thermal zone (-61)
    Sep 29 14:01:19 finalform alsactl[1362]: alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -6
    Sep 29 14:01:19 finalform nscd[1381]: 1381 stat failed for file `/etc/services'; will try again later: No such file or directory
    Sep 29 14:01:19 finalform bluetoothd[1364]: Failed to get file /var/lib/bluetooth/admin_policy_settings information
    Sep 29 14:01:26 finalform kded5[3525]: org.kde.libkbolt: Failed to connect to Bolt manager DBus interface: The name org.wicd.daemon was not provided by any .service files
    Sep 29 14:01:27 finalform kwin_x11[3530]: kf.config.core: "\"fsrestore1\" - conversion of \"0,0,0,0\" to QRect failed"
    Sep 29 14:01:27 finalform kwin_x11[3530]: kf.config.core: "\"fsrestore2\" - conversion of \"0,0,0,0\" to QRect failed"
    Sep 29 14:01:27 finalform kwin_x11[3530]: kf.config.core: "\"fsrestore3\" - conversion of \"0,0,0,0\" to QRect failed"
    Sep 29 14:01:27 finalform org_kde_powerdevil[3972]: Warning from helper: Failed to open "/sys/class/power_supply/BAT1/charge_start_threshold" for reading
    Sep 29 14:01:27 finalform org_kde_powerdevil[3972]: Warning from helper: Failed to open "/sys/class/power_supply/BAT1/charge_stop_threshold" for reading
    Sep 29 14:01:27 finalform org_kde_powerdevil[3972]: org.kde.powerdevil: org.kde.powerdevil.chargethresholdhelper.getthreshold failed "Charge thresholds not supported"
    Sep 29 14:01:27 finalform org_kde_powerdevil[3972]: Warning from helper: Failed to open "/sys/class/power_supply/BAT1/charge_start_threshold" for reading
    Sep 29 14:01:27 finalform org_kde_powerdevil[3972]: Warning from helper: Failed to open "/sys/class/power_supply/BAT1/charge_stop_threshold" for reading
    Sep 29 14:01:27 finalform org_kde_powerdevil[3972]: org.kde.powerdevil: org.kde.powerdevil.chargethresholdhelper.getthreshold failed "Charge thresholds not supported"
    Sep 29 14:02:03 finalform systemd[3388]: plasma-kactivitymanagerd.service: Failed with result 'exit-code'.
    Sep 29 14:02:03 finalform systemd[3388]: xdg-desktop-portal-gtk.service: Failed with result 'exit-code'.
    Sep 29 14:02:03 finalform dbus-daemon[1365]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Refusing activation, D-Bus is shutting down.
    Sep 29 14:02:03 finalform systemd[3388]: app-org.kde.yakuake-a213e392368348dcb92349a10368fe76.scope: Failed to kill control group /user.slice/user-1000.slice/user@1000.service/app.slice/app-org.kde.yakuake-a213e392368348dcb92349a10368fe76.scope, ignoring: Operation not permitted
    Sep 29 14:02:03 finalform systemd[3388]: app-org.kde.yakuake-a213e392368348dcb92349a10368fe76.scope: Failed to kill control group /user.slice/user-1000.slice/user@1000.service/app.slice/app-org.kde.yakuake-a213e392368348dcb92349a10368fe76.scope, ignoring: Operation not permitted
    Sep 29 14:02:03 finalform dbus-daemon[1365]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Refusing activation, D-Bus is shutting down.
    Sep 29 14:02:03 finalform dbus-daemon[1365]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Refusing activation, D-Bus is shutting down.
    Sep 29 14:02:03 finalform dbus-daemon[1365]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Refusing activation, D-Bus is shutting down.
    Sep 29 14:02:05 finalform dbus-daemon[1365]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.nm-dispatcher.service': Refusing activation, D-Bus is shutting down.

  2. #2

    Default Re: Multiple Problems After Upgrade to kernel 5.14

    I think I found a simple fix to my issue. I ran
    Code:
    sudo zypper remove bbswitch bbswitch-kmp-default
    to purge this bbswitch nonsense off of my system. Now prime-select is working for switching between intel and nvidia with a logout/login. The system is properly associating the nvidia driver with my card and I can play vidya again. Hopefully I don't eat my words. I will report back to this thread in a week's time regarding whether the random system crashes persist after this change.

  3. #3

    Thumbs up Re: Multiple Problems After Upgrade to kernel 5.14

    Quote Originally Posted by d00d View Post
    I think I found a simple fix to my issue. I ran
    Code:
    sudo zypper remove bbswitch bbswitch-kmp-default
    to purge this bbswitch nonsense off of my system. Now prime-select is working for switching between intel and nvidia with a logout/login. The system is properly associating the nvidia driver with my card and I can play vidya again. Hopefully I don't eat my words. I will report back to this thread in a week's time regarding whether the random system crashes persist after this change.
    Thanks for sharing!

    Uninstall bbswitch and bbswitch-kmp-default solved the problem partially.

    Now I can switch between intel and nvidia cards with prime-select login out and log in back. But there are some things that I cannot do:
    Reboot the pc with intel card selected (it got freeze).
    Run the apps: mailspring, skype, and visual studio code with nvidia card selected (only run with intel card selected).

  4. #4

    Default Re: Multiple Problems After Upgrade to kernel 5.14

    Quote Originally Posted by jfespinal View Post
    Thanks for sharing!

    Uninstall bbswitch and bbswitch-kmp-default solved the problem partially.

    Now I can switch between intel and nvidia cards with prime-select login out and log in back. But there are some things that I cannot do:
    Reboot the pc with intel card selected (it got freeze).
    Run the apps: mailspring, skype, and visual studio code with nvidia card selected (only run with intel card selected).
    I am pleased that my solution helped you at least somewhat. I tried switching to Intel and rebooting to recreate your issue, but encountered no freezing issues. I don't use the programs you mention so can't speak to that issue.

    Another observation:
    I use KDE and the SUSE Prime Selector widget and notice that now it does not match the driver that is currently selected. Regardless of whether I am currently using Intel or Nvidia, it always says that Nvidia is selected.

  5. #5

    Default Re: Multiple Problems After Upgrade to kernel 5.14

    Just updating that uninstalling bbswitch did not resolve my random crash issue when trying to run steam games.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •