Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Can not install HP-PLUGIN

  1. #1
    Join Date
    Jul 2011
    Location
    Čačak, Serbia
    Posts
    145

    Question Can not install HP-PLUGIN

    Hello,

    I installed Leap 15.3 with printer connected (HP-Laserjet1102p), and printer also was installed during Leap installing. But hp plugin can not be installed: using command line
    Code:
     hp-plugin -i
    it says that can not download it. Using YaST it cannot access; using select downloaded bin file it can not launch location in computer where bin file stored. I wanted to unpack bin file thinking it would be unpacked in the place it must be stored, but it was extracted in the folder I downloaded it. I deleted all extracted files from theh bin file.

    I deleted and re-added printer via YaST, installed via console, but hp-plugin can not be installed.

    Is there anything I can do? Everything were fine on 15.2

    Thank you for answering my questions.
    Vladimir from Čačak, Serbia

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,331
    Blog Entries
    1

    Default Re: Can not install HP-PLUGIN

    See if Malcolm's workaround post helps...
    https://forums.opensuse.org/showthre...70#post3049870
    openSUSE Leap 15.3; KDE Plasma 5

  3. #3
    Join Date
    Jul 2011
    Location
    Čačak, Serbia
    Posts
    145

    Question Re: Can not install HP-PLUGIN

    Quote Originally Posted by deano_ferrari View Post
    See if Malcolm's workaround post helps...
    https://forums.opensuse.org/showthre...70#post3049870
    Everything was fine, untill

    Code:
    hp-plugin -i -p
    Then, I ve got these messages:

    Code:
    probni@dhcppc9:~> hp-plugin -i -p
    
    HP Linux Imaging and Printing System (ver. 3.20.11)
    Plugin Download and Install Utility ver. 2.1
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    
    Traceback (most recent call last):
      File "/usr/bin/hp-plugin", line 93, in <module>
        handle_device_printer=False)
      File "/usr/share/hplip/base/module.py", line 430, in parseStdOpts
        self.usage(show_usage, error_msg)
      File "/usr/share/hplip/base/module.py", line 462, in usage
        utils.format_text(self.usage_data, show_usage, self.title, self.mod, self.version)
      File "/usr/share/hplip/base/utils.py", line 1655, in format_text
        formatter = usage_formatter()
      File "/usr/share/hplip/base/utils.py", line 1634, in usage_formatter
        rows, cols = ttysize()
      File "/usr/share/hplip/base/utils.py", line 1618, in ttysize
        ln1 = subprocess.getoutput('stty -a').splitlines()[0]
      File "/usr/lib64/python3.6/subprocess.py", line 556, in getoutput
        return getstatusoutput(cmd)[1]
      File "/usr/lib64/python3.6/subprocess.py", line 537, in getstatusoutput
        data = check_output(cmd, shell=True, universal_newlines=True, stderr=STDOUT)
      File "/usr/lib64/python3.6/subprocess.py", line 356, in check_output
        **kwargs).stdout
      File "/usr/lib64/python3.6/subprocess.py", line 423, in run
        with Popen(*popenargs, **kwargs) as process:
      File "/usr/lib64/python3.6/subprocess.py", line 729, in __init__
        restore_signals, start_new_session)
      File "/usr/lib64/python3.6/subprocess.py", line 1364, in _execute_child
        raise child_exception_type(errno_num, err_msg, err_filename)
    PermissionError: [Errno 13] Permission denied: '/bin/sh'
    probni@dhcppc9:~>
    And I don't know how to solve it?

    Thank you for answering my questions.
    Vladimir from Čačak, Serbia

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,465

    Default AW: Can not install HP-PLUGIN

    Have you installed:
    Code:
    python3-dbus-python >= 0.80
    python3-gobject
    python3-qt5

  5. #5
    Join Date
    Jul 2011
    Location
    Čačak, Serbia
    Posts
    145

    Default Re: AW: Can not install HP-PLUGIN

    Quote Originally Posted by Sauerland View Post
    Have you installed:
    Code:
    python3-dbus-python >= 0.80
    python3-gobject
    python3-qt5
    No. Those packages are not present in YaST list of either installed or not-installed packages.
    Vladimir from Čačak, Serbia

  6. #6
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,825
    Blog Entries
    15

    Default Re: Can not install HP-PLUGIN

    Quote Originally Posted by Vajcek View Post
    Everything was fine, untill

    Code:
    hp-plugin -i -p
    Then, I ve got these messages:

    Code:
    probni@dhcppc9:~> hp-plugin -i -p
    
    HP Linux Imaging and Printing System (ver. 3.20.11)
    Plugin Download and Install Utility ver. 2.1
    
    Copyright (c) 2001-18 HP Development Company, LP
    This software comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to distribute it
    under certain conditions. See COPYING file for more details.
    
    
    Traceback (most recent call last):
      File "/usr/bin/hp-plugin", line 93, in <module>
        handle_device_printer=False)
      File "/usr/share/hplip/base/module.py", line 430, in parseStdOpts
        self.usage(show_usage, error_msg)
      File "/usr/share/hplip/base/module.py", line 462, in usage
        utils.format_text(self.usage_data, show_usage, self.title, self.mod, self.version)
      File "/usr/share/hplip/base/utils.py", line 1655, in format_text
        formatter = usage_formatter()
      File "/usr/share/hplip/base/utils.py", line 1634, in usage_formatter
        rows, cols = ttysize()
      File "/usr/share/hplip/base/utils.py", line 1618, in ttysize
        ln1 = subprocess.getoutput('stty -a').splitlines()[0]
      File "/usr/lib64/python3.6/subprocess.py", line 556, in getoutput
        return getstatusoutput(cmd)[1]
      File "/usr/lib64/python3.6/subprocess.py", line 537, in getstatusoutput
        data = check_output(cmd, shell=True, universal_newlines=True, stderr=STDOUT)
      File "/usr/lib64/python3.6/subprocess.py", line 356, in check_output
        **kwargs).stdout
      File "/usr/lib64/python3.6/subprocess.py", line 423, in run
        with Popen(*popenargs, **kwargs) as process:
      File "/usr/lib64/python3.6/subprocess.py", line 729, in __init__
        restore_signals, start_new_session)
      File "/usr/lib64/python3.6/subprocess.py", line 1364, in _execute_child
        raise child_exception_type(errno_num, err_msg, err_filename)
    PermissionError: [Errno 13] Permission denied: '/bin/sh'
    probni@dhcppc9:~>
    And I don't know how to solve it?

    Thank you for answering my questions.
    Hi
    Don't forget the period after the -p to indicate the directory your in.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,465

    Default AW: Can not install HP-PLUGIN

    Should be there:
    Code:
    zypper se -s python3-dbus-python python3-gobject python3-qt5
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                      | Type  | Version           | Arch   | Repository
    ---+---------------------------+-------+-------------------+--------+-------------------------------------------------------------
    i+ | python3-dbus-python       | Paket | 1.2.16-6.3.1      | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | python3-dbus-python       | Paket | 1.2.4-4.24        | x86_64 | OSS
    i+ | python3-dbus-python-devel | Paket | 1.2.16-6.3.1      | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | python3-dbus-python-devel | Paket | 1.2.4-4.24        | x86_64 | OSS
    i+ | python3-gobject           | Paket | 3.34.0-2.27       | x86_64 | OSS
    i+ | python3-gobject-Gdk       | Paket | 3.34.0-2.27       | x86_64 | OSS
    i+ | python3-gobject-cairo     | Paket | 3.34.0-2.27       | x86_64 | OSS
    i+ | python3-gobject-devel     | Paket | 3.34.0-bp153.1.33 | x86_64 | OSS
    i+ | python3-gobject2          | Paket | 2.28.7-1.24       | x86_64 | OSS
    i+ | python3-gobject2-devel    | Paket | 2.28.7-1.24       | x86_64 | OSS
    i+ | python3-qt5               | Paket | 5.13.1-lp153.1.36 | x86_64 | OSS
    i+ | python3-qt5-devel         | Paket | 5.13.1-lp153.1.36 | x86_64 | OSS
       | python3-qt5-sip           | Paket | 12.8.1-bp153.1.13 | x86_64 | OSS
    Post
    Code:
    zypper lr -d

  8. #8
    Join Date
    Jul 2011
    Location
    Čačak, Serbia
    Posts
    145

    Default Re: AW: Can not install HP-PLUGIN

    Quote Originally Posted by Sauerland View Post
    Should be there:
    Code:
    zypper se -s python3-dbus-python python3-gobject python3-qt5
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                      | Type  | Version           | Arch   | Repository
    ---+---------------------------+-------+-------------------+--------+-------------------------------------------------------------
    i+ | python3-dbus-python       | Paket | 1.2.16-6.3.1      | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | python3-dbus-python       | Paket | 1.2.4-4.24        | x86_64 | OSS
    i+ | python3-dbus-python-devel | Paket | 1.2.16-6.3.1      | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | python3-dbus-python-devel | Paket | 1.2.4-4.24        | x86_64 | OSS
    i+ | python3-gobject           | Paket | 3.34.0-2.27       | x86_64 | OSS
    i+ | python3-gobject-Gdk       | Paket | 3.34.0-2.27       | x86_64 | OSS
    i+ | python3-gobject-cairo     | Paket | 3.34.0-2.27       | x86_64 | OSS
    i+ | python3-gobject-devel     | Paket | 3.34.0-bp153.1.33 | x86_64 | OSS
    i+ | python3-gobject2          | Paket | 2.28.7-1.24       | x86_64 | OSS
    i+ | python3-gobject2-devel    | Paket | 2.28.7-1.24       | x86_64 | OSS
    i+ | python3-qt5               | Paket | 5.13.1-lp153.1.36 | x86_64 | OSS
    i+ | python3-qt5-devel         | Paket | 5.13.1-lp153.1.36 | x86_64 | OSS
       | python3-qt5-sip           | Paket | 12.8.1-bp153.1.13 | x86_64 | OSS
    Post
    Code:
    zypper lr -d
    Here is:

    Code:
    zlatic@dhcppc9:~> zypper lr -d
    #  | Alias                            | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                     | Service
    ---+----------------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+-------------------------------------------------------------------------+--------
     1 | google-chrome                    | google-chrome                                                                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://dl.google.com/linux/chrome/rpm/stable/x86_64                     | 
     2 | http-ftp.gwdg.de-c1ffc423        | Packman Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/      | 
     3 | http-opensuse-guide.org-a9eafcd5 | libdvdcss repository                                                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Leap_15.3/                      | 
     4 | openSUSE-Leap-15.3-1             | openSUSE-Leap-15.3-1                                                                        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/           | 
     5 | packman-leap                     | packman-leap                                                                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/     | 
     6 | packman2                         | packman2                                                                                    | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/     | 
     7 | repo-backports-debug-update      | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/          | 
     8 | repo-backports-update            | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                | 
     9 | repo-debug                       | Debug Repository                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/     | 
    10 | repo-debug-non-oss               | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/ | 
    11 | repo-debug-update                | Update Repository (Debug)                                                                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                | 
    12 | repo-debug-update-non-oss        | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/            | 
    13 | repo-non-oss                     | Non-OSS Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/       | 
    14 | repo-oss                         | Main Repository                                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/           | 
    15 | repo-sle-debug-update            | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                | 
    16 | repo-sle-update                  | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                      | 
    17 | repo-source                      | Source Repository                                                                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/    | 
    18 | repo-update                      | Main Update Repository                                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss                       | 
    19 | repo-update-non-oss              | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes     |   99
    Vladimir from Čačak, Serbia

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,465

    Default AW: Can not install HP-PLUGIN

    First you have 2 Repos to delete, Packman and OSS are double:
    Code:
    zypper rr 4 6
    Install the python packages:
    Code:
    zypper in -f python3-dbus-python python3-gobject python3-qt5
    Now try hplip-plugin once more.

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,465

    Default AW: Can not install HP-PLUGIN

    And do not forget the point after -p:
    Code:
    hp-plugin -i -p .

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •