Results 1 to 7 of 7

Thread: qemu, display, 3D Accel ?

  1. #1

    Default qemu, display, 3D Accel ?

    I made a fresh installation of the 15.3
    then
    I installed with Yast KVM and KVM tools
    then
    with https://software.opensuse.org/package/virglrenderer

    I updated QEMU to 6.0.0 according to get libvirglrenderer >= 0.8.2 (0.9.1 in fact) with

    https://software.opensuse.org/downlo...ome%3Aregataos

    no problem with my 15.2.

    When I invoke the VM with

    qemu-kvm -enable-kvm \
    -m 2048 -smp 2 -cpu host \
    -device virtio-vga,virgl=on -display gtk,gl=on,zoom-to-fit=off \
    -device usb-ehci \
    -device usb-kbd \
    -device usb-mouse \
    -device usb-tablet \
    -device ich9-intel-hda \
    -device hda-duplex,audiodev=snd0 \
    -audiodev pa,id=snd0 \
    -device usb-host,vendorid=0x046d,productid=0x081b \
    -boot menu=on \
    -nic bridge \
    ~/QEMU_VM/android_x86_7.1-r5.img \

    I get an error

    Failed to open module: /usr/lib64/libvirglrenderer.so.1: undefined symbol: epoxy_glDeleteMemoryObjectsEXT
    qemu-kvm: -device virtio-vga,virgl=on: missing object type 'virtio-gpu-device'


    Is it a problem about missing package, ACL syntax, not started service or anything else ?

    Thanks
    OpenSuse Argon 15.3 x86_64,Asus Prime 250M-A, Intel Core i5-7400, 16 GB, Intel HD Graphics 630, Plugable usb-bt4le bluetooth 4.0 usb adapter, multicard reader USB 3.0 startech.com 35fcreadbu3, Epson XP-7100, Headset bluetooth 3.0 Philips SHQ7300

  2. #2
    Join Date
    Sep 2012
    Posts
    6,950

    Default Re: qemu, display, 3D Accel ?

    Quote Originally Posted by promeneur View Post
    Failed to open module: /usr/lib64/libvirglrenderer.so.1: undefined symbol: epoxy_glDeleteMemoryObjectsEXT
    Sounds like you installed package built for different openSUSE version. You did not really explain where you got it from (URL you posted offers several repositories and we do not know which of those you used).

  3. #3

    Default Re : qemu, display, 3D Accel ?

    i get packages from

    zypper addrepo https://download.opensuse.org/reposi...:regataos.repo
    OpenSuse Argon 15.3 x86_64,Asus Prime 250M-A, Intel Core i5-7400, 16 GB, Intel HD Graphics 630, Plugable usb-bt4le bluetooth 4.0 usb adapter, multicard reader USB 3.0 startech.com 35fcreadbu3, Epson XP-7100, Headset bluetooth 3.0 Philips SHQ7300

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,625

    Default AW: qemu, display, 3D Accel ?

    I think its an libepoxy problem.
    You do not switch to the package from the Repo....


    But:
    I would not switch to such an Repo, too much packages inside and you do not know, if they work with your System.

    I had the same experience last weekend, some KDE programs do not start (dolphin, ksysguard, kontact etc.)
    I found out, that in my Repo I have branched harfbuzz from gnome:next and that was the problem.
    After switching to the openSUSE Version (and deleting harfbuzz in my Repo) all is working.

  5. #5

    Default Re : qemu, display, 3D Accel ?

    Problem solved, thanks.

    Yes, you are right about add-on repos. I use them only to install or update selected packages, then I disable it. I never use "replace system package". Furthermore, I tried to use official experimental repo as "Virtualization" repo but some time we don't find what we want.
    OpenSuse Argon 15.3 x86_64,Asus Prime 250M-A, Intel Core i5-7400, 16 GB, Intel HD Graphics 630, Plugable usb-bt4le bluetooth 4.0 usb adapter, multicard reader USB 3.0 startech.com 35fcreadbu3, Epson XP-7100, Headset bluetooth 3.0 Philips SHQ7300

  6. #6
    Join Date
    Sep 2012
    Posts
    6,950

    Default Re: Re : qemu, display, 3D Accel ?

    Quote Originally Posted by promeneur View Post
    Problem solved, thanks.
    It would be prudent to describe what was the solution, for the sake of any other user reading this thread.

  7. #7

    Default Re : qemu, display, 3D Accel ?

    Problem solved <=> i replace the system package libepoxy by the one from raegataos repo.

    Be careful to disable the regataos repo after that to avoid updating other system packages update with the ones from regataos repo. This may lead to break some features of openSuse.
    OpenSuse Argon 15.3 x86_64,Asus Prime 250M-A, Intel Core i5-7400, 16 GB, Intel HD Graphics 630, Plugable usb-bt4le bluetooth 4.0 usb adapter, multicard reader USB 3.0 startech.com 35fcreadbu3, Epson XP-7100, Headset bluetooth 3.0 Philips SHQ7300

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •