Results 1 to 9 of 9

Thread: more update errors

  1. #1

    Default more update errors

    the to be installed patchpenSUSE-SLE-15.3-2021-3115-1.noarch conflicts with 'mozilla-nspr.x86_64

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    32,079
    Blog Entries
    15

    Default Re: more update errors

    Quote Originally Posted by 1chip View Post
    the to be installed patchpenSUSE-SLE-15.3-2021-3115-1.noarch conflicts with 'mozilla-nspr.x86_64
    Hi
    Not seeing that here, are you running a non-standard version of Firefox (as in from the Mozilla repository)?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: more update errors

    yes I'm using FF 92

  4. #4
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,031

    Default Re: more update errors

    Also using FF V92.0 from the mozilla repository (https://download.opensuse.org/reposi...USE_Leap_15.3/) on an up to date 15.3 system without any issue. The current version of "mozilla-nspr" is 4.32-lp153.1.2, also from the mozilla repo.

    I update using "zypper up", perhaps give that a try and see what conflicts, if any, are reported?
    Regards, Paul

  5. #5

    Default Re: more update errors

    Quote Originally Posted by tannington View Post
    Also using FF V92.0 from the mozilla repository (https://download.opensuse.org/reposi...USE_Leap_15.3/) on an up to date 15.3 system without any issue. The current version of "mozilla-nspr" is 4.32-lp153.1.2, also from the mozilla repo.

    I update using "zypper up", perhaps give that a try and see what conflicts, if any, are reported?
    manny@localhost:~> su-
    If 'su-' is not a typo you can use command-not-found to lookup the package that contains
    it, like this:
    cnf su-
    manny@localhost:~> su -
    Password:
    localhost:~ # zypper up
    Retrieving repository 'SUSE:SLE-15-SP2:Update' metadata .........................[error]
    Repository 'SUSE:SLE-15-SP2:Update' is invalid.
    [https-download.opensuse.org-9ccb8a98|https://download.opensuse.org/repositories/SUSE:/S
    LE-15-SP2:/Update/pool/] Valid metadata not found at specified URL
    History:
    - [https-download.opensuse.org-9ccb8a98|https://download.opensuse.org/repositories/SUSE
    :/SLE-15-SP2:/Update/pool/] Repository type can't be determined.

    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'SUSE:SLE-15-SP2:Update' because of the above error.
    Retrieving repository 'SUSE:SLE-15-SP1:Update' metadata .........................[error]
    Repository 'SUSE:SLE-15-SP1:Update' is invalid.
    [https-download.opensuse.org-e293e7c5|https://download.opensuse.org/repositories/SUSE:/S
    LE-15-SP1:/Update/pool/] Valid metadata not found at specified URL
    History:
    - [https-download.opensuse.org-e293e7c5|https://download.opensuse.org/repositories/SUSE
    :/SLE-15-SP1:/Update/pool/] Repository type can't be determined.

    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'SUSE:SLE-15-SP1:Update' because of the above error.
    Retrieving repository 'SUSE:SLE-15:Update' metadata .............................[error]
    Repository 'SUSE:SLE-15:Update' is invalid.
    [https-download.opensuse.org-ed1708a8|https://download.opensuse.org/repositories/SUSE:/S
    LE-15:/Update/pool/] Valid metadata not found at specified URL
    History:
    - [https-download.opensuse.org-ed1708a8|https://download.opensuse.org/repositories/SUSE
    :/SLE-15:/Update/pool/] Repository type can't be determined.

    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'SUSE:SLE-15:Update' because of the above error.
    Retrieving repository 'SUSE:SLE-15-SP3:Update' metadata .........................[error]
    Repository 'SUSE:SLE-15-SP3:Update' is invalid.
    [https-download.opensuse.org-f0d51679|https://download.opensuse.org/repositories/SUSE:/S
    LE-15-SP3:/Update/pool/] Valid metadata not found at specified URL
    History:
    - [https-download.opensuse.org-f0d51679|https://download.opensuse.org/repositories/SUSE
    :/SLE-15-SP3:/Update/pool/] Repository type can't be determined.

    Please check if the URIs defined for this repository are pointing to a valid repository.
    Warning: Skipping repository 'SUSE:SLE-15-SP3:Update' because of the above error.
    Some of the repositories have not been refreshed because of an error.
    Loading repository data...
    Warning: Repository 'openSUSE:Backports:SLE-15-SP3' appears to be outdated. Consider usi
    ng a different mirror or server.
    Reading installed packages...

    The following 4 package updates will NOT be installed:
    MozillaFirefox-branding-openSUSE kmozillahelper mozilla-nspr mozilla-nss-certs

    The following 8 packages are going to be upgraded:
    efibootmgr mdadm mozilla-nss-certs polkit-default-privs xorg-x11-fonts
    xorg-x11-fonts-converted xorg-x11-fonts-core xorg-x11-fonts-legacy

    8 packages to upgrade.
    Overall download size: 35.6 MiB. Already cached: 0 B. After the operation, 200.1 KiB
    will be freed.
    Continue? [y/n/v/...? shows all options] (y): y
    Retrieving package efibootmgr-14-4.3.2.x86_64 (1/8), 43.9 KiB ( 87.7 KiB unpacked)
    Retrieving delta: ./x86_64/efibootmgr-14-2.8_4.3.2.x86_64.drpm, 12.0 KiB
    Retrieving: efibootmgr-14-2.8_4.3.2.x86_64.drpm ..................................[done]
    Applying delta: ./efibootmgr-14-2.8_4.3.2.x86_64.drpm ............................[done]
    Retrieving package mdadm-4.1-24.6.1.x86_64 (2/8), 476.7 KiB ( 1.2 MiB unpacked)
    Retrieving delta: ./x86_64/mdadm-4.1-24.3.1_24.6.1.x86_64.drpm, 98.1 KiB
    Retrieving: mdadm-4.1-24.3.1_24.6.1.x86_64.drpm ..................................[done]
    Applying delta: ./mdadm-4.1-24.3.1_24.6.1.x86_64.drpm ............................[done]
    Retrieving package mozilla-nss-certs-3.68-3.56.1.x86_64
    (3/8), 258.3 KiB (513.5 KiB unpacked)
    Retrieving delta: ./x86_64/mozilla-nss-certs-3.53.1_3.68-3.53.1_3.56.1.x86_64.drpm, 126.
    8 KiB
    Retrieving: mozilla-nss-certs-3.53.1_3.68-3.53.1_3.56.1.x86_64.drpm ....[done (946 B/s)]
    Applying delta: ./mozilla-nss-certs-3.53.1_3.68-3.53.1_3.56.1.x86_64.drpm ........[done]
    Retrieving package polkit-default-privs-13.2+20210813.1c5fb05-3.3.1.noarch
    (4/8), 41.2 KiB (177.1 KiB unpacked)
    Retrieving: polkit-default-privs-13.2+20210813.1c5fb05-3.3.1.noarch.rpm ..........[done]
    Retrieving package xorg-x11-fonts-converted-7.6-13.6.5.noarch
    (5/8), 3.7 MiB ( 11.9 MiB unpacked)
    Retrieving: xorg-x11-fonts-converted-7.6-13.6.5.noarch.rpm ...........[done (3.1 MiB/s)]
    Retrieving package xorg-x11-fonts-core-7.6-13.6.1.noarch
    (6/8), 3.9 MiB ( 4.6 MiB unpacked)
    Retrieving delta: ./noarch/xorg-x11-fonts-core-7.6-13.3.1_13.6.1.noarch.drpm, 91.7 KiB
    Retrieving: xorg-x11-fonts-core-7.6-13.3.1_13.6.1.noarch.drpm ....................[done]
    Applying delta: ./xorg-x11-fonts-core-7.6-13.3.1_13.6.1.noarch.drpm ..............[done]
    Retrieving package xorg-x11-fonts-7.6-13.6.1.noarch
    (7/8), 1.4 MiB ( 7.0 MiB unpacked)
    Retrieving delta: ./noarch/xorg-x11-fonts-7.6-13.3.1_13.6.1.noarch.drpm, 42.2 KiB
    Retrieving: xorg-x11-fonts-7.6-13.3.1_13.6.1.noarch.drpm .........................[done]
    Applying delta: ./xorg-x11-fonts-7.6-13.3.1_13.6.1.noarch.drpm ...................[done]
    Retrieving package xorg-x11-fonts-legacy-7.6-13.6.1.noarch
    (8/8), 25.8 MiB ( 28.0 MiB unpacked)
    Retrieving delta: ./noarch/xorg-x11-fonts-legacy-7.6-13.3.1_13.6.1.noarch.drpm, 896.1 Ki
    B
    Retrieving: xorg-x11-fonts-legacy-7.6-13.3.1_13.6.1.noarch.drpm ..................[done]
    Applying delta: ./xorg-x11-fonts-legacy-7.6-13.3.1_13.6.1.noarch.drpm ............[done]

    Checking for file conflicts: .....................................................[done]
    (1/8) Installing: efibootmgr-14-4.3.2.x86_64 .....................................[done]
    (2/8) Installing: mdadm-4.1-24.6.1.x86_64 ........................................[done]
    Additional rpm output:
    Updating /etc/sysconfig/mdadm ...


    (3/8) Installing: mozilla-nss-certs-3.68-3.56.1.x86_64 ...........................[done]
    (4/8) Installing: polkit-default-privs-13.2+20210813.1c5fb05-3.3.1.noarch ........[done]
    Additional rpm output:
    Updating /etc/sysconfig/security ...


    (5/8) Installing: xorg-x11-fonts-converted-7.6-13.6.5.noarch .....................[done]
    (6/8) Installing: xorg-x11-fonts-core-7.6-13.6.1.noarch ..........................[done]
    (7/8) Installing: xorg-x11-fonts-7.6-13.6.1.noarch ...............................[done]
    (8/8) Installing: xorg-x11-fonts-legacy-7.6-13.6.1.noarch ........................[done]
    Executing %posttrans scripts .....................................................[done]
    There are running programs which still use files and libraries deleted or updated by rec
    ent upgrades. They should be restarted to benefit from the latest updates. Run 'zypper p
    s -s' to list these programs.

    localhost:~ #




  6. #6
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,031

    Default Re: more update errors

    Could you show the output from:

    Code:
    zypper lr -d
    Looks like your enabled repositories are in need of some attention.
    Regards, Paul

  7. #7

    Default Re: more update errors

    Quote Originally Posted by tannington View Post
    Could you show the output from:

    Code:
    zypper lr -d
    Looks like your enabled repositories are in need of some attention.
    Code:
    manny@localhost:~> su - 
    Password:  
    localhost:~ # zypper lr -d 
    #  | Alias                                | Name                                        
                                                    | Enabled | GPG Check | Refresh | Priori
    ty | Type   | URI                                                                       
                       | Service 
    ---+--------------------------------------+---------------------------------------------
    ------------------------------------------------+---------+-----------+---------+-------
    ---+--------+---------------------------------------------------------------------------
    -------------------+-------- 
     1 | http-download.opensuse.org-97ace8ce  | openSUSE:Leap:15.3:Update                   
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/update/leap/15.3/oss/                        
                       |  
     2 | https-download.opensuse.org-5d4da0bb | openSUSE:Backports:SLE-15-SP3:Checks        
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3
    :/Checks/standard/ |  
     3 | https-download.opensuse.org-758f5a47 | openSUSE:Backports:SLE-15-SP3               
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3
    /standard/         |  
     4 | https-download.opensuse.org-8e5d0252 | mozilla                                     
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | https://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.3/    
                       |  
     5 | https-download.opensuse.org-9ccb8a98 | SUSE:SLE-15-SP2:Update                      
                                                    | Yes     | ( p) Yes  | Yes     |   99  
       | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool/ 
                       |  
     6 | https-download.opensuse.org-e293e7c5 | SUSE:SLE-15-SP1:Update                      
                                                    | Yes     | ( p) Yes  | Yes     |   99  
       | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool/ 
                       |  
     7 | https-download.opensuse.org-ed1708a8 | SUSE:SLE-15:Update                          
                                                    | Yes     | ( p) Yes  | Yes     |   99  
       | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool/     
                       |  
     8 | https-download.opensuse.org-f0d51679 | SUSE:SLE-15-SP3:Update                      
                                                    | Yes     | ( p) Yes  | Yes     |   99  
       | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/Update/pool/ 
                       |  
     9 | https-download.opensuse.org-f3b4e39a | openSUSE:Backports:SLE-15-SP3:Update        
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3
    :/Update/standard/ |  
    10 | mozilla                              | mozilla                                     
                                                    | Yes     | (r ) Yes  | Yes     |   90
       | rpm-md | https://download.opensuse.org/repositories/mozilla/openSUSE_Leap_15.3/    
                       |  
    11 | openSUSE-Leap-15.3-1                 | openSUSE-Leap-15.3-1                        
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/             
                       |  
    12 | packman-essentials                   | packman-essentials                          
                                                    | Yes     | (r ) Yes  | Yes     |   90
       | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/Essenti
    als                |  
    13 | repo-backports-debug-update          | Update repository with updates for openSUSE 
    Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/            
                       |  
    14 | repo-backports-update                | Update repository of openSUSE Backports     
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                  
                       |  
    15 | repo-debug                           | Debug Repository                            
                                                    | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/       
                       |  
    16 | repo-debug-non-oss                   | Debug Repository (Non-OSS)                  
                                                    | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/   
                       |  
    17 | repo-debug-update                    | Update Repository (Debug)                   
                                                    | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                  
                       |  
    18 | repo-debug-update-non-oss            | Update Repository (Debug, Non-OSS)          
                                                    | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/              
                       |  
    19 | repo-non-oss                         | Non-OSS Repository                          
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/         
                       |  
    20 | repo-oss                             | Main Repository                             
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/             
                       |  
    21 | repo-sle-debug-update                | Update repository with debuginfo for updates
     from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                  
                       |  
    22 | repo-sle-update                      | Update repository with updates from SUSE Lin
    ux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                        
                       |  
    23 | repo-source                          | Source Repository                           
                                                    | No      | ----      | ----    |   99  
       | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/      
                       |  
    24 | repo-update                          | Main Update Repository                      
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/update/leap/15.3/oss                         
                       |  
    25 | repo-update-non-oss                  | Update Repository (Non-Oss)                 
                                                    | Yes     | (r ) Yes  | Yes     |   99  
       | rpm-md | http://download.opensuse.org/update/leap/15.3/non-oss/                    
                       |  
    localhost:~ #
    
    
    
    

  8. #8
    Join Date
    Sep 2013
    Location
    Norfolk, UK
    Posts
    2,031

    Default Re: more update errors

    Remove the redundant repositories #2 to #9 inclusive, (your mozilla repo #4 is duplicated at #10).

    Then zypper refresh followed by zypper up and you should be good to go.
    Regards, Paul

  9. #9

    Default Re: more update errors

    Quote Originally Posted by tannington View Post
    Remove the redundant repositories #2 to #9 inclusive, (your mozilla repo #4 is duplicated at #10).

    Then zypper refresh followed by zypper up and you should be good to go.
    Ok, I did all that and didn't get any errors.
    Thanks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •