Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: 'eclipse', 'netbeans' not found in package names. or

  1. #1

    Default 'eclipse', 'netbeans' not found in package names. or

    After upgrade from 15.2 to 15.3 i cannot install eclipse or netbeans.

    https://software.opensuse.org/package/eclipse - shows available package for 15.2, but not for 15.3

    same for https://software.opensuse.org/package/netbeans

    Is there a way to install it by zypper/yast?

    Can anyone explain, what happens with repositories for 15.3 comparing 15.2? May be i should add some repo?

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,513
    Blog Entries
    1

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    The package search page https://search.opensuse.org/packages/ currently doesn't work for openSUSE Leap 15.3

    For now though, you can use opi...
    Code:
    sudo zypper in opi
    Use it to search for a given package...
    Code:
    opi <package name>
    openSUSE Leap 15.3; KDE Plasma 5

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,513
    Blog Entries
    1

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    BTW, 'zypper se -s eclipse netbeans' (openSUSE Leap 15.3) turned up results for eclipse and netbeans packages.
    openSUSE Leap 15.3; KDE Plasma 5

  4. #4
    Join Date
    Sep 2012
    Posts
    6,970

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    Quote Originally Posted by deano_ferrari View Post
    For now though, you can use opi...
    No, you can not. opi is using exactly the same OBS API as software.opensuse.org and fails in exactly the same way. Moreover, for s.o.o proposed fix was merged so what is left is deploying fixed code, while for opi I do not see any fix nor even open issue.

    The correct workflow is to always use zypper/YaST Software Management to search for available packages and only use web/opi if zypper/yast fail.

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,513
    Blog Entries
    1

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    Quote Originally Posted by arvidjaar View Post
    No, you can not. opi is using exactly the same OBS API as software.opensuse.org and fails in exactly the same way. Moreover, for s.o.o proposed fix was merged so what is left is deploying fixed code, while for opi I do not see any fix nor even open issue.

    The correct workflow is to always use zypper/YaST Software Management to search for available packages and only use web/opi if zypper/yast fail.
    I demonstrated that with zypper already.

    I also ran the opi command and it returned the following results

    Code:
    # opi netbeans
    Searching...
     1. netbeans-resolver
     2. netbeans-javaparser
     3. netbeans-svnclientadapter
     4. netbeans-lejos
     5. netbeans
    Choose a number(0 to quit): 0
    linux-4k1z:~ # opi eclipse
    Searching...
     1. redeclipse
     2. eclipse-gef
     3. eclipse-egit
     4. eclipse-jgit
     5. eclipse-swtbot
     6. eclipse-nebula
     7. eclipse-anyedit
     8. eclipse-swtchart
     9. eclipse-collections
    10. trac-plugin-eclipse
    11. eclipse-jdt
    12. eclipse-pde
    13. eclipse-swt
    14. redeclipse-data
    15. eclipse-platform
    16. eclipse-license2
    17. eclipse-license1
    18. redeclipse-server
    19. eclipse-ecf-sdk
    20. eclipse-gef-sdk
    21. eclipse-emf-sdk
    22. eclipse-emf-xsd
    23. eclipse-ecf-core
    24. eclipse-emf-core
    25. eclipse-gef-tests
    26. eclipse-ecf-runtime
    27. eclipse-emf-runtime
    28. eclipse-equinox-osgi
    29. eclipse-p2-discovery
    30. eclipse-jdt-bootstrap
    31. eclipse-pde-bootstrap
    32. eclipse-swt-bootstrap
    33. entangle-plugin-eclipse
    34. eclipse-anyedit-javadoc
    35. eclipse-contributor-tools
    36. eclipse-platform-bootstrap
    37. eclipse-collections-javadoc
    38. eclipse-ecf-core-bootstrap
    39. eclipse-emf-core-bootstrap
    40. eclipse-equinox-osgi-bootstrap
    41. eclipse-p2-discovery-bootstrap
    42. eclipse
    Choose a number(0 to quit): 0
    openSUSE Leap 15.3; KDE Plasma 5

  6. #6

    Default Re: 'eclipse', 'netbeans' not found in package names. or


  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,513
    Blog Entries
    1

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    Okay, now I understand that the opi workaround mentioned here (and a number of other places)...
    https://bugzilla.opensuse.org/show_bug.cgi?id=1188365
    only returned the third party results. So, yes, stay with the 'zypper se...' method.
    openSUSE Leap 15.3; KDE Plasma 5

  8. #8

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    Quote Originally Posted by deano_ferrari View Post
    Okay, now I understand that the opi workaround mentioned here (and a number of other places)...
    https://bugzilla.opensuse.org/show_bug.cgi?id=1188365
    only returned the third party results. So, yes, stay with the 'zypper se...' method.
    So "opi" is out of discussion.


    Going back to available packages.

    This advice can be used download available rpm for different Opensuse versions.
    But there is "There is no official package available for openSUSE Leap 15.3".
    I tried
    Quote Originally Posted by Svyatko View Post
    Click yellow button "Show experimental packages" - for any available distribution (Tumbleweed, Leap 15.2, etc.).
    Search for "ALL Distributions" to get full list.

    For the first run in a browser perform changes "ALL Distributions" -> "openSUSE Tumbleweed" (or any other) -> "ALL Distributions" to get working search setting.
    But in does not work for me.


    I cannot believe that Eclipse and Netbean were thrown away in Leap 15.3.
    But i still can't find the way to install correct version for Leap 15.3. ( not RPM from other distribution )

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,513
    Blog Entries
    1

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    Quote Originally Posted by gvozdila View Post
    I cannot believe that Eclipse and Netbean were thrown away in Leap 15.3.
    But i still can't find the way to install correct version for Leap 15.3. ( not RPM from other distribution )
    That is not correct, as I mentioned back in post #3...
    Code:
    zypper se -s eclipse netbeans
    Install netbeans...
    Code:
    sudo zypper in netbeans
    openSUSE Leap 15.3; KDE Plasma 5

  10. #10

    Default Re: 'eclipse', 'netbeans' not found in package names. or

    Quote Originally Posted by deano_ferrari View Post
    That is not correct, as I mentioned back in post #3...
    Code:
    zypper se -s eclipse netbeans
    Install netbeans...
    Code:
    sudo zypper in netbeans
    Unfortunately is is not working for me. Mb i should add some repos?

    Code:
    zypper se -s netbeans
    Loading repository data...
    Reading installed packages...
    
    S | Name                      | Type       | Version          | Arch   | Repository
    --+---------------------------+------------+------------------+--------+--------------------------
      | netbeans-javaparser       | package    | 6.8-bp153.1.17   | noarch | openSUSE-Leap-15.3-Oss
      | netbeans-javaparser       | srcpackage | 6.8-bp153.1.17   | noarch | openSUSE-Leap-15.3-Source
      | netbeans-resolver         | package    | 6.7.1-bp153.1.17 | noarch | openSUSE-Leap-15.3-Oss
      | netbeans-resolver         | srcpackage | 6.7.1-bp153.1.17 | noarch | openSUSE-Leap-15.3-Source
      | netbeans-svnclientadapter | package    | 6.7.1-bp153.1.18 | noarch | openSUSE-Leap-15.3-Oss
      | netbeans-svnclientadapter | srcpackage | 6.7.1-bp153.1.18 | noarch | openSUSE-Leap-15.3-Source
    
    linux-0p5a:~ # zypper in netbeans
    Loading repository data...
    Reading installed packages...
    'netbeans' not found in package names. Trying capabilities.
    No provider of 'netbeans' found.
    Resolving package dependencies...
    Nothing to do.
    repolist

    Code:
    linux-0p5a:~ # zypper lr | grep Yes
     1 | download.opensuse.org-non-oss        | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes
     2 | http-download.opensuse.org-0ff1125a  | openSUSE:Leap:15.3:Update                                                                   | Yes     | (r ) Yes  | Yes
     3 | https-download.opensuse.org-36d32802 | KDE:Qt5                                                                                     | Yes     | (r ) Yes  | Yes
     5 | https-download.opensuse.org-d4c2878a | KDE:Frameworks5                                                                             | Yes     | (r ) Yes  | Yes
     7 | openSUSE_Leap_${releasever}          | GEO_openSUSE                                                                                | Yes     | (r ) Yes  | Yes
     8 | openSUSE_Leap_${releasever}_2        | openSUSE_Leap_15.3                                                                          | Yes     | (r ) Yes  | Yes
    10 | packman.inode.at-suse                | Packman Repository                                                                          | Yes     | (r ) Yes  | Yes
    12 | repo-backports-update                | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes
    17 | repo-non-oss                         | openSUSE-Leap-15.3-Non-Oss                                                                  | Yes     | (r ) Yes  | Yes
    18 | repo-oss                             | openSUSE-Leap-15.3-Oss                                                                      | Yes     | (r ) Yes  | Yes
    20 | repo-sle-update                      | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes
    21 | repo-source                          | openSUSE-Leap-15.3-Source                                                                   | Yes     | (r ) Yes  | Yes
    23 | repo-update                          | openSUSE-Leap-15.3-Update                                                                   | Yes     | (r ) Yes  | Yes
    24 | standard                             | kernel:HEAD                                                                                 | Yes     | (r ) Yes  | Yes

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •