Results 1 to 3 of 3

Thread: Can't SSH in to Kubic after flashing (Raspberry Pi)

  1. #1

    Default Can't SSH in to Kubic after flashing (Raspberry Pi)

    I've just flashed the latest Raspberry Pi image of Kubic (with kubeadm) to a MicroSD card. Normally, I haven't been able to get Combustion to work on the first boot of these systems, so I go ahead and preload my authorized keys into the root home directory using a series of commands like this as the superuser (so I can run the Combustion script manually by logging in via SSH):

    Code:
    mount /dev/sdb2 -o noatime,subvol=@/root /mnt
    mkdir -p /mnt/.ssh
    chmod 0700 /mnt/.ssh
    curl "https://github.com/stuartpb.keys" > /mnt/.ssh/authorized_keys
    chmod 0600 /mnt/.ssh/authorized_keys
    sync
    umount /mnt
    I've verified that the file is present with all the keys I'd expect, and have even plugged a screen into my Pi to make sure I'm getting the IP address correct, but when I try to `ssh root@192.168.0.127`, I get prompted for the password.

    Am I doing something wrong here? Is the root subvolume no longer getting mounted to the root home directory? How can I at least increase the amount of on-screen logging I can see to understand what's happening here?

  2. #2

    Default Re: Can't SSH in to Kubic after flashing (Raspberry Pi)

    UPDATE: After inspecting the /var subdirectory and taking a look at the journal, I'm seeing this:

    Code:
    -- Boot 000801fa67914b6cb37594972487449e --
    Sep 09 17:24:07 localhost sshd[2360]: Authentication refused: bad ownership or modes for directory /root
    Sep 09 17:24:08 localhost sshd[2360]: Connection closed by authenticating user root 192.168.0.99 port 55944 [preauth]
    Sep 09 17:24:14 localhost sshd[2363]: Authentication refused: bad ownership or modes for directory /root
    Sep 09 17:29:42 localhost sshd[2910]: Authentication refused: bad ownership or modes for directory /root
    Sep 09 17:29:45 localhost sshd[2910]: Connection closed by authenticating user root 192.168.0.124 port 57552 [preauth]
    This seems like an odd bug that's out of my hands (don't the modes for /root depend on how it's mounted?), so I'm filing an issue on Bugzilla.

  3. #3

    Default Re: Can't SSH in to Kubic after flashing (Raspberry Pi)


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •