Results 1 to 5 of 5

Thread: How to use XFCE with XRDP in Leap 15.3?

  1. #1

    Default How to use XFCE with XRDP in Leap 15.3?

    Hi

    I upgraded to Leap 15.3 and now my remote desktop session uses Icewm instead of XFCE. When I login locally I get XFCE desktop as expected but not when I use XRDP. I have tried updating the alternatives and it shows XFCE as the selected Windows Manager. I tried changing the startwm.sh as shown below but it will not login after the change. Any suggestions about how this is to be fixed?

    Code:
        elif [ -r /usr/bin/icewm-session ]
           /usr/bin/icewm-session
        fi
        ;;
    Code:
        elif [ -r /usr/bin/xfce4-session ]
           /usr/bin/xfce4-session
        fi
        ;;
    Thanks,
    Simon

  2. #2
    Join Date
    Apr 2016
    Location
    Cambridge, UK
    Posts
    257

    Default Re: How to use XFCE with XRDP in Leap 15.3?

    As you have spotted XRDP runs /etc/xrdp/startwm.sh to start it's window manager.

    I have come across several versions of this file and they do very different things depending on where it originated. I run a custom version so what I have on my main system is a bit useless.

    The guts of the code in the file that I have in my vanilla Leap15.3 is:

    Code:
    SESSION="plasma" 
     
      case $SESSION in
        lxde)
          /usr/bin/startlxde
          ;;
        sle)
          if [ -r /usr/bin/gnome-session ]; then
            export XDG_SESSION_TYPE=x11
            export GNOME_SHELL_SESSION_MODE=sle-classic
            /usr/bin/gnome-session --session gnome-classic
          elif [ -r /usr/bin/icewm-session ]; then
            /usr/bin/icewm-session
          fi
          ;;
        gnome)
          if [ -r /usr/bin/gnome-session ]; then   
            export XDG_SESSION_TYPE=x11
            /usr/bin/gnome-session
          elif [ -r /usr/bin/icewm-session ]; then
            /usr/bin/icewm-session
          fi 
          ;;
        plasma)
          if [ -r /usr/bin/startplasma-x11 ]; then
            export XDG_SESSION_TYPE=x11
            /usr/bin/startplasma-x11   
          elif [ -r /usr/bin/icewm-session ]; then
            /usr/bin/icewm-session
          fi
          ;;
        icewm)
          if [ -r /usr/bin/icewm-session ]; then
            /usr/bin/icewm-session
          fi
          ;;
      esac
    as such I would change the first line to:

    Code:
    SESSION="xfce"
    and add the lines at the top of the case statement:

    Code:
        xfce)
          /usr/bin/xfce4-session
          ;;
    Try that and see what happens. Have bot checked it myself but I think you get the idea of what I am trying to do.

  3. #3

    Default Re: How to use XFCE with XRDP in Leap 15.3?

    When I add the xfce option then I get an error saying:

    VNC start connecting
    Waiting 2000 ms for VNC to start...
    VNC connecting to 127.0.0.0 6100
    VNC error - problem connecting
    some problem

    Simon

  4. #4

    Default Solved: How to use XFCE with XRDP in Leap 15.3?

    Hi

    I cannot say what changed but all of a sudden I can connect using XRDP and I have the XFCE desktop.

    Simon

    Quote Originally Posted by simonwhite View Post
    When I add the xfce option then I get an error saying:

    VNC start connecting
    Waiting 2000 ms for VNC to start...
    VNC connecting to 127.0.0.0 6100
    VNC error - problem connecting
    some problem

    Simon

  5. #5
    Join Date
    Apr 2016
    Location
    Cambridge, UK
    Posts
    257

    Default Re: How to use XFCE with XRDP in Leap 15.3?

    Good work

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •