Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: Broadcom wlan + BT coexistence

  1. #1

    Default Broadcom wlan + BT coexistence

    Hello.

    I have this hardware...

    Code:
    wlan1 Dell Wireless 1704 802.11n + BT 4.0
    Code:
    Broadcom Corp. BCM43142 Bluetooth 4.0
    
    Broadcom Inc. and subsidiaries BCM43142 802.11b/g/n (rev 01)
    
    Broadcom and subsidiaries BCM43142 802.11b/g/n driver: wl
    


    WiFi works fine, bluetooth too, but not both at the same time.
    Music on bluetooth audio cuts when download a web page or a file.


    I tried:
    Code:
    /etc/bluetooth/main.conf
    
    [General]
    AutoEnable=true
    
    
    #COEXISTENCIA CON WIFI
    ohwcrypt=1
    blink=1
    btcoex_enable=1
    bt_ant_diversity=1

    Code:
    /etc/modprobe.d/iwlwifi.conf
    
     options iwlwifi bt_coex_active=1

    But nothing works, or works worst

    So I want to know how to configure the device coexistence to stop interference.

  2. #2
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    656

    Default Re: Broadcom wlan + BT coexistence

    Bluetooth + WiFi coexistence is tough, as part of my job I did work on it but it needs the Wifi and BT firmware to communicate with each other and preferably BT and Wifi should be master (for WiFi that means AP) so things can be easier delayed.

    If you want any decent performance I would go for WiFi in 5G, that way you do not have coexistence problems.

  3. #3

    Default Re: Broadcom wlan + BT coexistence

    Your answer don't solve anything.

  4. #4
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    656

    Default Re: Broadcom wlan + BT coexistence

    Thanks for the feedback.

    No it does not solve anything, it might help you to set your expectations right.

    I am wondering if these btcoex related params are even supported by the BT/WLAN module, this is how you can find out.

  5. #5

    Default Re: Broadcom wlan + BT coexistence

    Quote Originally Posted by javier View Post
    Code:
    /etc/modprobe.d/iwlwifi.conf
    
     options iwlwifi bt_coex_active=1
    But this is for Intel cards?

    https://wireless.wiki.kernel.org/en/...th-coexistence

    Set different frequencies for devices.

  6. #6

    Default Re: Broadcom wlan + BT coexistence

    modinfo btcoexist
    filename: /lib/modules/5.3.18-59.19-default/kernel/drivers/net/wireless/realtek/rtlwifi/btcoexist/btcoexist.ko.xz
    description: Realtek 802.11n PCI wireless core
    license: GPL
    author: Larry Finger <Larry.FInger@lwfinger.net>
    author: Realtek WlanFAE <wlanfae@realtek.com>
    author: Page He <page_he@realsil.com.cn>
    suserelease: SLE15-SP3
    srcversion: ACE23AE5A313740DFF4EE1F
    depends: rtlwifi
    supported: no
    retpoline: Y
    intree: Y
    name: btcoexist
    vermagic: 5.3.18-59.19-default SMP mod_unload modversions
    sig_id: PKCS#7



    iwlwifi
    parm: debug:debug output mask (uint)
    parm: swcrypto:using crypto in software (default 0 [hardware]) (int)
    parm: 11n_disable:disable 11n functionality, bitmap: 1: full, 2: disable agg TX, 4: disable agg RX, 8 enable agg TX (uint)
    parm: amsdu_size:amsdu size 0: 12K for multi Rx queue devices, 2K for AX210 devices, 4K for other devices 1:4K 2:8K 3:12K 4: 2K (default 0) (int)
    parm: fw_restart:restart firmware in case of error (default true) (bool)
    parm: nvm_file:NVM file name (charp)
    parm: uapsd_disable:disable U-APSD functionality bitmap 1: BSS 2: P2P Client (default: 3) (uint)
    parm: enable_ini:Enable debug INI TLV FW debug infrastructure (default: true (bool)
    parm: bt_coex_active:enable wifi/bt co-exist (default: enable) (bool)
    parm: led_mode:0=system default, 1=On(RF On)/Off(RF Off), 2=blinking, 3=Off (default: 0) (int)
    parm: power_save:enable WiFi power management (default: disable) (bool)
    parm: power_level:default power save level (range from 1 - 5, default: 1) (int)
    parm: disable_11acisable VHT capabilities (default: false) (bool)
    parm: remove_when_gone:Remove dev from PCIe bus if it is deemed inaccessible (default: false) (bool)
    parm: disable_11axisable HE capabilities (default: false) (bool)




    bluetooth
    parm: disable_escoisable eSCO connection creation (bool)
    parm: disable_ertmisable enhanced retransmission mode (bool)
    parm: enable_ecred:Enable enhanced credit flow control mode (bool)



    Bluetooth and wifi works only changing settings like coexistence, intolerance 40 mhz, collaboration BT, etc...
    I need access to that settings.



  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,315
    Blog Entries
    1

    Default Re: Broadcom wlan + BT coexistence

    As Svyatko already pointed out the iwlwifi dirver supports Intel hadrware and you have Broadcom.
    openSUSE Leap 15.3; KDE Plasma 5

  8. #8

    Default Re: Broadcom wlan + BT coexistence

    Quote Originally Posted by deano_ferrari View Post
    As Svyatko already pointed out the iwlwifi dirver supports Intel hadrware and you have Broadcom.
    I has been read, and don't need to know about iwlwifi driver.
    I want to know how to solve the interference.
    So that answer like your answer does not solve anything.

  9. #9

    Default Re: Broadcom wlan + BT coexistence

    Before reply this post.
    If you don't know how to solve don't reply this.
    This thread has a lot of messages and nothing about the topic.
    Thank you.

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,315
    Blog Entries
    1

    Default Re: Broadcom wlan + BT coexistence

    Quote Originally Posted by javier View Post
    I has been read, and don't need to know about iwlwifi driver.
    I want to know how to solve the interference.
    So that answer like your answer does not solve anything.
    It may not be something that ordinary users can solve. Sometimes vendor (firmware) support or bug reports may be needed. So far you've supplied little definitive information. Start by sharing the following information...

    Code:
    /sbin/lspci -nnk | grep -A3 net
    Code:
    dmesg | egrep -i "firmware|bluetooth"
    Please enclose the output within CODE tags.

    Also, user marel suggested using 5GHz wifi connectivity. Is that a possibility in your wifi network environment?
    Last edited by deano_ferrari; 03-Sep-2021 at 20:05.
    openSUSE Leap 15.3; KDE Plasma 5

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •