Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Backintime-qt will not start

  1. #1

    Default Backintime-qt will not start

    Hi all,

    I was running Leap 15.2 and the GUI for backintime stopped launching. I had been mucking around and figured I'd broken something, so I decided to update to Leap 15.3. I did a fresh install not an upgrade. I formatted the '/' drive. All went went, everything is working well apart from backintime. I am using KDE.

    Version; backintime-qt-1.2.1-bp153.1.12.noarch

    Traceback (most recent call last):
    File "/usr/share/backintime/qt/app.py", line 35, in <module>
    import qttools
    File "/usr/share/backintime/qt/qttools.py", line 47, in <module>
    import snapshots
    File "/usr/share/backintime/common/snapshots.py", line 34, in <module>
    import config
    File "/usr/share/backintime/common/config.py", line 32, in <module>
    import tools
    File "/usr/share/backintime/common/tools.py", line 51, in <module>
    import dbus
    ModuleNotFoundError: No module named 'dbus'

    I was originally getting an error about PyQt5 not being installed, so I used pip install PyQt5 and it did install, so I assume it was missing. Then I get the above error.

    I've done some searching and nothing quite fits my error. I have deleted my /home/username/.config/backintime/config file based on the suggestion of a possibly corrupted file. It had no effect.

    Can anyone suggest a fix? I feel someone lost and vulnerable without a working backup system...

    thanks!

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: Backintime-qt will not start

    I think with your action using pip you have a python mismatch.....

    It is working:
    Code:
    stephan@linux64:~> backintime-qt
    
    Back In Time
    Version: 1.2.1
    
    Back In Time comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `backintime --license' for details.
    
    
    Back In Time
    Version: 1.2.1
    
    Back In Time comes with ABSOLUTELY NO WARRANTY.
    This is free software, and you are welcome to redistribute it
    under certain conditions; type `backintime --license' for details.
    
    INFO: Lock
    INFO: Take a new snapshot. Profile: 1 Hauptprofil
    INFO: Call rsync to take the snapshot
    INFO: Save config file
    INFO: Save permissions
    INFO: Create info file
    INFO: Unlock
    stephan@linux64:~>
    Last edited by Sauerland; 27-Aug-2021 at 23:29.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

  4. #4

    Default Re: Backintime-qt will not start

    Okay, great, so how do I go about repairing that? Clearly I am not experienced here.

    I also discovered that I can run backintime successfully as root, if that makes any difference.

    thanks

  5. #5

    Default Re: Backintime-qt will not start

    I'm not really sure I'm making progress. As I said, before I likely made things worse, backintime was not launching the GUI. I have since removed the PyQt5 I installed with pip and I am back to a similar, although not identical, error to what I had originally;

    Traceback (most recent call last):
    File "/usr/share/backintime/qt/app.py", line 35, in <module>
    import qttools
    File "/usr/share/backintime/qt/qttools.py", line 21, in <module>
    from PyQt5.QtGui import (QFont, QColor, QKeySequence)
    ModuleNotFoundError: No module named 'PyQt5.QtGui'

    And if I launch from a su terminal it works fine.

    So my question remains, can somebody please suggest a possible cause and fix for my issue? That would be most appreciated.

    Thanks

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: Backintime-qt will not start

    Post:
    Code:
    zypper lr -d
    Code:
    zypper se -si python3-qt5
    Use Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste

  7. #7

    Default Re: Backintime-qt will not start

    zypper lr -d

    Code:
    #  | Alias                                | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                  | Service
    ---+--------------------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+--------------------------------------------------------------------------------------+--------
     1 | http-download.opensuse.org-6039e828  | openSUSE:Leap:15.3:Update                                                                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss/                                   | 
     2 | https-download.opensuse.org-00a106e8 | SUSE:SLE-15-SP1:GA                                                                          | No      | ----      | ----    |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/GA/pool/                | 
     3 | https-download.opensuse.org-202ea4c3 | home:seife:testing                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/home:/seife:/testing/15.3/                | 
     4 | https-download.opensuse.org-31b0d4cc | openSUSE:Backports:SLE-15-SP3                                                               | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3/standard/ | 
     5 | https-download.opensuse.org-5e2f39ad | SUSE:SLE-15-SP3:GA                                                                          | No      | ----      | ----    |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP3:/GA/pool/                | 
     6 | https-download.opensuse.org-67bcf14f | home:dl8fcl                                                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/home:/dl8fcl/15.3/                        | 
     7 | https-download.opensuse.org-6f17cc87 | SUSE:SLE-15-SP2:Update                                                                      | No      | ----      | ----    |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/Update/pool-leap-15.3/  | 
     8 | https-download.opensuse.org-8d29ca6b | SUSE:SLE-15:Update                                                                          | No      | ----      | ----    |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15:/Update/pool-leap-15.3/      | 
     9 | https-download.opensuse.org-de16102c | SUSE:SLE-15-SP1:Update                                                                      | No      | ----      | ----    |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP1:/Update/pool-leap-15.3/  | 
    10 | https-download.opensuse.org-e32b1a12 | SUSE:SLE-15-SP2:GA                                                                          | No      | ----      | ----    |   99     | NONE   | https://download.opensuse.org/repositories/SUSE:/SLE-15-SP2:/GA/pool/                | 
    11 | openSUSE-Leap-15.3-1                 | openSUSE-Leap-15.3-1                                                                        | No      | ----      | ----    |   99     | NONE   | cd:/?devices=/dev/disk/by-id/wwn-0x5001480000000000                                  | 
    12 | packman                              | Packman                                                                                     | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/                  | 
    13 | repo-backports-debug-update          | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/                       | 
    14 | repo-backports-update                | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                             | 
    15 | repo-debug                           | Debug Repository                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/                  | 
    16 | repo-debug-non-oss                   | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/              | 
    17 | repo-debug-update                    | Update Repository (Debug)                                                                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                             | 
    18 | repo-debug-update-non-oss            | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/                         | 
    19 | repo-non-oss                         | Non-OSS Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/                    | 
    20 | repo-oss                             | Main Repository                                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/                        | 
    21 | repo-sle-debug-update                | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                             | 
    22 | repo-sle-update                      | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                                   | 
    23 | repo-source                          | Source Repository                                                                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/                 | 
    24 | repo-update                          | Main Update Repository                                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss                                    | 
    25 | repo-update-non-oss                  | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/non-oss/                               | 
    26 | snappy                               | snappy                                                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.opensuse.org/repositories/system:/snappy/openSUSE_Leap_15.3         | 
    27 | teams                                | teams                                                                                       | Yes     | (r ) Yes  | Yes     |   99     | r
    zypper se -si python3-qt5

    Code:
    Loading repository data...
    Warning: Repository 'openSUSE:Backports:SLE-15-SP3' appears to be outdated. Consider using a different mirror or server.
    Reading installed packages...
    
    S  | Name        | Type    | Version           | Arch   | Repository
    ---+-------------+---------+-------------------+--------+----------------
    i+ | python3-qt5 | package | 5.13.1-lp153.1.36 | x86_64 | Main Repository

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: Backintime-qt will not start

    So the question is:
    Why do you get so many SLE Repos in your list?????

  9. #9

    Default Re: AW: Backintime-qt will not start

    Quote Originally Posted by Sauerland View Post
    So the question is:
    Why do you get so many SLE Repos in your list?????
    Because that is what was there after the install. I did not select them, they were added during the installation process. I was somewhat surprised as 15.2 did not use any of those repositories. Many have given me error messages, so I have disabled them, but not removed them as I was unsure if they were required. I have absolutely no idea what the minimum amount of repositories I need for my system, so it is near impossible for me to second guess the official install.

    I am posting on this forum as I do not know all the settings and how to troubleshoot my problem. If I did know this, I would not need assistance.

    And to reiterate, I was having an identical problem with 15.2 and backintime where it did not want to start the GUI. That was part of the motivation for upgrading to 15.3.

  10. #10
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: Re: AW: Backintime-qt will not start

    Quote Originally Posted by wilted926 View Post
    Because that is what was there after the install. I did not select them, they were added during the installation process. I was somewhat surprised as 15.2 did not use any of those repositories. Many have given me error messages, so I have disabled them, but not removed them as I was unsure if they were required. I have absolutely no idea what the minimum amount of repositories I need for my system, so it is near impossible for me to second guess the official install.

    I am posting on this forum as I do not know all the settings and how to troubleshoot my problem. If I did know this, I would not need assistance.

    And to reiterate, I was having an identical problem with 15.2 and backintime where it did not want to start the GUI. That was part of the motivation for upgrading to 15.3.
    No, those Repos are not enabled by Installation of openSUSE.

    Was your former Distribution SLES or SLED 15 and not openSUSE????

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •