Page 1 of 3 123 LastLast
Results 1 to 10 of 30

Thread: Clicking internet links doesn't work

  1. #1
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    395

    Default Clicking internet links doesn't work

    For many months now, whenever I've tried to follow a link, say, from an email, firefox opens but it tries to open a file which has been created in ~/.cache/kioexec/krun/... After months of looking for ways to fix it I still can't make it work as it should. I have a workaround which is to copy the link address, open firefox and paste the link into the url bar.
    Does anyone know what my problem is and how to fix it?
    I'm totally up-to-date with tumbleweed and as you can see my default browser is firefox (currently 91.0.1).
    Pete

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,284

    Default Re: Clicking internet links doesn't work

    And your Desktop???
    Henk van Velden

  3. #3
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    714

    Default Re: Clicking internet links doesn't work

    I couldn't tell for sure.
    Quote Originally Posted by peteh100 View Post
    ~/.cache/kioexec/krun/...
    However, that's not the firefox cache. Did you search in about:config? I'd try searching for that path or parts of it like "kio" or "krun". You'd have to show all settings and use "ctrl+f" not the search bar for setting names. In settings names you can search for "link" or "browser.link" - anything suspiscious?
    It could also be some some glitch in MIME settings?

  4. #4
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    395

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by hcvv View Post
    And your Desktop???
    Sorry I thought the kio bit was a pointer. The desktop is the latest kde framework-5.85 and plasma 5.22.
    Pete

  5. #5
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    820

    Default Re: Clicking internet links doesn't work

    Can you try on the command line "xdg-open https://forums.opensuse.org". Does that work, if not please post the command on the complete output in this topic.

  6. #6
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    820

    Default Re: Clicking internet links doesn't work

    For KDE you should be able to fix this through Settings --> System Settings --> Applications.

  7. #7
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    395

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by marel View Post
    Can you try on the command line "xdg-open https://forums.opensuse.org". Does that work, if not please post the command on the complete output in this topic.
    The following all appears from just the original command. It looks as though I've made 2 separate commands which I haven't!:

    Code:
    peteh ~ > xdg-open https://forums.opensuse.org
    kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/desktop.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/desktop.so'"
    kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/applications.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/applications.so'"
    peteh ~ > command= "/usr/bin/firefox" args= ("/usr/bin/firefox", "https://forums.opensuse.org")
    kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/desktop.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/desktop.so'"
    kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/applications.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/applications.so'"
    kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job.
    Copying QUrl("https://forums.opensuse.org")  to QUrl("file:///home/peteh/.cache/kioexec/krun/7198_0/unnamed")
    telling kioexecd to watch path "/home/peteh/.cache/kioexec/krun/7198_0/unnamed" dest "https://forums.opensuse.org"
    All files downloaded, will call slotRunApp shortly
    EXEC "/usr/bin/firefox /home/peteh/.cache/kioexec/krun/7198_0/unnamed"
    EXEC done
    My default browser is set to firefox in system settings and always has been.
    Pete

  8. #8
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    820

    Default Re: Clicking internet links doesn't work

    Okay that does not look good, for me it work and looks like:

    Code:
    $ xdg-open https://forums.opensuse.org
    kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/desktop.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/desktop.so'" 
    kf.coreaddons: no metadata found in "/usr/lib64/qt5/plugins/kf5/kio/applications.so" "Failed to extract plugin meta data from '/usr/lib64/qt5/plugins/kf5/kio/applications.so'"
    
    After that the tab is opened in Firefox.

    The relevant error looks to me:

    Code:
    kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job.
    Searching for that on the Internet gives some hints.
    Can you try:

    Code:
    $ xdg-mime query default x-scheme-handler/http  
    firefox.desktop 
    $ xdg-mime query default x-scheme-handler/https 
    firefox.desktop
    Does it list anything else for you?

  9. #9
    Join Date
    Sep 2014
    Location
    Germany
    Posts
    1,036

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by peteh100 View Post
    ... The desktop is the latest kde framework-5.85 and plasma 5.22.
    Do you have the package kmozillahelper installed?

    Regards

    susejunky

  10. #10
    Join Date
    Jun 2008
    Location
    Yorkshire
    Posts
    395

    Default Re: Clicking internet links doesn't work

    It started to work properly again yesterday. The only thing I did was make a slight change to a desktop widget for firefox but I can't think that would have made a difference (I added the "%u" after the command).
    Anyway, it's now working as it should so thanks for all you responses.
    Pete

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •