Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 30

Thread: Clicking internet links doesn't work

  1. #11
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,287

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by peteh100 View Post
    I added the "%u" after the command
    Why wasn't it there in the first place? That is rather crucial.
    Henk van Velden

  2. #12

    Default Re: Clicking internet links doesn't work

    I have been searching for this problem because I have exactly the same problem described.
    I'm using Leap 15.3 and plasma 5.18.6.
    Firefox is the default browser.

    When I open most links it opens a local file instead

    Code:
    fernando@andromeda:~> xdg-open https://forums.opensuse.org 
    fernando@andromeda:~> command= "firefox" args= ("firefox", "https://forums.opensuse.org") 
    kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job. 
    Copying QUrl("https://forums.opensuse.org")  to QUrl("file:///home/fernando/.cache/kioexec/krun/6808_0/unnamed") 
    Telling kioexecd to watch path "/home/fernando/.cache/kioexec/krun/6808_0/unnamed" dest "https://forums.opensuse.org" 
    All files downloaded, will call slotRunApp shortly 
    EXEC "/usr/bin/firefox /home/fernando/.cache/kioexec/krun/6808_0/unnamed" 
    EXEC done
    

  3. #13

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by fperal View Post
    I have been searching for this problem because I have exactly the same problem described.
    I'm using Leap 15.3 and plasma 5.18.6.
    Firefox is the default browser.

    When I open most links it opens a local file instead

    Code:
    fernando@andromeda:~> xdg-open https://forums.opensuse.org 
    fernando@andromeda:~> command= "firefox" args= ("firefox", "https://forums.opensuse.org") 
    kf.kio.core: Protocol Class of url QUrl("https://forums.opensuse.org") , isn't ':local', cancelling job. 
    Copying QUrl("https://forums.opensuse.org")  to QUrl("file:///home/fernando/.cache/kioexec/krun/6808_0/unnamed") 
    Telling kioexecd to watch path "/home/fernando/.cache/kioexec/krun/6808_0/unnamed" dest "https://forums.opensuse.org" 
    All files downloaded, will call slotRunApp shortly 
    EXEC "/usr/bin/firefox /home/fernando/.cache/kioexec/krun/6808_0/unnamed" 
    EXEC done
    

    I found the problem.
    In system setting I had set web browser to "with the following command" set to
    firefox
    I changed it to /usr/bin/firefox and it works

  4. #14
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,287

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by fperal View Post
    I found the problem.
    In system setting I had set web browser to "with the following command" set to
    firefox
    I changed it to /usr/bin/firefox and it works
    I my KDE System Settings, the "with the following command" is not checked at all.
    Henk van Velden

  5. #15

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by hcvv View Post
    I my KDE System Settings, the "with the following command" is not checked at all.

    I have three options

    *In an application based in the contents of the url
    *in the following application
    *with the following command


    in the second option only chromium, seamonkey and opera appear, so y used the third one

  6. #16
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,287

    Default Re: Clicking internet links doesn't work

    I have the same three option.

    But the second shows Firefox or Konqueror only (which is correct, I do not have any other installed). I never changed there, because Firefox is nowadays the default in KDE and thus this was already as it is now surviving several upgrades.

    Thus I guess the strange thing here is that you do not have Firefox in that list, although you have it installed?
    Henk van Velden

  7. #17

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by hcvv View Post
    I have the same three option.

    But the second shows Firefox or Konqueror only (which is correct, I do not have any other installed). I never changed there, because Firefox is nowadays the default in KDE and thus this was already as it is now surviving several upgrades.

    Thus I guess the strange thing here is that you do not have Firefox in that list, although you have it installed?

    One funny thing more.
    In some applications (for instance I use telegram app to use telegram and rambox to use whatsapp in the pc) the links where not working, after changing the "with the following command" now they work ...... but with chromium!!!! but there is not set in any of this applications to use chromium. Then I change the system settings to "In an application based in the contents of the url" open one of these programs, click on a link and it opens firefox, but not the link. And if I set "in the following application" and set opera, then it open the link with opera

  8. #18

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by fperal View Post
    One funny thing more.
    In some applications (for instance I use telegram app to use telegram and rambox to use whatsapp in the pc) the links where not working, after changing the "with the following command" now they work ...... but with chromium!!!! but there is not set in any of this applications to use chromium. Then I change the system settings to "In an application based in the contents of the url" open one of these programs, click on a link and it opens firefox, but not the link. And if I set "in the following application" and set opera, then it open the link with opera

    and then I change again to "In an application based in the contents of the url" and it continues using opera, and I change again to "with the following command" and it continues using opera too

  9. #19
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    31,287

    Default Re: Clicking internet links doesn't work

    Sorry I have no idea why this seemingly random use of browsers. I only wanted to show you what I have in a rather bland situation: only standard installed browsers and never (in this area) changed KDE config.
    Henk van Velden

  10. #20
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    16,047
    Blog Entries
    3

    Default Re: Clicking internet links doesn't work

    Quote Originally Posted by fperal View Post
    I have three options

    *In an application based in the contents of the url
    *in the following application
    *with the following command


    in the second option only chromium, seamonkey and opera appear, so y used the third one
    When using those settings, I click on the small icon to the right of "with the following". That gives me an application window where I can find "firefox". This should set it the way that KDE expects.
    openSUSE Leap 15.4; KDE Plasma 5.24.4;
    testing Tumbleweed.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •