Results 1 to 6 of 6

Thread: OpenSuSe 15.3 и видеоредакторы

  1. #1
    Join Date
    Feb 2016
    Location
    Samara
    Posts
    19

    Default OpenSuSe 15.3 и видеоредакторы

    Поставил Pitivi - не запустился. Плюнул, поставил kdenlive - запустился, но работать отказался со словами:
    Отсутствует MLT модуль avformat(FFmpeg), необходимый для работы со звуком и видео.
    Почитал всякие умные советы на форумах, попытался сделать разное:
    - ставил ffmpeg, ffmpeg3, ffmpeg4
    - менял репозитарии на packman, пробовал vlc
    - ставил другие редакторы
    - само собой поставил все нужные пакеты

    Подозреваю, что что-то сломали в самом mlt, потому что в системе оно есть и видеоредактор об этом в курсе.

    Прошу помощи гуру, очень надо смонтировать небольшой ролик (не за деньги, по дружбе), а винду ставить очень не хочется, да и есть ли там сейчас бесплатные без ватермарков...
    Кривыми должны быть извилины, а не руки.

  2. #2

    Default Re: OpenSuSe 15.3 и видеоредакторы

    Не OpenSuSe, а openSUSE.

    Поставил kdenlive - он запустился на Leap 15.2.
    Ищи avformat - нужны libavformat57 или libavformat58.
    Ищи MLT - нужны libmlt 4 пакета.

    В Leap 15.3 часть пакетов идёт от SLE 15 SP3 и нужны соответствующие хранилища.

  3. #3
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    188

    Default Re: OpenSuSe 15.3 и видеоредакторы

    Quote Originally Posted by Phantom63rus View Post
    Поставил Pitivi - не запустился. Плюнул, поставил kdenlive - запустился, но работать отказался со словами....
    Приветствую.

    Pitivi
    действительно не запускается, а вот Kdenlive, у меня, прекрасно работает.

    Я делал так:
    • Установил кодеки, в один клик, вот от сюда openSUSE-Community.
    • Перевёл системные пакеты на версии из репозитория Packman. И повысил приоритет репозитория Packman до 97. (пришлось отказаться от VLC, из-за конфликта)
    • Установил Kdenlive.


    Всё это проделал на openSUSE Leap 15.3

    Недопустимо перемешивание пакетов из разных репозиториев (Main, multimedia, Packman), это обычно ломает приложения.
    Что бы этого избежать, надо выставлять разный приоритет репозиториев и переводить системные пакеты на один из репозиториев (тот который вам важнее).

  4. #4

    Default Re: OpenSuSe 15.3 и видеоредакторы

    Quote Originally Posted by e_dimas View Post
    • Перевёл системные пакеты на версии из репозитория Packman. И повысил приоритет репозитория Packman до 97. (пришлось отказаться от VLC, из-за конфликта)
    VLC плеер обычно работает - ставить из Packman.

  5. #5
    Join Date
    Jun 2010
    Location
    Кропоткин, Краснодарский край
    Posts
    188

    Default Re: OpenSuSe 15.3 и видеоредакторы

    Quote Originally Posted by Svyatko View Post
    VLC плеер обычно работает - ставить из Packman.
    В Packman-е нет VLC.
    Ну то есть, там есть "vlc-beta", нечто кривое, с дебильным интерфейсом аля андроид! Пользоваться невозможно!

    Но это не беда, VLC всегда криво работал. То аппаратное ускорение не работает, то какой нибудь декодер глючит, то просто ресурсы жрёт.

    Уже много лет пользуюсь SMPlayer, аппаратное ускорение работает и на Nvidia и на Intel, ресурсы вообще не потребляет.

  6. #6

    Default Re: OpenSuSe 15.3 и видеоредакторы

    Quote Originally Posted by e_dimas View Post
    В Packman-е нет VLC.
    http://packman.links2linux.org/package/vlc

    Нет для Leap 15.3, есть для 15.2 и TW.

    VLC от Videolan есть: https://download.videolan.org/SuSE/SLEap_15.3/

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •