Results 1 to 4 of 4

Thread: Update fails with message "installation has completed with error"

  1. #1

    Default Update fails with message "installation has completed with error"

    Doing a `zypper dup`. 600-odd pkgs to update, 1GB. After pkgs retrieved, ignoring `android-platform-tools` not being found in repo, then the msg about installation completing but not updates being installed. Fortunately the downloads appear to be cached. How do I force the update to proceed? *Should* I?

  2. #2

    Default Re: Update fails with message "installation has completed with error"

    Quote Originally Posted by tomr08 View Post
    Doing a `zypper dup`. 600-odd pkgs to update, 1GB. After pkgs retrieved, ignoring `android-platform-tools` not being found in repo, then the msg about installation completing but not updates being installed. Fortunately the downloads appear to be cached. How do I force the update to proceed? *Should* I?

    $ sudo zypper dup
    Loading repository data...
    Reading installed packages...
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these
    repositories are compatible before you continue. See 'man zypper' for more information about this
    command.
    Computing distribution upgrade...

    The following 8 NEW packages are going to be installed:
    android-platform-tools android-platform-tools-bash-completion android-platform-tools-python3
    android-tools-python3 kernel-pae-5.13.8-1.1 libprotobuf28 libprotobuf-lite28 python38-protobuf

    The following package is going to be REMOVED:
    android-tools

    The following 591 packages are going to be upgraded:

    ...

    In cache kernel-pae-5.13.8-1.1.i686.rpm (539/600), 92.6 MiB (288.4 MiB unpacked)
    Retrieving package android-platform-tools-bash-completion-31.0.2-8.2.noarch
    (540/600), 15.3 KiB ( 18.0 KiB unpacked)
    Retrieving: android-platform-tools-bash-completion-31.0.2-8.2.noarch.rpm ..............[not found]
    File './noarch/android-platform-tools-bash-completion-31.0.2-8.2.noarch.rpm' not found on medium '
    https://download.opensuse.org/reposi...SE_Tumbleweed/'
    Abort, retry, ignore? [a/r/i/...? shows all options] (a): i
    Warning: You have chosen to ignore a problem with download or installation of a package which migh
    t lead to broken dependencies of other packages. It is recommended to run 'zypper verify' after th
    e operation has finished.

    ...

    In cache libxine2-1.2.11-166.16.i586.rpm (600/600), 2.9 MiB ( 6.8 MiB unpacked)
    Installation has completed with error.




  3. #3

    Default Re: Update fails with message "installation has completed with error"

    <Pls disregard - adding email subscr>

  4. #4

    Default Re: Update fails with message "installation has completed with error"

    Quote Originally Posted by tomr08 View Post
    Doing a `zypper dup`. 600-odd pkgs to update, 1GB. After pkgs retrieved, ignoring `android-platform-tools` not being found in repo, then the msg about installation completing but not updates being installed. Fortunately the downloads appear to be cached. How do I force the update to proceed? *Should* I?
    I managed to get the update to complete by locking the following pkgs. Presumably the missing `android-platform-tools` is related to some upstream problem. After the successful update, I then unlocked them so as to attempt to replace them next time I do an update. Fortunately I don't use `android-tools` on the box in question.

    android-platform-tools
    android-platform-tools-python3
    android-platform-tools-bash-completion

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •