Results 1 to 3 of 3

Thread: OpenGl: glewInit() throws error. Tumbleweed problem ?

  1. #1

    Default OpenGl: glewInit() throws error. Tumbleweed problem ?

    Hi,

    I'm started a project on OpenGl after a long time on openSUSE Tumbleweed. Calling glewInit() throws the error message
    "glewInit failed: Missing GL version"

    The same program runs on Ubuntu 20.04 without any problem. All other programs using OpenGl (steam, CUDA, ...)
    are working without any problems.

    My question is if someone else is facing problems with OpenGl programming using GLEW library ? If someone wants to try
    out, a simple test program and compiling parameter can be found in this issue in RedHat Bugzilla:

    https://bugzilla.redhat.com/show_bug.cgi?id=1895018

    Thanks a lot !

  2. #2

    Default Re: OpenGl: glewInit() throws error. Tumbleweed problem ?

    I'm having a same problem when running "supertuxkart" on tumbleweed.
    Code:
    ..:: Antarctica Rendering Engine 2.0 ::.. 
    [info   ] IrrDriver: OpenGL version: 4.6 
    [info   ] IrrDriver: OpenGL vendor: Intel Open Source Technology Center 
    [info   ] IrrDriver: OpenGL renderer: Mesa DRI Intel(R) UHD Graphics 630 (CFL GT2) 
    [info   ] IrrDriver: OpenGL version string: 4.6 (Core Profile) Mesa 21.1.6 
    [fatal  ] GLEW: Glew initialization failed with error Missing GL version
    And SuperTuxKart simply just won't run.

    Supertux2 Also have this issue too. Although It'll continue to run but graphics acceleration won't be available on supertux2
    Code:
    
    [WARNING] /home/abuild/rpmbuild/BUILD/SuperTux-v0.6.2-Source/src/video/video_system.cpp:52 Error creating GLVideoSystem-330core, usin
    g GLVideoSystem-20 fallback: GLVideoSystem: GlewError: Missing GL version 
    [WARNING] /home/abuild/rpmbuild/BUILD/SuperTux-v0.6.2-Source/src/video/video_system.cpp:57 Error creating GLVideoSystem-20, using SDL
     fallback: GLVideoSystem: GlewError: Missing GL version
    

  3. #3

    Default Re: OpenGl: glewInit() throws error. Tumbleweed problem ?

    UPDATE: On openSUSE Tumbleweed 20210820 actually fix GLEW Error with Missing GL version.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •