Results 1 to 8 of 8

Thread: cobbler autoinstall

  1. #1

    Default cobbler autoinstall

    Hello,
    I am trying to use cobbler to install opensuse leap 15. I am getting the following errors:
    https://i.imgur.com/jPT9nYQ.png

    Here is my autoyast_install.xml. I haven't seen a autoyast linter...
    https://paste.opensuse.org/4f3d6bc7

  2. #2
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    710

    Default Re: cobbler autoinstall

    Hi browncow999,

    Welcome to this forum.

    Leap 15.1 is EOL since several months. Better go for 15.2 or 15.3.

  3. #3

    Default Re: cobbler autoinstall

    Leap 15.2 and 15.3 are not in the cobbler signatures yet.

  4. #4
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    710

    Default Re: cobbler autoinstall

    Quote Originally Posted by browncow999 View Post
    Leap 15.2 and 15.3 are not in the cobbler signatures yet.
    Hmm, I can't help with cobbler. But 15.2 was released over a year to go. Are you sure you need to rely on a signature that only offers a distro that is out of support i.e. security patches?
    I just quickly checked their website:
    https://cobbler.readthedocs.io/en/la...t-distribution

    AFAIU it's for automated setups. I assume you don't only use it on one machine? Then maybe it's worth the bother to import a newer version?

  5. #5

    Default Re: cobbler autoinstall

    I'll reach out to the developers via git or gitter.im and see if I can get that put in.

  6. #6

    Default Re: cobbler autoinstall

    Either way I need some help fixing my autoinstall.xml. That's what I really need some help with.

  7. #7

    Default Re: cobbler autoinstall

    Cobbler got updated with the correct signatures. I am trying to install OpenSUSE 15.2 LEAP and i'm getting the same errors.

  8. #8
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    710

    Default Re: cobbler autoinstall

    Yeah, sorry. Got carried away with the versions. I can't really help. I have created an autoyast on my system, and for example "profile line 3 ..." is the same as yours:

    Code:
    <profile xmlns="http://www.suse.com/1.0/yast2ns" xmlns:config="http://www.suse.com/1.0/configns">
    Asking the duck for "opening and ending tag mismatch" gives several hits:
    https://access.redhat.com/documentat...s-tag_mismatch
    https://stackoverflow.com/questions/...ine-4-and-head

    It seem a slash is needed to close a tag. But I have no idea of XML code.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •