Results 1 to 8 of 8

Thread: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

  1. #1

    Default No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    On a clean install of Leap 15.3, I cannot install vlc-codecs using the '1-click' install option from opensue-guide.org. I have absolutely no sound. I have tried restarting and installing multiple times with no success. To make this even stranger, I have done the same thing on two other systems with no problems. I did have to restart once for both them, but everything installed and the codecs work.

    The only difference with this machine is that I have it hooked up to a TV via an HDMI cable so that I can work with a really big monitor instead. I have installed Leap 15.3 on this computer using the HDMI-connected TV as the monitor from the start. The TV is a Panasonic. Is there a specific HDMI port I should be plugging into? The screen functions well, but no sound comes from the speakers. I cannot install vlc-codecs either. The only difference between the systems is that this is the only one connected to a TV via an HDMI. I have done this successfully with Leap 15.2 before with no issues, though to a LG TV. Any ideas what I should try to fix these issues?

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,303

    Default AW: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    No vlc-codecs from Packman:
    Code:
    LANG=C zypper se -s vlc
    Loading repository data...
    Reading installed packages...
    
    S  | Name                        | Type       | Version                          | Arch   | Repository
    ---+-----------------------------+------------+----------------------------------+--------+-----------
       | libvlc-gtk0                 | package    | 0.6.8.20160609.6575c25-pm153.2.4 | x86_64 | packman
       | libvlc-gtk0-debuginfo       | package    | 0.6.8.20160609.6575c25-pm153.2.4 | x86_64 | packman
    i+ | libvlc5                     | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | libvlccore9                 | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
       | nulloy-vlc                  | package    | 0.8.2.pre61qt5.9b036e-bp153.1.25 | x86_64 | OSS
       | phonon4qt5-backend-vlc      | package    | 0.11.1-bp153.1.27                | x86_64 | OSS
       | phonon4qt5-backend-vlc-lang | package    | 0.11.1-bp153.1.27                | noarch | OSS
       | python2-python-vlc          | package    | 3.0.12118-bp153.1.1              | noarch | OSS
    i  | python3-python-vlc          | package    | 3.0.12118-bp153.1.1              | noarch | OSS
    i+ | vlc                         | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
       | vlc-beta                    | package    | 20210710.485005a0b6-pm153.1.1    | x86_64 | packman
       | vlc-beta                    | srcpackage | 20210710.485005a0b6-pm153.1.1    | noarch | packman
       | vlc-beta-debuginfo          | package    | 20210710.485005a0b6-pm153.1.1    | x86_64 | packman
       | vlc-beta-debugsource        | package    | 20210710.485005a0b6-pm153.1.1    | x86_64 | packman
    i+ | vlc-codec-gstreamer         | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | vlc-devel                   | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | vlc-jack                    | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | vlc-lang                    | package    | 3.0.13-bp153.1.1                 | noarch | OSS
    i+ | vlc-noX                     | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | vlc-opencv                  | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | vlc-qt                      | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
    i+ | vlc-vdpau                   | package    | 3.0.13-bp153.1.1                 | x86_64 | OSS
       | yarock-vlc                  | package    | 1.4.0-lp153.6.2                  | x86_64 | KDE-Extra
       | yarock-vlc-debuginfo        | package    | 1.4.0-lp153.6.2                  | x86_64 | KDE-Extra

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,098

    Default Re: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    Did you do the "Vendor Switch" to Packman?
    Code:
    zypper dup --from packman
    Henk van Velden

  4. #4

    Default Re: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    Yikes, it is listed here as the thing to do, and this : https://en.opensuse.org/SDB:Installi...n_repositories

    Hi, it seems the 'vlc-codecs' is recognized in the vlc-beta player:

    'vlc-codecs' not found in package names. Trying capabilities.
    'vlc-beta' providing 'vlc-codecs' is already installed.


    Though I am still left without sound. I tried going to Youtube and playing a random video to test the sound, and nothing plays. Yes, the vendor switch was done and vlc-beta is from the Packman repo.
    Last edited by JDoe; 01-Aug-2021 at 03:08. Reason: Added that repo switch was done

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,303

    Default AW: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    Install pavucontrol and see, if your sound is working when you start it.

  6. #6

    Default Re: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    This was done prior to me posting on this forum. Before it showed sound movement, but listed a 'Dummy' output. This time upon restart, it clearly lists a Cedar HDMI cable. Going over to the 'playback' tab shows that under Firefox sound is playing, as the bar moves. Unfortunately no sound is produced through the speakers.

  7. #7

    Default Re: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    Fixed it. Although it was still showing a red line through the speaker icon in pavucontrol, i went back down to the volume icon in the lower right-hand corner of the KDE desktop. There I opened up the menu and found two listed outputs - the HDMI cable and headphones (there is nothing plugged in to the headphone jack). I noticed that 'headphones' was automatically selected as the default output. I simply switched it and everything works! Thanks to both of you for your help, and sorry for the trouble.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,098

    Default Re: No Sound and Can't Install vlc-codecs on clean install of Leap 15.3

    That is no trouble. That is why we are here for. Just listening and suggesting until you get the "Eureka" moment.
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •