Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: odd KDE Desktop image and no images for wallpaper thumbs

  1. #1

    Default odd KDE Desktop image and no images for wallpaper thumbs

    Hello, All. After serious problems with my last home-built computer, I rebuilt it with a geforce 3070 video card (only one I could get). Installed the geforce driver using one-click. Resolution works, but the default wallpaper is odd - limited to say 3 colours and chunky-block. And thumb images for new wallpaper will not resolve (all alike - black, essentially, no picture). I can add widgets. But the wallpaper is something out of DOS. Don't know how to get a screen shot to show the problem (seems my account will not let me add attachments anyway). Any suggestions how I can get proper graphics in 15.3 leap?

    Thanks,
    Mark

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Quote Originally Posted by MarkH View Post
    Hello, All. After serious problems with my last home-built computer, I rebuilt it with a geforce 3070 video card (only one I could get). Installed the geforce driver using one-click. Resolution works, but the default wallpaper is odd - limited to say 3 colours and chunky-block. And thumb images for new wallpaper will not resolve (all alike - black, essentially, no picture). I can add widgets. But the wallpaper is something out of DOS. Don't know how to get a screen shot to show the problem (seems my account will not let me add attachments anyway). Any suggestions how I can get proper graphics in 15.3 leap?

    Thanks,
    Mark
    Hi
    Hopefully the one click worked..... Can you show the output from;

    Code:
    zypper lr -d
    
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    
    zypper se -si nvidia
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Ah, I notice an error message that plasma closed unexpectedly:

    Executable: plasmashell PID: 2669 Signal: Segmentation fault (11) Time: 31/07/2021 18:19:41

    Application: Plasma (plasmashell), signal: Segmentation fault

    [KCrash Handler]

    #4 0x00007f56fffab756 in ?? () from /usr/lib64/libQt5Qml.so.5

    #5 0x00007f56ffe6a4d6 in ?? () from /usr/lib64/libQt5Qml.so.5

    #6 0x00007f56ffe6a63a in ?? () from /usr/lib64/libQt5Qml.so.5

    #7 0x00007f56fff0058b in QV4::Runtime::method_iteratorNext(QV4::ExecutionEngine*, QV4::Value const&, QV4::Value*) () from /usr/lib64/libQt5Qml.so.5
    #8 0x00007f56c5c4ec0d in ?? ()
    #9 0x0000000000000000 in ?? ()

    [Inferior 1 (process 2669) detached]


    Is this a function of some bug in the nvidia driver?

    Here is the hardware info on the video card and driver:

    a1:00.0 VGA compatible controller [0300]: Nvidia corporation GA104 [GeForce RTX 3070] [10de:2484] (rev a1)

    sysystem ASUSTech
    Kernel driver in use: nvidia
    Kernel modules : nouveau, nvidia_dvm, nvidia.


    Does that help identify the problem?

    Many kind thanks.
    Mark

  4. #4

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Hello, Malcolm. Here be the results. Hopefully they are readable. Cheers. Mark.




    Hi
    Hopefully the one click worked..... Can you show the output from;

    Code:
    zypper lr -d
    
    ocalhost:~ # zypper lr -d
    #  | Alias                           | Name                                                                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                          | Service
    ---+---------------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------------------------------+--------
     1 | download.nvidia.com-$releasever | nVidia Graphics Drivers                                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/leap/15.3                                               | 
     2 | openSUSE-Leap-15.3-1            | openSUSE-Leap-15.3-1                                                                        | No      | ----      | ----    |   99     | NONE   | hd:/?device=/dev/disk/by-id/usb-Kingston_DataTraveler_3.0_08606E6D418AF261C714EBF3-0:0-part1 | 
     3 | repo-backports-debug-update     | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/update/leap/15.3/backports_debug/                               | 
     4 | repo-backports-update           | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/backports/                                     | 
     5 | repo-debug                      | Debug Repository                                                                            | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/                          | 
     6 | repo-debug-non-oss              | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/                      | 
     7 | repo-debug-update               | Update Repository (Debug)                                                                   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/oss/                                     | 
     8 | repo-debug-update-non-oss       | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/non-oss/                                 | 
     9 | repo-non-oss                    | Non-OSS Repository                                                                          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/                            | 
    10 | repo-oss                        | Main Repository                                                                             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/distribution/leap/15.3/repo/oss/                                | 
    11 | repo-sle-debug-update           | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/update/leap/15.3/sle/                                     | 
    12 | repo-sle-update                 | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/sle/                                           | 
    13 | repo-source                     | Source Repository                                                                           | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/                         | 
    14 | repo-update                     | Main Update Repository                                                                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/oss                                            | 
    15 | repo-update-non-oss             | Update Repository (Non-Oss)                                                                 | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/leap/15.3/non-oss/                                       | 
    localhost:~ # 
    
    
    
    /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    
    ocalhost:~ # /sbin/lspci -nnk | egrep -A3 "VGA|Display|3D"
    a1:00.0 VGA compatible controller [0300]: NVIDIA Corporation GA104 [GeForce RTX 3070] [10de:2484] (rev a1)
            Subsystem: ASUSTeK Computer Inc. Device [1043:87c1]
            Kernel driver in use: nvidia
            Kernel modules: nouveau, nvidia_drm, nvidia
    localhost:~ # 
    
    
    
    
    zypper se -si nvidia
    
    localhost:~ # zypper se -si nvidia
    Loading repository data...
    Reading installed packages...
    
    S  | Name                      | Type    | Version                      | Arch   | Repository
    ---+---------------------------+---------+------------------------------+--------+------------------
    i+ | kernel-firmware-nvidia    | package | 20210208-2.4                 | noarch | Main Repository
    i  | nvidia-computeG05         | package | 460.84-lp153.40.1            | x86_64 | (System Packages)
    i  | nvidia-gfxG05-kmp-default | package | 460.84_k5.3.18_57-lp153.40.1 | x86_64 | (System Packages)
    i  | nvidia-glG05              | package | 460.84-lp153.40.1            | x86_64 | (System Packages)
    i+ | x11-video-nvidiaG05       | package | 460.84-lp153.40.1            | x86_64 | (System Packages)
    localhost:~ #
    Last edited by malcolmlewis; 31-Jul-2021 at 17:46. Reason: Add missing code tag

  5. #5
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Hi
    Above looks fine, since you have seen a seg fault, one wonders if it the new card (that's a beast of a card ) and Plasma?
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  6. #6

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Above looks fine, since you have seen a seg fault, one wonders if it the new card (that's a beast of a card ) and Plasma?
    The card was an accident and beyond over the top - alas, affordable video cards in Canada are non-existent.

    If a driver fault, I assume a bug report is needed?

    I so miss my old ATI and Matrox cards.

  7. #7
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Quote Originally Posted by MarkH View Post
    The card was an accident and beyond over the top - alas, affordable video cards in Canada are non-existent.

    If a driver fault, I assume a bug report is needed?

    I so miss my old ATI and Matrox cards.
    Hi
    I only use the hard way for nvidia drivers, 470.57.02 on Leap 15.3 (GT710) and Tumbleweed (GT1030), might be worth a shot only 'After' removal on the nvidia driver as the bug report may not be accepted with Plasma and nvidia driver, I'm a GNOME user, perhaps others can offer insights....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  8. #8

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Quote Originally Posted by malcolmlewis View Post
    Hi
    I only use the hard way for nvidia drivers, 470.57.02 on Leap 15.3 (GT710) and Tumbleweed (GT1030), might be worth a shot only 'After' removal on the nvidia driver as the bug report may not be accepted with Plasma and nvidia driver, I'm a GNOME user, perhaps others can offer insights....
    Hello, Malcolm. After a time feeling as if I were walking on the edge of a cliff, I was able (1) to remove the 'one click' installation' and (2) to complete the hard way to install the nvidia driver (the current March version). I am assuming adding 'nomodeset 3' on reboot before install was sufficient to shut down all of the X system. Anyway, proper resolution appears.

    However, I am not quite confident my system is there, yet. Would you (or another reader) kindly post a screenshot of the expected KDE plasma desktop created on first install? My desktop wallpaper appears to be a chunkyblock image of a sea-coast without any details at all and with funky colours (brown colour to the left, and a white/blueish colour matrix to the right with a jagged edge dividing the two parts). The thumbnails of optional wallpapers are unresolved - black background with 7 strips of colour bands drawn horizontally in the middle of each thumbnail image. (My account does not allow me to post attachments, and anyway, I have no idea how to do a screen capture and post it).

    Thank you, Malcolm, for all the kind help.

    Cheers,
    Mark

  9. #9
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,700
    Blog Entries
    15

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Quote Originally Posted by MarkH View Post
    Hello, Malcolm. After a time feeling as if I were walking on the edge of a cliff, I was able (1) to remove the 'one click' installation' and (2) to complete the hard way to install the nvidia driver (the current March version). I am assuming adding 'nomodeset 3' on reboot before install was sufficient to shut down all of the X system. Anyway, proper resolution appears.

    However, I am not quite confident my system is there, yet. Would you (or another reader) kindly post a screenshot of the expected KDE plasma desktop created on first install? My desktop wallpaper appears to be a chunkyblock image of a sea-coast without any details at all and with funky colours (brown colour to the left, and a white/blueish colour matrix to the right with a jagged edge dividing the two parts). The thumbnails of optional wallpapers are unresolved - black background with 7 strips of colour bands drawn horizontally in the middle of each thumbnail image. (My account does not allow me to post attachments, and anyway, I have no idea how to do a screen capture and post it).

    Thank you, Malcolm, for all the kind help.

    Cheers,
    Mark
    Hi
    Just a 3 should have sufficed... Can you post the output from (please install xdpyinfo);

    Code:
    inxi -Gxxz
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  10. #10

    Default Re: odd KDE Desktop image and no images for wallpaper thumbs

    Hello, Malcolm.

    Output:
    localhost:~ # inxi -Gxxz
    Graphics: Device-1: NVIDIA GA104 [GeForce RTX 3070] vendor: ASUSTeK driver: nvidia v: 470.57.02 bus ID: a1:00.0
    chip ID: 10de:2484
    Display: server: X.Org 1.20.3 compositor: kwin_x11 driver: nvidia resolution: 1920x1200~60Hz s-dpi: 75
    OpenGL: renderer: NVIDIA GeForce RTX 3070/PCIe/SSE2 v: 4.6.0 NVIDIA 470.57.02 direct render: Yes

    Also, I appear to have no icons beside each app name in the application launcher. I noticed this happened when I uninstalled the one-click driver.

    Cheers,
    Mark

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •