Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: No GUIs will open - Qt - Badwindow

  1. #1

    Default No GUIs will open - Qt - Badwindow

    Since installing 15.3 (new installation, not upgrade) with kde a few weeks back I have experienced the following:
    On several occasions, immediately after booting, no GUI's will open (tried dolphin, firefox, okular, Kate etc). The only window available is a Konsole, which I always leave open when closing down - that works as expected. Even the shutdown dialogue does not work and I have to shutdown by pressing and holding the power button. Normally, on reboot, things are back to normal but on one occasion I had to reboot twice before I got a working session. The following is a snippet from /var/log/warn during such an episode.
    2021-07-26T08:07:11.832957+01:00 localhost dolphin[2407]: qt.qpa.xcb: could not connect to display :0
    2021-07-26T08:07:11.833180+01:00 localhost dolphin[2407]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    2021-07-26T08:07:11.837518+01:00 localhost dolphin[2407]: Failed to create wl_display (No such file or directory)
    2021-07-26T08:07:11.837790+01:00 localhost dolphin[2407]: qt.qpa.plugin: Could not load the Qt platform plugin "wayland" in "" even though it was found.
    2021-07-26T08:07:11.837951+01:00 localhost dolphin[2407]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.#012#012Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
    2021-07-26T08:07:11.867360+01:00 localhost kwin_x11[1755]: qt.qpa.xcb: QXcbConnection: XCB error: 3 (BadWindow), sequence: 15422, resource id: 31457670, major code: 18 (ChangeProperty), minor code: 0
    2021-07-26T08:07:42.416949+01:00 localhost dbus-daemon[1661]: [session uid=1000 pid=1661] Activating service name='org.kde.LogoutPrompt' requested by ':1.13' (uid=1000 pid=1741 comm="/usr/bin/ksmserver ")
    2021-07-26T08:07:42.503465+01:00 localhost org.kde.LogoutPrompt[2412]: No protocol specified
    2021-07-26T08:07:42.503694+01:00 localhost ksmserver-logout-greeter[2412]: qt.qpa.xcb: could not connect to display :0
    2021-07-26T08:07:42.503884+01:00 localhost ksmserver-logout-greeter[2412]: qt.qpa.plugin: Could not load the Qt platform plugin "xcb" in "" even though it was found.
    2021-07-26T08:07:42.504028+01:00 localhost ksmserver-logout-greeter[2412]: This application failed to start because no Qt platform plugin could be initialized. Reinstalling the application may fix this problem.#012#012Available platform plugins are: wayland-org.kde.kwin.qpa, eglfs, linuxfb, minimal, minimalegl, offscreen, vnc, wayland-egl, wayland, wayland-xcomposite-egl, wayland-xcomposite-glx, xcb.
    2021-07-26T08:07:42.508538+01:00 localhost org.kde.LogoutPrompt[2412]: Invalid MIT-MAGIC-COOKIE-1 key
    2021-07-26T08:07:42.509898+01:00 localhost dbus-daemon[1661]: [session uid=1000 pid=1661] Activated service 'org.kde.LogoutPrompt' failed: Process org.kde.LogoutPrompt received signal 6
    2 Maybe this indicates that the problem has something to with Qt. Even when the system is running apparently normally, I have noticed lots of these BadWindow entries in /var/log/warn - currently 3477 since July 4. These entries also appear to be associated with the following behaviour: clicking on a file to open it in its associated application (say Kate) does not succeed but opening the application first then using the "Open" dialogue does work. This behaviour is transient and may not be present earlier or later in the session.

    I have been using the same Toshiba Satellite laptop for quite a few years, with different releases (not 15.2 but certainly 15.1 and 42.3) but have only seen these problems with 15.3

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,358

    Question Re: No GUIs will open - Qt - Badwindow

    @pianomalc:

    Are you trying to use Wayland rather than X.Org?

  3. #3

    Default Re: No GUIs will open - Qt - Badwindow

    As far as I am aware, I made no customizations to the basic installation of 15.3 which might have influenced this

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,109

    Default Re: No GUIs will open - Qt - Badwindow

    Assuming that you mean with "after booting" not only after booting, but also after login. I also assume you use KDE.

    Did you try to use another user, a fresh one?
    Henk van Velden

  5. #5
    Join Date
    Jun 2011
    Location
    Germany
    Posts
    430

    Default Re: No GUIs will open - Qt - Badwindow

    Quote Originally Posted by pianomalc View Post
    As far as I am aware, I made no customizations to the basic installation of 15.3 which might have influenced this
    I can't test it right now, but I think in the login screen you can choose which session you want to start. If you don't want to use Wayland you can try and make sure to open a fresh X.Org session. Same issue there?

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,358

    Question Re: No GUIs will open - Qt - Badwindow

    @pianomalc:

    When you performed the installation, did you choose “Automatic login” for the user you configured?
    • If you did, you'll need to use a Virtual Terminal (VT) to reconfigure the system –


    1. After the system has booted, press the following 3 keys simultaneously – <Ctrl-Alt-F1>.

    2. You'll be presented with a blank screen – upper left a login prompt.
    3. Login as the user “root” – you set the password at installation time.
    4. A the command line prompt, type “yast2”.
    5. You'll be presented with a graphical interface which you navigate by means of the <Tab> key, the <Arrow> keys and, the Function keys <F1 .. F12>. Yet another navigation is by means of the <Alt> key plus a letter key – <A .. Z>.
    6. With the <Arrow-Down> key (↓) navigate to “Security and Users”.
    7. Change your user such that, automatic login doesn't happen.

    The YaST user management is documented here – <https://doc.opensuse.org/documentati...-userman.html#>.
    Using YaST in text mode is documented here – <https://doc.opensuse.org/documentati...ast-text.html#>.

  7. #7

    Default Re: No GUIs will open - Qt - Badwindow

    Can confirm that I did indeed mean after booting and logging-in and am using KDE. I haven't configured automatic login and I see now that there are 3 options for the desktop : Plasma, Plasma (Full Wayland) and Plasma (Wayland). Since I didn't even realize that there were options, I must have been going with the default, which I guess is Plasma. I suppose that I could try the other options to see if they behave in the same way.

    With regard to trying a new clean user, the difficulty is that the problem doesn't happen every day - I can go more than a week with no problem or it can happen 2 days running. Once it does happen, I would need to be able to switch user from the keyboard, since the Leave dialogue, which includes Switch User, doesn't work in that situation. Using su I can switch user in the Konsole window, which is the only thing that works but what I would need is to start a whole new session from the keyboard and I don't know if that is even possible.

  8. #8
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,109

    Default Re: No GUIs will open - Qt - Badwindow

    Quote Originally Posted by pianomalc View Post
    Can confirm that I did indeed mean after booting and logging-in and am using KDE. I haven't configured automatic login and I see now that there are 3 options for the desktop : Plasma, Plasma (Full Wayland) and Plasma (Wayland). Since I didn't even realize that there were options, I must have been going with the default, which I guess is Plasma. I suppose that I could try the other options to see if they behave in the same way.
    Thanks for the clarification. I also think that Plasma is the default and hat you most probably used it all the time.
    Quote Originally Posted by pianomalc View Post
    With regard to trying a new clean user, the difficulty is that the problem doesn't happen every day - I can go more than a week with no problem or it can happen 2 days running. Once it does happen, I would need to be able to switch user from the keyboard, since the Leave dialogue, which includes Switch User, doesn't work in that situation. Using su I can switch user in the Konsole window, which is the only thing that works but what I would need is to start a whole new session from the keyboard and I don't know if that is even possible.
    Alas, problems that are showing up irregular are probably the most difficult to solve as long as nobody understands the circumstances that create them
    Henk van Velden

  9. #9

    Default Re: No GUIs will open - Qt - Badwindow

    As luck would have it, the first time I booted and logged in this morning, the problem was there. This time I tried launching applications (I used kate and okular) from the Konsole command line. They failed with basically the same error messages as when launched by clicking on the desktop icon, although now of course explicitly linked to the commands that generated them. Unfortunately, I was so rusty on using linux from the command line that I could not remember "script" for recording the session. I also tried using strace with these applications, directing stderr to files, so I do have that output. To the untrained eye, I couldn't see anything enlightening in the output but maybe someone else would be able to spot something. However, I haven't spotted any option for attaching files to the post.

    Finally, I went to the Leave dialogue on the desktop and selected Switch User. I had expected nothing to happen, as when I select Shutdown, but was instead confronted with a new black screen with the following in bold letters:

    The screen locker is broken and unlocking is not possible anymore.
    In order to unlock switch to a virtual terminal (Ctrl+Alt+F2), login and execute the command loginctl unlock-session 2
    Afterwards switch back to the running session (Ctrl+Alt+F7)

    I tried these keystrokes to no effect and ended up resorting to the power button as normal. On reboot, everything was fine again.

  10. #10
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,109

    Default Re: No GUIs will open - Qt - Badwindow

    For posting computer info here.

    There is an important, but not easy to find feature on the forums.

    Please in the future use CODE tags around copied/pasted computer text in a post. It is the # button in the tool bar of the post editor. When applicable copy/paste complete, that is including the prompt, the command, the output and the next prompt.

    An example is here: Using CODE tags Around your paste.


    For very long text and screen shots, there is https://susepaste.org/

    For text to susepaste you do not need copy/paste, you can pipe output to the sustepaste tool
    Code:
    whatevercommand > susepaste -e 0
    see
    Code:
    man susepaste
    It will provide you with the link to be posted.
    Henk van Velden

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •