Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Please help me obtain sound production in Leap 15.3.

  1. #11
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,863
    Blog Entries
    39

    Default Re: Please help me obtain sound production in Leap 15.3.

    Quote Originally Posted by 2009Newbie View Post
    As a clarification and explanation in VirtualBox’s “Settings, Audio” I have only the following three choices listed in a drop-down list box with “Audio Controller:” printed beside that drop-down list box: “ICH AC97,” “Intel HD Audio,” and “SoundBlaster 16.” I concluded from https://documentation.help/VirtualBox/oh03s08.html on the Internet that the “ICH AC97” “Audio Controller” is not supported in Microsoft Windows operating systems of Windows 7 or newer.
    I skimmed through that link and I could not see what you were talking about - and can not see (yet) as to how you can to that conclusion. I assume to be certain, you did a test on the other drop down menu selections? Yes?

    Is this what you were referring to:
    Intel HD Audio support was added with VirtualBox 4.0 because Windows 7 and later (as well as 64-bit Windows Vista) do not support the Intel AC'97 controller out of the box
    Is ICH AC97 the same as Intel AC'97 controller ? < not sure > I don't know the exact acronym means.


    Quote Originally Posted by 2009Newbie View Post
    Note that even though I have the software package “pulseaudio” installed in Leap 15.3 that in my case “PulseAudio” does not appear in that drop-down list box.
    In the example I gave 'pulseaudio' was the choice for the HOST system. In your case the HOST is Windows-10. In my case, my host was LEAP-15.2 and I was running LEAP-15.3 as the VirtualBox Guest. Since Windows-10 doesn't run 'pulseaudio' its clear you won't see 'pulseaudio' as a 'HOST' option.

    I suspect deano_ferrari has a setup MUCH MUCH closer to yours than my setup.

    I confess "I don't do Windows" ... and if I am in a hurry and for some reason need to boot to windows on my PC (typically I only boot to MS-Windows to do a check disk on an NTFS formatted external hard disk - which happens once or twice a year) I will boot to Windows with a mix of fear and trepidation. Given my Windows partition (that came with PC) is rarely booted and never updated, trying to boot to it is best described as annoying (for me). I suspect I would need to run Windows more often (than twice per year) for it to be useful for me ...

    Quote Originally Posted by 2009Newbie View Post
    Here is what made me suspicious that the failure of sound production in my Leap-15.3 installation might relate to some “boot” failures using the Linux kernel 5.3.18-59.16.1.x86_64-default.--While earlier I had VirtualBox’s “Settings, Audio, Audio Controller:” set to “ICH AC97,” I noticed that during “booting” into Leap 15.3 with the Linux kernel 5.3.18-59.16.1.x86_64-default that on my Windows-10 taskbar the microphone icon appeared and disappeared, appeared and disappeared! Such appearing and disappearing was fortunately easy to notice with open eyes. This makes me suspect that there might have been some instability or problem relating to sound software in such “boots” into Leap 15.3 which might have sometimes caused problems “booting” into Leap 15.3. And that seems bad.
    Honestly? I would have come to the opposite conclusion, and concluded the 5.3.18-59.16.1.x86_64-preempt was bad - and that some other issue present.
    Last edited by oldcpu; 27-Jul-2021 at 22:22.

  2. #12

    Default Re: Please help me obtain sound production in Leap 15.3.

    Thank you again, deano_ferrari, for trying to help me. Here I skip mentioning some of the things which did not work for me.

    1) As a “root” user I entered
    Code:
    setup-pulseaudio –-enable
    and saw the computer software’s “response” of “Enabling PulseAudio for ALSA” (Advanced Linux Sound Architecture), et cetera. Then I rebooted into Leap 15.3 using the Linux kernel 5.3.18-59.16.1.x86_64-preempt and, after entering as a regular user the command you earlier provided me of
    Code:
    systemctl --user list-unit-files | egrep -i 'pipe|pulse'
    , obtained the surprising result of “disabled disabled” for “pulseaudio.service”! The service pipewire.service has also been shown as “disabled disabled” there. Another strange result is that pipewire.socket was shown as “enabled enabled” in that list; yet after I as a “root” user entered
    Code:
    systemctl disable pipewire.socket
    , the computer software’s “response” was
    Code:
    Failed to disable unit: Unit file pipewire.socket does not exist.
    These contradicting results regarding whether pipewore.socket exists or not in my Leap-15.3 installation cause me to think that there might be an error in some computer software regarding detecting the existence of pipewire.socket.

    2) I learned that within my “home” directory of the form /home/MY_HOME_DIRECTORY_NAME that there is a normally hidden directory named .config/pulse/. That directory has a folder and some files in it, which I could see by opening my preferred Leap-15.3 File Manager Konqueror as a “root” user, but not a file named daemon.conf or /daemon.conf, which according to the “response” to the command
    Code:
    start-pulseaudio-x11
    one could expect to see there.

    3) From https://www.webosose.org/docs/tools/...or-user-guide/ on the Internet I read that in VirtualBox’s (Settings, Audio) one should set the “Host Audio Driver” to “PulseAudio” for, in effect, an Ubuntu “host” operating system or “Windows DirectSound” for a Windows “host” operating system. So for in my case a Windows-10 “host” operating system I wonder if I am not supposed to see PulseAudio among the listed items in the drop-down list box beside VirtualBox’s Settings, Audio’s “Host Audio Driver:”. And this speculation of mine leads me to guess that since the poster oldcpu does have PulseAudio selected there that he might have a Linux “host” operating system rather than a Windows “host” operating system on the computer in which he has Leap 15.3 installed as a “guest” operating system or Virtual “Machine” (VM) in VirtualBox. I guess that poster oldcpu might have Leap 15.3 installed as both the “host” and “guest” operating systems, with VirtualBox installed in his “host” operating system, in posting number eight in this “thread” of postings.

    4) I unfortunately had a failure when trying to open the Pulse Audio Volume Control computer program pavucontrol as either a “root” or a regular user.

    5) Is there a set of instructions which someone might have produced for configuring PulseAudio and/or sound production to work specifically in a 64-bit, Leap-15.3, Linux operating system? If not, it might be good if someone would produce such a set of instructions and upload it to a Web page. Complexity: The working instructions for sound production in Leap 15.3 might have to include what to do regarding PulseAudio, ALSA, and pipewire computer software.

  3. #13

    Default Re: Please help me obtain sound production in Leap 15.3.

    Sorry, I misspelled pipewire at least once.

  4. #14
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,318
    Blog Entries
    1

    Default Re: Please help me obtain sound production in Leap 15.3.

    Quote Originally Posted by 2009Newbie View Post
    Thank you again, deano_ferrari, for trying to help me. Here I skip mentioning some of the things which did not work for me.

    1) As a “root” user I entered
    Code:
    setup-pulseaudio –-enable
    and saw the computer software’s “response” of “Enabling PulseAudio for ALSA” (Advanced Linux Sound Architecture), et cetera. Then I rebooted into Leap 15.3 using the Linux kernel 5.3.18-59.16.1.x86_64-preempt and, after entering as a regular user the command you earlier provided me of
    Code:
    systemctl --user list-unit-files | egrep -i 'pipe|pulse'
    , obtained the surprising result of “disabled disabled” for “pulseaudio.service”! The service pipewire.service has also been shown as “disabled disabled” there. Another strange result is that pipewire.socket was shown as “enabled enabled” in that list; yet after I as a “root” user entered
    Code:
    systemctl disable pipewire.socket
    , the computer software’s “response” was
    Code:
    Failed to disable unit: Unit file pipewire.socket does not exist.
    These contradicting results regarding whether pipewore.socket exists or not in my Leap-15.3 installation cause me to think that there might be an error in some computer software regarding detecting the existence of pipewire.socket.
    Please, when running commands show us the command and full output generated. The systemd units in question are for the user instance, so disabling would be more like...
    Code:
    systemctl --user disable --now foo.service
    Show us the output of
    Code:
    zypper se -s pipe pulse
    Last edited by deano_ferrari; 28-Jul-2021 at 14:34.
    openSUSE Leap 15.3; KDE Plasma 5

  5. #15
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,318
    Blog Entries
    1

    Default Re: Please help me obtain sound production in Leap 15.3.

    Quote Originally Posted by 2009Newbie View Post

    4) I unfortunately had a failure when trying to open the Pulse Audio Volume Control computer program pavucontrol as either a “root” or a regular user.
    It needs to be run as the user. Can you elaborate more about the error encountered when running it as user?

    Report back with output of
    Code:
    journalctl -b |grep pulse
    openSUSE Leap 15.3; KDE Plasma 5

  6. #16
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,318
    Blog Entries
    1

    Default Re: Please help me obtain sound production in Leap 15.3.

    Quote Originally Posted by 2009Newbie View Post
    5) Is there a set of instructions which someone might have produced for configuring PulseAudio and/or sound production to work specifically in a 64-bit, Leap-15.3, Linux operating system? If not, it might be good if someone would produce such a set of instructions and upload it to a Web page. Complexity: The working instructions for sound production in Leap 15.3 might have to include what to do regarding PulseAudio, ALSA, and pipewire computer software.
    These may be of value to you
    https://en.opensuse.org/Sound_troubleshooting
    https://en.opensuse.org/SDBulseaudio
    openSUSE Leap 15.3; KDE Plasma 5

  7. #17

    Default Re: Please help me obtain sound production in Leap 15.3.

    Concerning item 5 in my previous posting in this “thread” postings I think it would have been better if I had instead typed there “a 64-bit, Leap-15.3, openSUSE, Linux operating system.” And sorry, I should have included a direct statement in that posting of

    I have yet to succeed in the consistent production of desired sound in my Leap-15.3 installation.

    Question: In a terminal computer program in a Leap-15.3 operating system how do you people capture your entered commands and the “responses” of computer software to them? Below you can see my failed and gratefully successful methods for such capturing.

    I. Very Detailed Writing Concerning Methods of Capturing Terminal Commands and Computer-Software “Responses” to Them That Some Readers Who Already Know How to Do Such Capturing May Want to Skip Reading

    i. My Failed Method

    I tried to capture text from LXTerminal, the terminal program I have been using in Leap 15.3 using the command “script” (reference: https://www.redhat.com/sysadmin/linux-script-command on the Internet). But I failed in this regard.---One such output file following the input of the “script” command and terminating a text-capturing terminal-program session by pressing the Ctrl and D keys was automatically named “typescript,” which I found in my “home” directory of the form /home/MY_HOME_DIRECTORY. When I opened that file in the computer programs KWrite and I think also Kate, it contained some text that I had I typed. But it also contained some strange-looking characters I did not want to see. So in my case clearly there was a formatting mismatch between the format used in LXTerminal and the format or formats used in KWrite and Kate at that time. And after I entered the command
    Code:
    script --t=terminal.txt
    and terminated another session with the “Ctrl”- and “D”-labeled keys of my computer keyboard, the output file terminal.txt contained none of the text I typed and contained mostly, if not entirely digits. So I abandoned that “script” way of attempting to capture commands and “responses” from a session using the terminal computer program LXTerminal.

    ii. My Gratefully Successful Method

    I may have an instance of the Mozilla Firefox Web browser open in my Windows-10, “host” operating system. And in that Web browser I may have my openSUSE “forum” posting page open. And I may often do my typing in a LibreOffice Writer document in my Windows-10 operating system and afterward copy and “paste” my typed text from that Writer document into my openSUSE “forum” posting using “Ctrl”- and “C”-labeled keys for copying and “Ctrl”- and “V”-labeled keys for the “pasting” of text. So here is gratefully my successful way of capturing LXTerminal commands and “responses” to them in my “guest,” Leap-15.3, Linux operating system. Gratefully the copying and “pasting” of text between my “host,” Windows-10 and “guest,” Leap-15.3 operating systems is working via VirtualBox 6.1.22’s “Settings, General” with on the “Advanced” tab there in a drop-down list box beside “Shared Clipboard:” having “Bidirectional” selected (Although probably not necessary in this regard, in addition I also have “Bidirectional” selected in a drop-down list box beside “Drag’n’Drop:”.) So in the computer program LXTerminal in my Leap-15.3 operating system opened in the Lightweight X Windows System, version 11 (X11), Desktop Environment (LXDE) I can move an “I”-beam-looking symbol over LXTerminal by moving a finger over my notebook computer’s touchpad to the place where I want to start copying characters from LXTerminal. Then I need to simultaneously do three things: a) Hold down the left button between my computer’s touchpad and my chest with my right hand’s index finger. b) Move my right hand’s middle finger horizontally and vertically over the touchpad to highlight the text I wish to copy. And c) I need to use my eyes to see the progression of the highlighting of the text as I move my right hand’s middle finger over my computer’s touchpad. (Users of desktop computers should substitute “mouse” for “touchpad” in my above writing and “mouse’s” left button for my computer’s left button.) Then after I have all of the text I want to copy highlighted I can release my right hand’s index finger from the left button between the touchpad and my chest. And I can move the middle finger of my right hand over my computer’s touchpad while watching the “I”-beam-looking symbol move to over LXTerminal’s “Edit” “menu” item. And when that occurs I can then with the index finger of my right hand press down once on that left button. That opens a drop-down list for that “menu” item “Edit.” So then I need to move the middle finger of my right hand down until the “I”-beam-looking symbol lies on top of the word “Copy”. And then I should press down once with the index finger of my right hand on the left button of my computer that I have been discussing here. (Or alternatively one can simultaneously press and hold down the “Shift”- and “Ctrl”-labeled keys and briefly press the “C”-labeled key to accomplish such copying.) That action should place all of the highlighted text into the computer “clipboard,” which is a portion of Random Access Memory (RAM, https://www.techbout.com/clear-clipb...dows-10-26155/). Then in my Windows operating system I can press the “Ctrl”- and “V”-labeled keys to “paste” the copied text from the computer “clipboard” into my LibreOffice Writer document. And finally after I have that document looking at least approximately the way I want it to look I can in a similar way copy and “paste” the text I want to copy into my openSUSE “forum” posting, again by pressing the “Ctrl”- and “C”-labeled keys for copying the text from the Writer document into the computer “clipboard” and afterward by pressing the “Ctrl” and “V” keys while a cursor symbol is visible in the "body" of my to-be openSUSE “forum” posting.

  8. #18

    Default Re: Please help me obtain sound production in Leap 15.3.

    II. Moving Ahead With Data and a Discussion of the Problems With Hopefully the Desired Short-Term Future Result of Being Able to Hear Sound in My Leap-15.3 Installation

    As you may have already realized, this letter is too long to be just one posting. So it continues beyond this posting. This section II contains the results of commands that I inputted, with some of them at least overlapping commands kindly suggested to me by poster deano_ferrari. My Leap-15.3 user name is "newbie."

  9. #19

    Default Re: Please help me obtain sound production in Leap 15.3.

    Code:
    newbie@linux-hdi0:~> zypper se -s pipe pulse
    Loading repository data...
    Reading installed packages...
    
    S  | Name                           | Type       | Version                            | Arch   | Repository
    ---+--------------------------------+------------+------------------------------------+--------+-------------------------------------------------------------
       | aespipe                        | package    | 2.4e-bp153.1.17                    | x86_64 | Main Repository
    i+ | alsa-plugins-pulse             | package    | 1.2.2-1.55                         | x86_64 | Main Repository
    i+ | alsa-plugins-pulse             | package    | 1.2.2-1.55                         | x86_64 | openSUSE-Leap-15.3-1
    i+ | alsa-plugins-pulse-32bit       | package    | 1.2.2-1.55                         | x86_64 | Main Repository
    i+ | alsa-plugins-pulse-32bit       | package    | 1.2.2-1.55                         | x86_64 | openSUSE-Leap-15.3-1
    i  | apulse                         | package    | 0.1.12-lp152.1.3                   | x86_64 | (System Packages)
    v  | apulse                         | package    | 0.1.12-bp153.1.20                  | x86_64 | Main Repository
       | aws-sdk-java-codepipeline      | package    | 1.11.3-1.75                        | noarch | Main Repository
       | aws-sdk-java-datapipeline      | package    | 1.11.3-1.75                        | noarch | Main Repository
       | cmus-plugin-pulse              | package    | 2.8.0~20180422.gb595b8c-bp153.1.27 | x86_64 | Main Repository
       | courier-authlib-pipe           | package    | 0.69.1-bp153.1.23                  | x86_64 | Main Repository
       | gstreamer-plugin-pipewire      | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | gstreamer-plugin-pipewire      | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    i  | libKF5PulseAudioQt2            | package    | 1.2-lp152.1.4                      | x86_64 | (System Packages)
    v  | libKF5PulseAudioQt2            | package    | 1.2-bp153.1.23                     | x86_64 | Main Repository
       | libgvncpulse-1_0-0             | package    | 1.0.0-2.35                         | x86_64 | Main Repository
       | libpipeline-devel              | package    | 1.4.1-1.27                         | x86_64 | Main Repository
    i+ | libpipeline1                   | package    | 1.4.1-1.27                         | x86_64 | Main Repository
    i+ | libpipeline1                   | package    | 1.4.1-1.27                         | x86_64 | openSUSE-Leap-15.3-1
    i  | libpipewire-0_3-0              | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | libpipewire-0_3-0              | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    v  | libpipewire-0_3-0              | package    | 0.3.24-2.1                         | x86_64 | openSUSE-Leap-15.3-1
       | libpipewire-0_3-0-32bit        | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | libpipewire-0_3-0-32bit        | package    | 0.3.24-2.1                         | x86_64 | Main Repository
       | libpt2_10_11-plugins-pulse     | package    | 2.10.11-4.90                       | x86_64 | Main Repository
       | libpulse-devel                 | package    | 14.2-4.2                           | x86_64 | Main Repository
       | libpulse-devel-32bit           | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | libpulse-mainloop-glib0        | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | libpulse-mainloop-glib0        | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
       | libpulse-mainloop-glib0-32bit  | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | libpulse0                      | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | libpulse0                      | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i+ | libpulse0-32bit                | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | libpulse0-32bit                | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i+ | libxine2-pulse                 | package    | 1.2.9-lp152.4.7                    | x86_64 | (System Packages)
    v  | libxine2-pulse                 | package    | 1.2.9-bp153.1.30                   | x86_64 | Main Repository
    i  | mpg123-pulse                   | package    | 1.26.4-1.15                        | x86_64 | Main Repository
    i  | mpg123-pulse                   | package    | 1.26.4-1.15                        | x86_64 | openSUSE-Leap-15.3-1
       | mpg123-pulse-32bit             | package    | 1.26.4-1.15                        | x86_64 | Main Repository
       | perl-IO-Pipely                 | package    | 0.005-bp153.1.17                   | noarch | Main Repository
       | pipenightdreams                | package    | 0.10.0-bp153.1.17                  | x86_64 | Main Repository
       | piper                          | package    | 0.5.1-bp153.1.10                   | noarch | Main Repository
    i  | pipewire                       | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | pipewire                       | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    v  | pipewire                       | package    | 0.3.24-2.1                         | x86_64 | openSUSE-Leap-15.3-1
       | pipewire                       | srcpackage | 0.3.24-4.3.1                       | noarch | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-alsa                  | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-alsa                  | package    | 0.3.24-2.1                         | x86_64 | Main Repository
       | pipewire-devel                 | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-devel                 | package    | 0.3.24-2.1                         | x86_64 | Main Repository
       | pipewire-doc                   | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-doc                   | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    i  | pipewire-lang                  | package    | 0.3.24-4.3.1                       | noarch | (System Packages)
    v  | pipewire-lang                  | package    | 0.3.24-4.3.1                       | noarch | Update repository with updates from SUSE Linux Enterprise 15
    v  | pipewire-lang                  | package    | 0.3.24-2.1                         | noarch | Main Repository
    v  | pipewire-lang                  | package    | 0.3.24-2.1                         | noarch | openSUSE-Leap-15.3-1
       | pipewire-libjack-0_3           | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-libjack-0_3           | package    | 0.3.24-2.1                         | x86_64 | Main Repository
       | pipewire-libjack-0_3-32bit     | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-libjack-0_3-32bit     | package    | 0.3.24-2.1                         | x86_64 | Main Repository
       | pipewire-libpulse-0_3          | package    | 0.3.6-3.6.1                        | x86_64 | Main Repository
    i  | pipewire-modules               | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | pipewire-modules               | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    v  | pipewire-modules               | package    | 0.3.24-2.1                         | x86_64 | openSUSE-Leap-15.3-1
       | pipewire-modules-32bit         | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-modules-32bit         | package    | 0.3.24-2.1                         | x86_64 | Main Repository
       | pipewire-pulseaudio            | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-pulseaudio            | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    i  | pipewire-spa-plugins-0_2       | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | pipewire-spa-plugins-0_2       | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    v  | pipewire-spa-plugins-0_2       | package    | 0.3.24-2.1                         | x86_64 | openSUSE-Leap-15.3-1
       | pipewire-spa-plugins-0_2-32bit | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
       | pipewire-spa-plugins-0_2-32bit | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    i  | pipewire-spa-tools             | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | pipewire-spa-tools             | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    v  | pipewire-spa-tools             | package    | 0.3.24-2.1                         | x86_64 | openSUSE-Leap-15.3-1
    i  | pipewire-tools                 | package    | 0.3.24-4.3.1                       | x86_64 | Update repository with updates from SUSE Linux Enterprise 15
    v  | pipewire-tools                 | package    | 0.3.24-2.1                         | x86_64 | Main Repository
    v  | pipewire-tools                 | package    | 0.3.24-2.1                         | x86_64 | openSUSE-Leap-15.3-1
    i+ | pulseaudio                     | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio                     | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i  | pulseaudio-bash-completion     | package    | 14.2-4.2                           | x86_64 | Main Repository
    i  | pulseaudio-bash-completion     | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
       | pulseaudio-equalizer           | package    | 2.7.0.2-bp153.1.12                 | noarch | Main Repository
       | pulseaudio-esound-compat       | package    | 14.2-4.2                           | x86_64 | Main Repository
       | pulseaudio-gdm-hooks           | package    | 14.2-4.2                           | x86_64 | Main Repository
       | pulseaudio-gdm-hooks           | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i  | pulseaudio-lang                | package    | 14.2-4.2                           | noarch | Main Repository
    i  | pulseaudio-lang                | package    | 14.2-4.2                           | noarch | openSUSE-Leap-15.3-1
    i+ | pulseaudio-module-bluetooth    | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-module-bluetooth    | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i  | pulseaudio-module-gconf        | package    | 14.2-4.2                           | x86_64 | Main Repository
    i  | pulseaudio-module-gconf        | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
       | pulseaudio-module-gsettings    | package    | 14.2-4.2                           | x86_64 | Main Repository
       | pulseaudio-module-gsettings    | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
       | pulseaudio-module-jack         | package    | 14.2-4.2                           | x86_64 | Main Repository
       | pulseaudio-module-lirc         | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-module-x11          | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-module-x11          | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i+ | pulseaudio-module-zeroconf     | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-module-zeroconf     | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
       | pulseaudio-qt-devel            | package    | 1.2-bp153.1.23                     | x86_64 | Main Repository
       | pulseaudio-system-wide         | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-utils               | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-utils               | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
    i+ | pulseaudio-utils-32bit         | package    | 14.2-4.2                           | x86_64 | Main Repository
    i+ | pulseaudio-utils-32bit         | package    | 14.2-4.2                           | x86_64 | openSUSE-Leap-15.3-1
       | pulseaudio-zsh-completion      | package    | 14.2-4.2                           | x86_64 | Main Repository
       | pulseview                      | package    | 0.4.0-bp153.1.16                   | x86_64 | Main Repository

  10. #20

    Default Re: Please help me obtain sound production in Leap 15.3.

    Code:
    | python2-pulsectl               | package    | 20.2.4-bp153.2.1                   | noarch | Main Repository
       | python3-django-pipeline        | package    | 2.0.5-bp153.1.21                   | noarch | Main Repository
       | python3-pulsectl               | package    | 20.2.4-bp153.2.1                   | noarch | Main Repository
       | texlive-bagpipe                | package    | 2017.135.3.02svn34393-6.16         | noarch | Main Repository
       | texlive-bagpipe-doc            | package    | 2017.135.3.02svn34393-6.16         | noarch | Main Repository
       | typelib-1_0-GVncPulse-1_0      | package    | 1.0.0-2.35                         | x86_64 | Main Repository
       | xfce4-pulseaudio-plugin        | package    | 0.4.3-bp153.2.1                    | x86_64 | Main Repository
       | xfce4-pulseaudio-plugin        | package    | 0.4.3-bp153.2.1                    | x86_64 | openSUSE-Leap-15.3-1
       | xfce4-pulseaudio-plugin-lang   | package    | 0.4.3-bp153.2.1                    | noarch | Main Repository
       | xfce4-pulseaudio-plugin-lang   | package    | 0.4.3-bp153.2.1                    | noarch | openSUSE-Leap-15.3-1
       | xmms2-plugin-pulse             | package    | 0.8-bp153.1.39                     | x86_64 | Main Repository
    
    For an extended search including not yet activated remote resources you may run
    'zypper search-packages' at any time.
    Do you want to run 'zypper search-packages' now? [yes/no/always/never] (no):yes
    
    Could not parse the options: ambiguous option: -s
    Could not search for the package: SUSE::Connect::UnsupportedOperation: Package search is not supported by the registration proxy: Alternatively, use the web version at https://scc.suse.com/packages/
    Could not search for the package: SUSE::Connect::UnsupportedOperation: Package search is not supported by the registration proxy: Alternatively, use the web version at https://scc.suse.com/packages/
    Could not search for the package: SUSE::Connect::UnsupportedOperation: Package search is not supported by the registration proxy: Alternatively, use the web version at https://scc.suse.com/packages/
    No package found
    
    newbie@linux-hdi0:~>  
    
    newbie@linux-hdi0:~> su
    Password: 
    
    (Here I skipped one failed attempt.)
    
    linux-hdi0:/home/newbie # setup-pulseaudio --enable
    Enabling PulseAudio for ALSA...
    Enabling PulseAudio for libao...
    Default driver is pulse already in /etc/libao.conf
    Enabling PulseAudio for mplayer...
    Enabling PulseAudio for OSS...
    Application aumix already setup for PulseAudio
    Application sox already setup for PulseAudio
    Enabling PulseAudio for SDL...
    Enabling PulseAudio for Timidity...
    Timidity already setup for using PulseAudio
    Enabling PulseAudio for Phonon...
    Enabling PulseAudio for Kmix...
    Enabling PulseAudio for speech dispatcher...
    Enabling PulseAudio for SoX...
    Setting auto sink/src for gstreamer
    Enabling PulseAudio for QEMU/KVM
    Enabling systemd user socket...
    linux-hdi0:/home/newbie #
    Then I “rebooted” my virtual computer in VirtualBox 6.1.22 into Leap 15.3, as usual lately, using the Linux kernel 5.3.18-59.16.1.x86_64-preempt and, except for prompts, entered the following command as a regular user with the ensuing results.

    Code:
    newbie@linux-hdi0:~> systemctl --user list-unit-files | egrep -i 'pipe|pulse'
    pipewire-media-session.service                                                     enabled   enabled      
    pipewire.service                                                                   disabled  disabled     
    pulseaudio.service                                                                 disabled  disabled     
    pipewire.socket                                                                    enabled   enabled      
    pulseaudio.socket                                                                  enabled   enabled      
    newbie@linux-hdi0:~>

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •