Results 1 to 8 of 8

Thread: Windows dual boot

  1. #1

    Default Windows dual boot

    I have a machine with 2 SSDs that I set up to dual boot Windows 10 and Opensuse Leap 15.2. Windows in on one SSD; Opensuse 15.2 is on the other. Windows was installed over a year ago and I really, really don't want to reinstall it. However, I'm okay with reinstalling Opensuse 15.2. The problem I have is that the Windows install is on a disk that is configured for legacy BIOS, while Suse is UEFI, so Suse doesn't see the Windows partition and the only way I can dual boot is to constantly switch the BIOS betweeen UEFI and Legacy-only. I'm trying to reinstall OpenSuse to use Legacy BIOS just like Windows, assuming that's the answer. So my question is, what do I have to do to get dual boot working? Reinstalling Windows is a show stopper.

  2. #2
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,214

    Default Re: Windows dual boot

    Disable UEFI, then boot the Leap install medium: it should boot up in "legacy" mode and you should be able to install Leap that way and the automatic bootloader configuration should be able to "see" Win* as well.
    When the Leap install medium is booted in "legacy" mode you should see some option "buttons" at the bottom of the screen.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  3. #3

    Default Re: Windows dual boot

    Thanks for your reply.

    I've set bios to legacy only. When I go to install, the original SuSe installation is still there (of course). If I delete all of the existing partitions, the only option for boot partition related-type is EFI.

    What do I do with the existing partitions and how do I prepare the disk?

  4. #4
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,214

    Default Re: Windows dual boot

    Maybe you don't have to reinstall. Boot the install media in "legacy" mode, at the boot prompt look for the option "Boot existing Linux system" (or something similar, I cannot check now), then look for your existing openSUSE and boot it.
    If everything is working, start YaST2-Bootloader, then:
    - go to the Boot Code Options tab;
    - choose "GRUB2" ( _not_ "GRUB2 for EFI");
    - leave other options at their default settings, then "OK".
    Reboot, if everything went well, you should be able to boot Leap _and_ Win*.
    If not so, report here.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  5. #5

    Default Re: Windows dual boot

    Sorry for the delayed response. I finally got an opportunity to try this. The problem system is a workstation my son is using for his Summer internship and we didn't want to risk making it unbootable. Anyway, it didn't work. I set the boot mode to legacy and the bootable USB stick with opensuse on it was found as expected, but when we selected "Boot from hard disk", the machine just hung. I'm guessing because it's in legacy mode but the installed opensuse is not?

    Do you have any idea what would happen if we set the boot code option to "GRUB2" in the running system and then changed to legacy boot mode in the bios?

  6. #6
    Join Date
    Oct 2014
    Location
    Italy
    Posts
    2,214

    Default Re: Windows dual boot

    I just checked with the Leap 15.2 DVD in "legacy" mode:
    - at the boot prompt choose > More...
    - then choose > Boot Linux System
    the kernel in the DVD is loaded, then system disks are searched for bootable systems.
    If your installed Leap is found, you should be presented with the choice to boot it and then with optional choices if you have more than one kernel installed etc.; the first choice should work (just hit "Enter") unless your system has problems.
    At the end you should land in your installed Leap 15.2 and able to adjust the bootloader as required.

    I cannot check if booting in UEFI mode, adjusting for "legacy" GRUB and then switching BIOS to "legacy mode" works, so I cannot advise, even if it might work in principle. If it doesn't work, you are left with an unbootable system, so think twice.
    Tumbleweed Gnome on i7 4720HQ + Geforce GTX960M
    testing Leap 15.3

  7. #7
    Join Date
    Sep 2012
    Posts
    6,773

    Default Re: Windows dual boot

    Quote Originally Posted by Dilireus63 View Post
    I set the boot mode to legacy and the bootable USB stick with opensuse on it was found as expected, but when we selected "Boot from hard disk", the machine just hung.
    Of course it did. This option simply loads the first sector of the first drive and tries to execute it. This sector likely contains some garbage which computer tries to do.

    Do you have any idea what would happen if we set the boot code option to "GRUB2" in the running system and then changed to legacy boot mode in the bios?
    changing bootloader in YaST will install it in selected location. If selected location matches BIOS boot drive, computer should boot into openSUSE.

  8. #8
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,216

    Default Re: Windows dual boot

    Boot the install media in the mode you want to boot the OS in. ie MBR/legacy or EFI. The install will use the mode it boot into to install the OS in the same mode.

    If you manage to boot to the installed system you can change the booting method in Yast

    Note that to dual boot ALL os's must use the same boot method!!!!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •