Results 1 to 6 of 6

Thread: Krita dependency issue

  1. #1

    Exclamation Krita dependency issue

    Hi,

    I have been having trouble installing Krita on Tumbleweed KDE.
    Before the latest snapshot, zypper couldn't find "libKSeExpr" and now it can't find "libOpenColorIO".
    Here's the output along with my list of repositories:

    Code:
    ~ 
    ❯ sudo zypper lr -P
    [sudo] password for munsterplop: 
    #  | Alias                            | Name                        | Enabled | GPG Check | Refresh | Priority
    ---+----------------------------------+-----------------------------+---------+-----------+---------+---------
     7 | packman                          | Packman                     | Yes     | (r ) Yes  | Yes     |   90
     1 | brave-browser                    | brave-browser               | Yes     | (r ) Yes  | No      |   99
     2 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)   | Yes     | (r ) Yes  | Yes     |   99
     3 | download.opensuse.org-oss        | Main Repository (OSS)       | Yes     | (r ) Yes  | Yes     |   99
     4 | download.opensuse.org-tumbleweed | Main Update Repository      | Yes     | (r ) Yes  | Yes     |   99
     5 | nvidia                           | nvidia                      | Yes     | (r ) Yes  | Yes     |   99
     6 | packages-microsoft-com-prod      | packages-microsoft-com-prod | Yes     | (r ) Yes  | No      |   99
     8 | repo-debug                       | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99
     9 | repo-source                      | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99
    10 | vscode                           | Visual Studio Code          | Yes     | (r ) Yes  | No      |   99
    
    
    ~ 
    ❯ sudo zypper in krita
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    
    Problem: nothing provides 'libOpenColorIO.so.1()(64bit)' needed by the to be installed krita-4.4.5-1.2.x86_64
     Solution 1: do not install krita-4.4.5-1.2.x86_64
     Solution 2: break krita-4.4.5-1.2.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or cancel [1/2/c/d/?] (c):
    I'm not sure if it comes from my system but I had the same problem after a fresh install so I doubt it does..
    I'd like to confirm it before submitting a bug report though.

  2. #2
    Join Date
    Sep 2012
    Posts
    6,973

    Default Re: Krita dependency issue

    Just wait until new TW snapshot will be published
    Code:
    - Remove the OpenColorIO build dependency for openSUSE Tumbleweed.
      krita doesn't support OCIO 2.0 yet (kde#435474)

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,490

    Default Re: Krita dependency issue

    As an extra remark:
    A repo list without URLs is next to useless. We (and you) will only see Names and Aliases which may give an idea about the purpose of a repo, but not more. So next time please use
    Code:
    zypper lr -d
    Henk van Velden

  4. #4

    Default Re: Krita dependency issue

    Quote Originally Posted by arvidjaar View Post
    Just wait until new TW snapshot will be published
    Code:
    - Remove the OpenColorIO build dependency for openSUSE Tumbleweed.
      krita doesn't support OCIO 2.0 yet (kde#435474)
    Thank you for the info, I'll wait then.

    Quote Originally Posted by hcvv View Post
    As an extra remark:
    A repo list without URLs is next to useless. We (and you) will only see Names and Aliases which may give an idea about the purpose of a repo, but not more. So next time please use
    Code:
    zypper lr -d
    Thanks, that makes sense, I'll keep it in mind, I'm pretty new to the SUSE .
    Here's the output with -d:

    Code:
    ❯ sudo zypper lr -dP
    #  | Alias                            | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                  | Service
    ---+----------------------------------+-----------------------------+---------+-----------+---------+----------+--------+----------------------------------------------------------------------+--------
     7 | packman                          | Packman                     | Yes     | (r ) Yes  | Yes     |   90     | rpm-md | https://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/ | 
     1 | brave-browser                    | brave-browser               | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://brave-browser-rpm-release.s3.brave.com/x86_64/               | 
     2 | download.opensuse.org-non-oss    | Main Repository (NON-OSS)   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                | 
     3 | download.opensuse.org-oss        | Main Repository (OSS)       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                    | 
     4 | download.opensuse.org-tumbleweed | Main Update Repository      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                      | 
     5 | nvidia                           | nvidia                      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://download.nvidia.com/opensuse/tumbleweed                      | 
     6 | packages-microsoft-com-prod      | packages-microsoft-com-prod | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://packages.microsoft.com/opensuse/15/prod/                     | 
     8 | repo-debug                       | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/              | 
     9 | repo-source                      | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/             | 
    10 | vscode                           | Visual Studio Code          | Yes     | (r ) Yes  | No      |   99     | rpm-md | https://packages.microsoft.com/yumrepos/vscode                       |

  5. #5
    Join Date
    Apr 2011
    Location
    Texas USA
    Posts
    308

    Default Re: Krita dependency issue

    Krita sounded interesting so I installed it on leap 15.3 to preview and it works fine. The two files of concern that are missing from the tumbleweed install are installed on my leap 15.3 system as part of krita. I am assuming these would be found in a search of repos in tumbleweed and could be installed.

    Looks like a fun app. tom kosvic

  6. #6

    Default Re: Krita dependency issue

    It's now working fine with the new snapshot !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •