Results 1 to 7 of 7

Thread: Lost ability to configure Desktop both dispays after recent update

  1. #1

    Default Lost ability to configure Desktop both dispays after recent update

    Tumbleweed
    KDE

    After a recent Tumbleweed update of 250+ files I have lost the ability to configure the Desktop settings on both displays. (Dual display set-up obviously.)

    For example, I could previously set the Desktop wallpaper background on both displays. Now I can only do that on 1 display. The other display gets an un-changable black background and no response to right-mouse-click which should present a menu to change the display settings.

  2. #2
    Join Date
    Jan 2018
    Location
    Canada
    Posts
    189

    Default Re: Lost ability to configure Desktop both dispays after recent update

    Try using the KDE Display and Monitor app to check/change the resolution of your display(s). If it is showing as correct, apply a different setting and then apply the correct setting. For me this survives until the next boot.

  3. #3

    Default Re: Lost ability to configure Desktop both dispays after recent update

    Quote Originally Posted by doscott View Post
    Try using the KDE Display and Monitor app to check/change the resolution of your display(s). If it is showing as correct, apply a different setting and then apply the correct setting. For me this survives until the next boot.
    Same behaviour here. Works but does not survive reboot.

  4. #4

    Default Re: Lost ability to configure Desktop both dispays after recent update


  5. #5
    Join Date
    May 2015
    Location
    Italy
    Posts
    440

    Default Re: Lost ability to configure Desktop both dispays after recent update

    Same problem here
    The QT bug link is here: https://bugreports.qt.io/browse/QTBUG-86604

    As suggested on that bug, running
    plasmashell --replace
    fixes the problem (for me) until next reboot.

    Cris
    Desktop: OpenSUSE Tumbleweed (x86_64) - AMD Ryzen 5 3600 Six-Core Processor, 16Gb RAM, 120GB Samsung Evo 840 SSD, 500Gb WD BLACK SN750 NVMe SSD
    Laptop: OpenSUSE Tumbleweed (x86_64) - Thinkpad T440 - Intel i5-4210U, 12Gb RAM, 250GB Samsung EVO 750 SSD

  6. #6
    Join Date
    Jun 2008
    Location
    Connecticut, USA
    Posts
    2,295
    Blog Entries
    1

    Default Re: Lost ability to configure Desktop both dispays after recent update

    Just came back to openSUSE after being elsewhere for a long time.

    Looking to see if there is an update with this issue.

    I have a laptop connected to a second monitor. I am trying to set it up so it only uses the second monitor and not the laptop screen as they are not side-by-side.

    The primary desktop only shows my desktop icons, while the non-primary desktop shows the main panel. It didn't matter which one I set as primary, it was missing the panel.

    Duplicating makes both of them act as primary desktops (no panel) and the different screen size / resolution also effects it.

    I am able to get the external monitor usable so long as I have them of them running, overlaping each other and running as mentioned
    Code:
    plasmashell --replace
    Since you mentioned that it doesn't stick between reboots I set up a script and added that to autorun when I log in.

    Set it by using System settings > Startup and Shutdown > Autostart > Add Login script > [[add an executable file w/code below]]
    Code:
    #!/bin/sh
    plasmashell --replace &
    Do you have any updates or tricks that may work?
    "Linux provides freedom, problem is most users don't know what it is or how to use it." ~me
    Friends don't let Friends wear red shirts on away parties!
    Linux User #477531 | Danbury Area Computer Society (www.dacs.org)

  7. #7
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,270
    Blog Entries
    1

    Default Re: Lost ability to configure Desktop both dispays after recent update

    Try the following: Go into background services in systemsettings5, deselect "Kscreen 2" and apply. Log out of Plasma and delete ~/.local/share/kscreen2/* and ~/.cache/* while Plasma is not running. From then you can use a startup xrandr script that should stick. Mine are in /etc/X11/xinit/xinitrc.d/. Arandr can be used to create such a script.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, TW, 15.3 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.2 on i965P w/ Radeon
    Tertiary: Mageia, Fedora, Debian, more on Kaby Lake & older Intel, AMD, NVidia &&&&&

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •