Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 23

Thread: Open Source NMS on Leap 15.x

  1. #11
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,169

    Default Re: Open Source NMS on Leap 15.x

    So it looks like I either have to find hardware to run server or rebuild this machine as a server
    It is already a server, you don't have to run SLES - it's simply the commercial offering. Leap can do everything SLE can do, the only difference in practice is the paid support.

    You are simply following instructions made for a different distribution version instead of installing it the way it should be for Leap.

    A simple guide is available here for 15.1, simply replace all references to 15.1 with 15.2 or 15.3 depending what system you are installing on;
    Code:
    https://www.osradar.com/install-zabbix-opensuse-15-1-leap/
    .: miuku @ #opensuse @ irc.libera.chat

  2. #12
    Join Date
    Mar 2020
    Location
    NoWhere
    Posts
    45

    Default Re: Open Source NMS on Leap 15.x

    Well useless is as useless does and I am pretty **** useless

    Seems like I cannot start Apache because of some config issue or other

    Code:
    httpd-prefork: Syntax error on line 210 of /etc/apache2/httpd.conf: Syntax error on line 119 of /etc/apache2/default-server.conf: Syntax error on line 30 of /etc/apache2/con>
    
    I have no idea what i am looking at or for and after 6 hours of trying to get this to work well I just give up.

    Chance of Success 0
    Chance of Failure 100







  3. #13
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,317
    Blog Entries
    1

    Default Re: Open Source NMS on Leap 15.x

    Quote Originally Posted by GOKIWI View Post
    Well useless is as useless does and I am pretty **** useless

    Seems like I cannot start Apache because of some config issue or other

    Code:
    httpd-prefork: Syntax error on line 210 of /etc/apache2/httpd.conf: Syntax error on line 119 of /etc/apache2/default-server.conf: Syntax error on line 30 of /etc/apache2/con>
    
    I have no idea what i am looking at or for and after 6 hours of trying to get this to work well I just give up.

    Chance of Success 0
    Chance of Failure 100
    Can you show the complete output from...
    Code:
    sudo journalctl -u apache2
    If it is lengthy, consider uploading to https://susepaste.org/ and share the link to it here.







    openSUSE Leap 15.3; KDE Plasma 5

  4. #14
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,974

    Default Re: Open Source NMS on Leap 15.x

    Quote Originally Posted by GOKIWI View Post
    Seems like I cannot start Apache because of some config issue or other
    Code:
    httpd-prefork: Syntax error on line 210 of /etc/apache2/httpd.conf: Syntax error on line 119 of /etc/apache2/default-server.conf: Syntax error on line 30 of /etc/apache2/con>
    
    Install that and try again:
    Code:
    erlangen:~ # zypper in --type pattern lamp_server 
    Loading repository data... 
    Reading installed packages... 
    'pattern:lamp_server' is already installed. 
    No update candidate for 'pattern:lamp_server-20210330-1.2.x86_64'. The highest available version is already installed. 
    Resolving package dependencies... 
    Nothing to do. 
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  5. #15
    Join Date
    Mar 2020
    Location
    NoWhere
    Posts
    45

    Default Re: Open Source NMS on Leap 15.x

    Hi All,

    Well have to say and I am totally not sure how but with your help I managed to get it all working (except its not).

    I can log into Zabbix no issues , I have set a discovery to run and manually added a couple of nodes, but they dont collect any data.

    So as far as OpenSuse is concerned its working now to join the Zabbix community to see if they will help.

    The Forum has come through again :-)

  6. #16
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,363

    Question Re: Open Source NMS on Leap 15.x

    Quote Originally Posted by GOKIWI View Post
    I have set a discovery to run and manually added a couple of nodes, but they dont collect any data.
    Are you certain that, the other hosts on the network have Zabbix Agents installed and running?

  7. #17
    Join Date
    Mar 2020
    Location
    NoWhere
    Posts
    45

    Default Re: Open Source NMS on Leap 15.x

    So after all this its a no go - Zabbix wont/cant help as they dont support OpenSuse Leap/Tumbleweed 15.2/15.3 also this version 4.0 is as buggy as hell and will not support "!" in our snmp strings (corporate standard).

    The recommendation from the forum "Go Ubuntu" - It's officially supported.

  8. #18
    Join Date
    May 2012
    Location
    Finland
    Posts
    2,169

    Default Re: Open Source NMS on Leap 15.x

    I don't understand how this is such a big problem. It took me literally 5 minutes to setup Zabbix on 15.x with zero issues and running 5.x.

    Perhaps you should stop following some random guides on their forums/website and use the ones we give you instead of hitting your head on a brick wall or alternatively hire someone who knows how to do this in literally no time at all.
    .: miuku @ #opensuse @ irc.libera.chat

  9. #19
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,974

    Default Re: Open Source NMS on Leap 15.x

    Quote Originally Posted by GOKIWI View Post
    So after all this its a no go - Zabbix wont/cant help as they dont support OpenSuse Leap/Tumbleweed 15.2/15.3 also this version 4.0 is as buggy as hell and will not support "!" in our snmp strings (corporate standard).

    The recommendation from the forum "Go Ubuntu" - It's officially supported.
    That's folklore!

    SUSE Linux Enterprise Server

    https://www.zabbix.com/documentation..._packages/suse
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  10. #20
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,317
    Blog Entries
    1

    Default Re: Open Source NMS on Leap 15.x

    Quote Originally Posted by GOKIWI View Post
    So after all this its a no go - Zabbix wont/cant help as they dont support OpenSuse Leap/Tumbleweed 15.2/15.3 also this version 4.0 is as buggy as hell and will not support "!" in our snmp strings (corporate standard).

    The recommendation from the forum "Go Ubuntu" - It's officially supported.
    If you're not willing to follow Miuku's pertinent advice, then go where the official support exists.
    openSUSE Leap 15.3; KDE Plasma 5

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •