Results 1 to 2 of 2

Thread: qemu-system no internet please help

  1. #1

    Default qemu-system no internet please help

    New in openSUSE Tumbleweed linux. Loving it as it is the most compatable as a desktop distro with my machine. In fedora or debian I use only qemu-system-arch no virt daemon running just from the commandline -net nic,model=e1000 -net user was enough to run a virtual machine which used user network. But In opensuse it is creating dhcp and getting the ip address and also updating dns but no network for somereason. It a new install of tumbelweed. I added boot option ipv6.disable=1 which doesn't seem the cause of the issue. Doesn't look like a firewall issue too. Don't actually want to create a bridge just want to run the machine inside the userspace. Here is the script I am using It works great in fedora and debian. And also I am using networkmanager.

    #!/bin/bash
    args=(
    -m 4064 --sandbox on --cpu host
    -name subnode -enable-kvm
    -boot d "$@"
    -cpu Penryn,kvm=on
    -smp "$CPU_THREADS",cores="$CPU_CORES",sockets="$CPU_SOCKETS"
    -net nic,model=e1000 -net user
    -vga qxl
    )
    /usr/bin/qemu-system-x86_64 "${args[@]}"
    exit 0

  2. #2

    Default Re: qemu-system no internet please help

    Actually Its fixed now. It wasn't related to any distro settings or anything related. Its was just the router dns was overlaping with the virtual ip address.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •