Page 3 of 3 FirstFirst 123
Results 21 to 23 of 23

Thread: Wicked doesn't assign any IPv6 addresses

  1. #21
    Join Date
    Sep 2012
    Posts
    6,795

    Default Re: Wicked doesn't assign any IPv6 addresses

    Quote Originally Posted by jonapap View Post
    Ok, finally got IPv6 to work! I had to disable IPv6 forwarding.
    Oh. My apologies, I should have thought about it. Good troubleshooting.
    I'll troubleshoot and if it looks like this is a bug, I'll raise one on the Bugzilla.
    Please do not. It is not a bug and it will just waste time of those who will need to handle it.
    Let me know if you have an idea why IPv6 forwading causes this.
    Because if forwarding is enabled system is assumed to be a router and routers are expected to provide prefixes, not to request them. If you still want to auto-configure interfaces, set accept_ra to 2.
    Code:
    accept_ra - INTEGER
            Accept Router Advertisements; autoconfigure using them.
                     0  Do not accept Router Advertisements.
                     1  Accept Router Advertisements if forwarding is disabled.
                     2  Overrule forwarding behaviour. Accept Router Advertisements
                        even if forwarding is enabled.
    But network management programs may still interfere with those options, so testing is needed.

  2. #22
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,363

    Default Re: Wicked doesn't assign any IPv6 addresses

    Quote Originally Posted by jonapap View Post
    Thing is, it could be nice to have IPv6 forwarding on that machine.
    Maybe, this will help – <https://doc.opensuse.org/documentati...network-router>.

  3. #23

    Default Re: Wicked doesn't assign any IPv6 addresses

    Quote Originally Posted by arvidjaar View Post
    Because if forwarding is enabled system is assumed to be a router and routers are expected to provide prefixes, not to request them. If you still want to auto-configure interfaces, set accept_ra to 2.
    Quote Originally Posted by dcurtisfra View Post
    Ok, thanks, that makes sense. I'll look into this. I'm using this machine as a Wireguard VPN server (among other things), so I'll follow this to try to use IPv6 in the tunnel. I guess I got a bit used to IPv4 working fine with forwading enabled.

Page 3 of 3 FirstFirst 123

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •