Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Audio level is too high after startup

  1. #1

    Exclamation Audio level is too high after startup

    This started fairly recently, about a week or so.
    When the PC starts up audio volume would be set at 74%, this is extremely annoying, I have to remember to manually lower it after I log in, otherwise the first sound will beat the **** out of my eardrums.
    I tried manually saving the session after lowering the volume and I tried explicitly setting fiat-volume to `no` in the pulse config, both to no avail.
    Before this problem wasn't happening, so I imagine some update might have broken something.

  2. #2
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,363

    Question Re: Audio level is too high after startup

    Which Desktop GUI are you using?
    • The issue may be caused by the user specific TDB databases – does this behaviour also occur with a freshly configured new user?

    If the issue doesn't appear with a new, fresh, user then –
    • Logout the graphical session of the affected user.
    • Login as the affected user by means of a VT – tty1 .. tty6 – <Ctrl-Alt-F1> .. <Ctrl-Alt-F6>.
    • Remove every thing in the affected user's ‘~/.config/pulse/’ directory.
    • Logout of the VT.
    • Login to the affected user's graphical session and setup the Audio again.

  3. #3
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,857
    Blog Entries
    39

    Default Re: Audio level is too high after startup

    I have no idea if this could be Tumbleweed specific. Nominally, the last level one used in audio, should be saved and kept for the next reboot - at least that is my understanding.

    On older openSUSE versions, what worked sometimes was to set "flat-volumes = no" in /etc/pulse/daemon.conf (but I have read did not work all the time).

    I suppose (if relevant to Tumbleweed) you could try to delete ~/.config/pulse/ and/or ~/.pulse (if present). That may revert all volumes to the defaults (which may be good or bad dependent on how you like the default levels).

    Also, to quote from an alsa developer for a MUCH OLDER version of openSUSE:
    if this happens after reboot, it could be the wrongly saved mixer state. There are a few layers saving/restoring the mixer state, alsactl invoked via udev, PulseAudio, and kmix.

    A possible fix would be to clean up the config. Go to runlevel 3 once, login as root, kill all pending Pulse Audio processes (if any). Then adjust via "alsamixer -c0", and run "alsactl store". This resets the mixer restored via alsactl.

    I have no idea if that true for Tumbleweed.

  4. #4
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,974

    Default Re: Audio level is too high after startup

    Quote Originally Posted by AlexCzar View Post
    This started fairly recently, about a week or so.
    When the PC starts up audio volume would be set at 74%, this is extremely annoying, I have to remember to manually lower it after I log in, otherwise the first sound will beat the **** out of my eardrums.
    I tried manually saving the session after lowering the volume and I tried explicitly setting fiat-volume to `no` in the pulse config, both to no avail.
    Before this problem wasn't happening, so I imagine some update might have broken something.
    You may check Save/Restore Sound Card State:
    Code:
    i3-4130:~ # journalctl -b -1 -o short-monotonic -u alsa-restore.service   
    -- Journal begins at Sun 2021-07-11 15:51:53 CEST, ends at Thu 2021-07-15 12:33:10 CEST. -- 
    [    4.008177] i3-4130 systemd[1]: Starting Save/Restore Sound Card State... 
    [    4.015056] i3-4130 alsactl[837]: alsa-lib parser.c:242:(error_node) UCM is not supported for this HDA model (HDA Intel HDMI at 0xf0534000 irq 32) 
    [    4.015056] i3-4130 alsactl[837]: alsa-lib main.c:1405:(snd_use_case_mgr_open) error: failed to import hw:0 use case configuration -6 
    [    4.016254] i3-4130 systemd[1]: Finished Save/Restore Sound Card State. 
    [  374.506988] i3-4130 systemd[1]: Stopping Save/Restore Sound Card State... 
    [  374.563556] i3-4130 systemd[1]: alsa-restore.service: Deactivated successfully. 
    [  374.563668] i3-4130 systemd[1]: Stopped Save/Restore Sound Card State. 
    i3-4130:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,389

    Default AW: Audio level is too high after startup


  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,363

    Default Re: Audio level is too high after startup

    I've added a comment to <https://bugzilla.opensuse.org/show_bug.cgi?id=1188196> – it has been mirrored over to the SUSE Bug Report …
    • BTW, I'm using Leap 15.3.

    Basically, if you touch PipeWire with anything – for example with “pw-mon” – a couple of PipeWire processes will start for that user.
    Therefore –
    • systemctl --user mask pipewire.service
    • systemctl --user mask pipewire.socket
    • systemctl --user mask pipewire-media-session.service

    Code:
     > file ~/.config/systemd/user/*
    /home/xxx/.config/systemd/user/pipewire-media-session.service: symbolic link to /dev/null
    /home/xxx/.config/systemd/user/pipewire.service:               symbolic link to /dev/null
    /home/xxx/.config/systemd/user/pipewire.socket:                symbolic link to /dev/null
     >
    • The directory ‘~/.config/systemd/user’ is automatically created with the first call to “systemctl --user mask «pipewire – whatever»”

    I suspect that, simply removing the PipeWire packages will not really help –
    Code:
     > rpm --query --whatrequires pipewire
    pipewire-modules-0.3.24-4.3.1.x86_64
    pipewire-spa-plugins-0_2-0.3.24-4.3.1.x86_64
    pipewire-lang-0.3.24-4.3.1.noarch
     > rpm --query --whatrecommends pipewire
    libpipewire-0_3-0-0.3.24-4.3.1.x86_64
    xdg-desktop-portal-kde-5.18.5-bp153.1.27.x86_64
     > rpm --query --whatsuggests pipewire
    no package suggests pipewire
     >
    Taking the alternative route and removing PulseAudio is also not exactly easy –
    Code:
     > rpm --query --whatrequires pulseaudio
    alsa-plugins-pulse-1.2.2-1.55.x86_64
    pulseaudio-lang-14.2-4.2.noarch
    pulseaudio-module-zeroconf-14.2-4.2.x86_64
    pulseaudio-module-x11-14.2-4.2.x86_64
    pulseaudio-module-gconf-14.2-4.2.x86_64
    pulseaudio-module-bluetooth-14.2-4.2.x86_64
     > rpm --query --whatrecommends pulseaudio
    patterns-kde-kde_plasma-20181130-lp153.2.8.noarch
     > rpm --query --whatsuggests pulseaudio
    patterns-base-base-20200505-lp153.6.1.x86_64
     >

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,974

    Default Re: Audio level is too high after startup

    Quote Originally Posted by dcurtisfra View Post
    I've added a comment to <https://bugzilla.opensuse.org/show_bug.cgi?id=1188196> – it has been mirrored over to the SUSE Bug Report …
    • BTW, I'm using Leap 15.3.

    Basically, if you touch PipeWire with anything – for example with “pw-mon” – a couple of PipeWire processes will start for that user.
    Therefore –
    • systemctl --user mask pipewire.service
    • systemctl --user mask pipewire.socket
    • systemctl --user mask pipewire-media-session.service



    • The directory ‘~/.config/systemd/user’ is automatically created with the first call to “systemctl --user mask «pipewire – whatever»”


    I suspect that, simply removing the PipeWire packages will not really help –

    Taking the alternative route and removing PulseAudio is also not exactly easy –
    Pipewire units exist:
    Code:
    karl@erlangen:~> systemctl list-unit-files --user 'pipewire*'  
    UNIT FILE                      STATE    VENDOR PRESET
    pipewire-media-session.service enabled  enabled      
    pipewire.service               disabled disabled     
    pipewire.socket                enabled  enabled      
    
    3 unit files listed. 
    karl@erlangen:~> 
    
    They don't get loaded and don't interfere with pulseaudio:
    Code:
    karl@erlangen:~> systemctl list-units --user 'pipewire*'      
      UNIT LOAD ACTIVE SUB DESCRIPTION
    0 loaded units listed. Pass --all to see loaded but inactive units, too. 
    To show all installed unit files use 'systemctl list-unit-files'. 
    karl@erlangen:~> 
    Thus I refrain from tinkering.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,363

    Default Re: Audio level is too high after startup

    Quote Originally Posted by karlmistelberger View Post
    They don't get loaded and don't interfere with pulseaudio:
    Really?
    • Simply “ ps -u «Username» | grep -i 'wire' ” – strange that a process named “pipewire” and “pipewire-media-session” running under that Username are present …

    This is also mentioned in the Bug Report …

  9. #9
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,974

    Default Re: Audio level is too high after startup

    Quote Originally Posted by dcurtisfra View Post
    Really?
    • Simply “ ps -u «Username» | grep -i 'wire' ” – strange that a process named “pipewire” and “pipewire-media-session” running under that Username are present …

    This is also mentioned in the Bug Report …
    Code:
    
    Leap-15-3:~ # ps -u karl | grep -i 'wire' 
    Leap-15-3:~ #
    
    Code:
    karl@Leap-15-3:~> systemctl --user status pipewire* 
     pipewire.socket - Multimedia System 
         Loaded: loaded (/usr/lib/systemd/user/pipewire.socket; enabled; vendor preset: enabled) 
         Active: active (listening) since Thu 2021-07-15 20:03:13 CEST; 4min 2s ago 
       Triggers: ● pipewire.service 
         Listen: /run/user/1000/pipewire-0 (Stream) 
         CGroup: /user.slice/user-1000.slice/user@1000.service/pipewire.socket 
    
    Jul 15 20:03:13 Leap-15-3 systemd[1579]: Listening on Multimedia System. 
    karl@Leap-15-3:~> 
    Code:
    karl@Leap-15-3:~> journalctl -b --user -u '*pipe*'  
    -- Logs begin at Wed 2021-07-07 12:07:22 CEST, end at Thu 2021-07-15 20:08:49 CEST. -- 
    Jul 15 20:03:13 Leap-15-3 systemd[1579]: Listening on Multimedia System. 
    karl@Leap-15-3:~> 
    
    
    Code:
    Leap-15-3:~ # ll /var/lib/alsa/asound.state 
    -rw-r--r-- 1 root root 18004 Jul 15 06:01 /var/lib/alsa/asound.state 
    Leap-15-3:~ # journalctl -b -o short-monotonic -u *alsa* -u *sound* 
    -- Logs begin at Wed 2021-07-07 11:53:27 CEST, end at Thu 2021-07-15 20:08:49 CEST. -- 
    [    5.563724] Leap-15-3 systemd[1]: Starting Save/Restore Sound Card State... 
    [    5.563873] Leap-15-3 systemd[1]: Condition check resulted in Manage Sound Card State (restore and store) being skipped. 
    [    5.566003] Leap-15-3 systemd[1]: Finished Save/Restore Sound Card State. 
    [    5.567037] Leap-15-3 systemd[1]: Starting Load extra kernel modules for sound stuff... 
    [    5.568808] Leap-15-3 systemd[1]: sound-extra.service: Succeeded. 
    [    5.568977] Leap-15-3 systemd[1]: Finished Load extra kernel modules for sound stuff. 
    [    5.569279] Leap-15-3 systemd[1]: Reached target Sound Card. 
    Leap-15-3:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  10. #10

    Default Re: Audio level is too high after startup

    Quote Originally Posted by AlexCzar View Post
    This started fairly recently, about a week or so.
    When the PC starts up audio volume would be set at 74%, this is extremely annoying, I have to remember to manually lower it after I log in, otherwise the first sound will beat the **** out of my eardrums.
    I tried manually saving the session after lowering the volume and I tried explicitly setting fiat-volume to `no` in the pulse config, both to no avail.
    Before this problem wasn't happening, so I imagine some update might have broken something.
    Same here. Always resets to 74%. Same after a power save. It looks like an update broke something.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •