Results 1 to 7 of 7

Thread: Auto Aktualisierung Steam update geht nicht

  1. #1

    Default Auto Aktualisierung Steam update geht nicht

    Softwareaktualisierung will die Aktualisierung openSUSE-2021-1099(1), Recommended update for steam, installieren.
    Das geht aber nicht, da das Paket 'libpipewire-0_3-0-32bit' für steam-1.0.0.71-lp152.2.24.1.x86_64 nicht gefunden wird.
    Kennt jemand das? Danke.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,491

    Default AW: Auto Aktualisierung Steam update geht nicht

    Poste als root ausgeführt:
    Code:
    zypper up

  3. #3

    Default Re: Auto Aktualisierung Steam update geht nicht

    Danke für die schnelle Antwort. Ich weiß das sehr zu schätzen.

    Code:
    inux-t0qs:~ # zypper up
    Loading repository data...
    Reading installed packages...
    
    The following 4 package updates will NOT be installed:
      libgstgl-1_0-0 libquicktime0 steam steam-devices
    Nothing to do.
    linux-t0qs:~ #
    

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,491

    Default AW: Auto Aktualisierung Steam update geht nicht

    Was passiert bei einem:
    Code:
    zypper in -f steam steam-devices

  5. #5

    Default Re: Auto Aktualisierung Steam update geht nicht

    Hallo, bekam auch gerade den Patch openSUSE-2021-1099 für openSUSE Leap 15.2.

    Der Patch möchte libpipewire-0_3-0-32bit haben, welches es aber für openSUSE Leap 15.2 nicht gibt.
    Mein installiertes libpipewire kommt aus dem Hauptupdate Repository (keine 32bit Version vorhanden).

    Habe daher einen Bugreport erstellt: https://bugzilla.opensuse.org/show_bug.cgi?id=1189185

    Nachtrag: Für openSUSE Leap 15.3 gibt es zwar ibpipewire-0_3-0-32bit (u.a. Hauptupdate Repository), aber hier scheint dann Steam nicht mehr zu starten: https://bugzilla.opensuse.org/show_bug.cgi?id=1189181

  6. #6

    Default Re: Auto Aktualisierung Steam update geht nicht

    Kleiner Nachtrag:
    https://build.opensuse.org/package/rdiff/games:tools/steam?linkrev=base&rev=87
    hat die Abhängigkeit von "%dependency libpipewire-0_3-0" eingeführt. Diese wird aber nicht benötigt, da die Steam Runtime libpipewire-32bit mitbringt:
    Siehe auch https://github.com/ValveSoftware/ste...ment-847328220
    "having a 32 bit pipewire 0.3 client library on the host is entirely optional."

  7. #7

    Default Re: Auto Aktualisierung Steam update geht nicht

    Yup, ist auch bei mir so.

    Code:
    linux-t0qs:~ # zypper in -f steam steam-devices
    Loading repository data...
    Reading installed packages...
    Forcing installation of 'steam-1.0.0.71-lp152.2.24.1.x86_64' from repository 'openSUSE-Leap-15.2-Update-Non-Oss'.
    Forcing installation of 'steam-devices-1.0.0.71-lp152.2.24.1.x86_64' from repository 'openSUSE-Leap-15.2-Update-Non-Oss'.
    Resolving package dependencies...
    2 Problems:
    Problem: nothing provides 'libpipewire-0_3-0-32bit' needed by the to be installed steam-1.0.0.71-lp152.2.24.1.x86_64
    Problem: nothing provides 'libpipewire-0_3-0-32bit' needed by the to be installed steam-1.0.0.71-lp152.2.24.1.x86_64
    
    Problem: nothing provides 'libpipewire-0_3-0-32bit' needed by the to be installed steam-1.0.0.71-lp152.2.24.1.x86_64
     Solution 1: do not install steam-1.0.0.71-lp152.2.24.1.x86_64
     Solution 2: break steam-1.0.0.71-lp152.2.24.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 1
    
    Problem: nothing provides 'libpipewire-0_3-0-32bit' needed by the to be installed steam-1.0.0.71-lp152.2.24.1.x86_64
     Solution 1: do not install steam-devices-1.0.0.71-lp152.2.24.1.x86_64
     Solution 2: break steam-1.0.0.71-lp152.2.24.1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c/d/?] (c): 
    linux-t0qs:~ #
    

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •