Page 1 of 5 123 ... LastLast
Results 1 to 10 of 41

Thread: Very slow reboot or shutdown

  1. #1
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    277

    Default Very slow reboot or shutdown

    I have several machines on 15.3 now. One was a fresh install and others were upgrades from 15.2
    I am having a problem shutting down or rebooting. I hit a 1.5 minute shutdown pause quite often. The message is: ending session for user 1000 (me), ending session for user ronnie (also me, same user), or ending session 2 for user ronnie ( I never had a second session open)
    This did not exist on any of the 15.2 machines. It does occur in at least 2 of the 15.3 machines.
    I followed a suggestion from dcurtisfra on a 15.2 post and edited /etc/systemd/logind.conf to kill user ronnie, which did not work after reboot.

    Another user in the 15.2 post suggested that removing LVM packages solved his problem, but I do use LVM, so that is not an option.
    My drives are basic Luks, formatted in EXT4.

  2. #2

    Default Re: Very slow reboot or shutdown

    I would check the drive as it might be failing. Had a similar issue with long shutdowns that were due to the drive going bad.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,332

    Default AW: Very slow reboot or shutdown

    1,5 minutes (90 sec) seems a systemd service does not close......

    So press ESC to see, what is going on.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,402
    Blog Entries
    3

    Default Re: Very slow reboot or shutdown

    I think it is a user process that does not shutdown when it should.

    I use LUKS LVM and ext4. I am not seeing this problem.

    I do run a script on logout that does "pulseaudio --kill". I don't know if that is why I don't see this problem.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    277

    Default Re: Very slow reboot or shutdown

    Quote Originally Posted by nrickert View Post
    I think it is a user process that does not shutdown when it should.

    I use LUKS LVM and ext4. I am not seeing this problem.

    I do run a script on logout that does "pulseaudio --kill". I don't know if that is why I don't see this problem.
    I have never allowed pulse or pipewire to be installed. My last shutdown was quick, but my system was not up for long. The problem seems to occur more often when my system is up for a longer time.

    Pressing "esc" is how I saw the messages: "ending session for user "" and it is accompanied by a 1:30 timer. I see no other messages that might indicate which process is not shutting down properly. All processes that I run were also being run on 15.2 before the upgrade, and had no problem.

  6. #6
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    277

    Default Re: Very slow reboot or shutdown

    Quote Originally Posted by AdmFubar View Post
    I would check the drive as it might be failing. Had a similar issue with long shutdowns that were due to the drive going bad.
    It's an M.2 drive and it has been verified good by testing with full scan by Mfr's software.

  7. #7
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    277

    Default Re: Very slow reboot or shutdown

    Is it possible that it has something to do with drive caching? I do often move large files and the "write" policy is set to whatever the openSUSE default is. I have 64GB of RAM and the write cache often fills 99% of it.

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,402
    Blog Entries
    3

    Default Re: Very slow reboot or shutdown

    I'm doubting that. Your problem seems to be with user processes, while drive caching is managed by system processes.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  9. #9
    Join Date
    Aug 2008
    Location
    Texas, US
    Posts
    277

    Default Re: Very slow reboot or shutdown

    It may be unrelated, but I'll mention it since Luks was brought up earlier. When I booted this morning, one of my Luks volumes was not mounted. Upon checking, it no longer had an entry in /dev/mapper. The drive and partition showed up in Yast partitioner, but mounting options were not available. I manually re-created the mapping via cryptsetup and gave it the original name. Once that was done, the partitioner showed the original correct mounting path.

    This partition is mounted within my "home" partition, making user "me" the owner. Is it possible the system is having problems releasing that drive, and thus can't end my session? Also, would it be possible that the mapping of the drive was lost in crypttab and /dev/mapper/ because the drive was forced to stop (after 1:30) before operations were completed? The disk passes diagnostic tests, and these problems did not exist in openSUSE 15.2

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,402
    Blog Entries
    3

    Default Re: Very slow reboot or shutdown

    It's hard to know. With that information, I would be guessing.

    I will note, however, that the 15.3 installer may have set them up a little differently from the 15.2 installer.

    After an install, I sometimes edit "/etc/crypttab" to set them up as I want. And if I change anything there, then I make any corresponding changes in "/etc/fstab" and then run "mkinitrd" to regenerate the "initrd".
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Page 1 of 5 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •