Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Wifi problem with Asus M415D

  1. #1

    Default Wifi problem with Asus M415D

    Hi,
    I can't use wifi with my Asus M415D (openSUSE 15.3). No ssid appears in the little box at the bottom right corner of the computer. I tried many things with the openSUSE french community Alionet (install rtl8821ce, as my wifi card is AzureWave AW-CB231NF), but it didn't work, and they ask me to contact Sauerland here, as he is the one who is in charge of the rtl8821ce. I will of course be grateful of the help of anyone of you.

    Thanks

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,491

    Default AW: Wifi problem with Asus M415D

    Post:
    Code:
    /sbin/lspci | grep -iA3 net
    Code:
    uname -a

  3. #3

    Default Re: Wifi problem with Asus M415D

    Thanks a lot Sauerland.
    Code:
    /sbin/lspci | grep -iA3 net
    01:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter
    02:00.0 Non-Volatile memory controller: Kingston Technology Company, Inc. Device 500c (rev 01)
    03:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Picasso (rev c2)
    03:00.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Raven/Raven2/Fenghuang HDMI/DP Audio Controller
    Code:
    is@localhost:~> uname -a
    Linux localhost.localdomain 5.3.18-59.5-default #1 SMP Wed Jun 2 08:21:36 UTC 2021 (eaf040d) x86_64 x86_64 x86_64 GNU/Linux
    Last edited by Sauerland; 23-Jun-2021 at 07:58.

  4. #4

    Default Re: Wifi problem with Asus M415D

    Also:

    Code:
    sudo lspci -nnkd ::280
    [sudo] Mot de passe de root : 
    01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
            Subsystem: AzureWave Device [1a3b:3040]
            Kernel modules: rtw88_8821ce, rtw_8821ce, wl, 8821ce

    Code:
    is@localhost:~> zypper lr -U
    Les priorités des dépôts sont sans effet. Tous les dépôts activés partagent la même priorité.
    
    #  | Alias                                        | Name                                                                                        | Enab-> | GPG Check        | Refresh    | URI
    ---+----------------------------------------------+---------------------------------------------------------------------------------------------+--------+------------------+------------+------------------------------------------------------------------------------------------------
     4 | openSUSE-Leap-15.3-1                         | openSUSE-Leap-15.3-1                                                                        | Non    | ----             | ----       | hd:/?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_5B870F000110-0:0-part2
     9 | repo-debug-non-oss                           | Debug Repository (Non-OSS)                                                                  | Non    | ----             | ----       | http://download.opensuse.org/debug/d.../repo/non-oss/
     8 | repo-debug                                   | Debug Repository                                                                            | Non    | ----             | ----       | http://download.opensuse.org/debug/d...15.3/repo/oss/
    11 | repo-debug-update-non-oss                    | Update Repository (Debug, Non-OSS)                                                          | Non    | ----             | ----       | http://download.opensuse.org/debug/u.../15.3/non-oss/
    10 | repo-debug-update                            | Update Repository (Debug)                                                                   | Non    | ----             | ----       | http://download.opensuse.org/debug/u...leap/15.3/oss/
    14 | repo-sle-debug-update                        | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | Non    | ----             | ----       | http://download.opensuse.org/debug/u...leap/15.3/sle/
    12 | repo-non-oss                                 | Dépôt Non-OSS                                                                               | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/distrib.../repo/non-oss/
    13 | repo-oss                                     | Dépôt principal                                                                             | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/distrib...15.3/repo/oss/
    16 | repo-source                                  | Source Repository                                                                           | Non    | ----             | ----       | http://download.opensuse.org/source/...15.3/repo/oss/
     7 | repo-backports-update                        | Update repository of openSUSE Backports                                                     | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/...5.3/backports/
     6 | repo-backports-debug-update                  | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | Non    | ----             | ----       | http://download.opensuse.org/update/...ckports_debug/
    18 | repo-update-non-oss                          | Dépôt de mises à jour (Non-OSS)                                                             | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.3/non-oss/
    17 | repo-update                                  | Dépôt principal de mise à jour                                                              | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.3/oss
    15 | repo-sle-update                              | Update repository with updates from SUSE Linux Enterprise 15                                | Oui    | (r ) Oui         | Oui        | http://download.opensuse.org/update/leap/15.3/sle/
     1 | ftp.gwdg.de-openSUSE_Leap_$releasever        | Packman Repository                                                                          | Oui    | (r ) Oui         | Oui        | http://ftp.gwdg.de/pub/linux/misc/pa...USE_Leap_15.3/
     5 | opensuse-guide.org-openSUSE_Leap_$releasever | Libdvdcss Repository                                                                        | Oui    | (r ) Oui         | Oui        | http://opensuse-guide.org/repo/openSUSE_Leap_15.3/
     2 | home_Sauerland_hardware                      | Hardware (openSUSE_Leap_15.3_Update)                                                        | Oui    | (r ) Oui         | Non        | https://download.opensuse.org/reposi...p_15.3_Update/
     3 | https-download.opensuse.org-8facad13         | openSUSE:Backports:SLE-15-SP3                                                               | Oui    | (r ) Oui         | Oui        | https://download.opensuse.org/reposi...-SP3/standard/
    Code:
    is@localhost:~> zypper search -s rtl8821 rtw88
    Le dépôt 'Update repository with updates from SUSE Linux Enterprise 15' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
    Chargement des données du dépôt...
    Avertissement : Le dépôt 'openSUSE:Backports:SLE-15-SP3' semble être obsolète. Envisagez d'utiliser un autre miroir ou un autre serveur.
    Lecture des paquets installés...
    
    S  | Name                           | Type          | Version                            | Arch         | Repository
    ---+--------------------------------+---------------+------------------------------------+--------------+-------------------------------------
       | rtl8821ae-firmware             | paquet        | 0.7.git20208019-lp153.2.1          | noarch       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821ce                      | paquet source | git20210529-lp153.3.1              | noarch       | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-blacklist-rtw_8821ce | paquet        | git20210529-lp153.3.1              | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-kmp-default          | paquet        | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821ce-kmp-preempt          | paquet        | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu                      | paquet source | 20210527-lp153.3.1                 | noarch       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu-kmp-default          | paquet        | 20210527_k5.3.18_59.5-lp153.3.1    | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu-kmp-preempt          | paquet        | 20210527_k5.3.18_59.5-lp153.3.1    | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtw88                          | paquet source | git20210618-lp153.2.1              | noarch       | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtw88-kmp-default              | paquet        | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtw88-kmp-preempt              | paquet        | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
    is@localhost:~>
    Last edited by Sauerland; 23-Jun-2021 at 08:06.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,491

    Default AW: Wifi problem with Asus M415D

    First:
    My fault, should be
    Code:
    /sbin/lspci -nnk | grep -iA3 net
    but you have it posted:
    Code:
    [sudo] Mot de passe de root : 
    01:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8821CE 802.11ac PCIe Wireless Network Adapter [10ec:c821]
            Subsystem: AzureWave Device [1a3b:3040]
            Kernel modules: rtw88_8821ce, rtw_8821ce, wl, 8821ce
    Second:
    Please use Code-Tags:
    https://forums.opensuse.org/showthre...und-Your-Paste
    I changed your posts.

    Third:
    When you use not English at your native language, please add for every command you post:
    Code:
    LANG=C
    That will show the commannd with English output:
    My native language is German:
    Code:
    zypper se -si rtw rtl8821ce
    Repository-Daten werden geladen...
    Installierte Pakete werden gelesen...
    
    S  | Name                 | Type  | Version                            | Arch   | Repository
    ---+----------------------+-------+------------------------------------+--------+-----------------
    i  | libKPimImportWizard5 | Paket | 20.04.2-bp153.1.28                 | x86_64 | OSS
    i+ | rtw88-kmp-default    | Paket | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Sauerland-Update
    Now with LANG=C:
    Code:
    stephan@laptop:~> LANG=C zypper se -si rtw rtl8821ce
    Loading repository data...
    Reading installed packages...
    
    S  | Name                 | Type    | Version                            | Arch   | Repository
    ---+----------------------+---------+------------------------------------+--------+-----------------
    i  | libKPimImportWizard5 | package | 20.04.2-bp153.1.28                 | x86_64 | OSS
    i+ | rtw88-kmp-default    | package | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Sauerland-Update

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,491

    Default AW: Wifi problem with Asus M415D

    Answer:
    Please use only one kmp, not both:
    Code:
    is@localhost:~> zypper search -s rtl8821 rtw88
    Le dépôt 'Update repository with updates from SUSE Linux Enterprise 15' n'est pas à jour. Vous pouvez lancer 'zypper refresh' en tant que root pour le mettre à jour.
    Chargement des données du dépôt...
    Avertissement : Le dépôt 'openSUSE:Backports:SLE-15-SP3' semble être obsolète. Envisagez d'utiliser un autre miroir ou un autre serveur.
    Lecture des paquets installés...
    
    S  | Name                           | Type          | Version                            | Arch         | Repository
    ---+--------------------------------+---------------+------------------------------------+--------------+-------------------------------------
       | rtl8821ae-firmware             | paquet        | 0.7.git20208019-lp153.2.1          | noarch       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821ce                      | paquet source | git20210529-lp153.3.1              | noarch       | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-blacklist-rtw_8821ce | paquet        | git20210529-lp153.3.1              | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-kmp-default          | paquet        | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821ce-kmp-preempt          | paquet        | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu                      | paquet source | 20210527-lp153.3.1                 | noarch       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu-kmp-default          | paquet        | 20210527_k5.3.18_59.5-lp153.3.1    | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu-kmp-preempt          | paquet        | 20210527_k5.3.18_59.5-lp153.3.1    | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtw88                          | paquet source | git20210618-lp153.2.1              | noarch       | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtw88-kmp-default              | paquet        | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
       | rtw88-kmp-preempt              | paquet        | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64       | Hardware (openSUSE_Leap_15.3_Update)
    is@localhost:~>
    See my last post:
    Only:
    Code:
    i+ | rtw88-kmp-default    | Paket | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Sauerland-Update
    Wlan is working.

  7. #7

    Default Re: AW: Wifi problem with Asus M415D

    Thanks for your remarks.
    Do I erase every kmp-preempt, or do I keep only this one:
    Code:
    i+ | rtw88-kmp-default    | Paket | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Sauerland-Update
    I'm coming back with the english responses, I'm sorry I didn't realize.

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,491

    Default AW: Wifi problem with Asus M415D

    is@localhost:~> uname -a
    Linux localhost.localdomain 5.3.18-59.5-default #1 SMP Wed Jun 2 08:21:36 UTC 2021 (eaf040d) x86_64 x86_64 x86_64 GNU/Linux
    So this one should work:
    i+ | rtw88-kmp-default | Paket | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Sauerland-Update
    Both rtl8821ce packages can be deleted:
    i+ | rtl8821ce-blacklist-rtw_8821ce | paquet | git20210529-lp153.3.1 | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-kmp-default | paquet | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
    After this restart your Computer.

  9. #9

    Default Re: Wifi problem with Asus M415D

    In english now:

    Code:
    is@localhost:~> LANG=C zypper lr -U
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                                        | Name                                                                                        | Enabled | GPG Check | Refresh | URI
    ---+----------------------------------------------+---------------------------------------------------------------------------------------------+---------+-----------+---------+------------------------------------------------------------------------------------------------
     4 | openSUSE-Leap-15.3-1                         | openSUSE-Leap-15.3-1                                                                        | No      | ----      | ----    | hd:/?device=/dev/disk/by-id/usb-Kingston_DataTraveler_2.0_5B870F000110-0:0-part2
     9 | repo-debug-non-oss                           | Debug Repository (Non-OSS)                                                                  | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.3/repo/non-oss/
     8 | repo-debug                                   | Debug Repository                                                                            | No      | ----      | ----    | http://download.opensuse.org/debug/distribution/leap/15.3/repo/oss/
    11 | repo-debug-update-non-oss                    | Update Repository (Debug, Non-OSS)                                                          | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.3/non-oss/
    10 | repo-debug-update                            | Update Repository (Debug)                                                                   | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.3/oss/
    14 | repo-sle-debug-update                        | Update repository with debuginfo for updates from SUSE Linux Enterprise 15                  | No      | ----      | ----    | http://download.opensuse.org/debug/update/leap/15.3/sle/
    12 | repo-non-oss                                 | Dépôt Non-OSS                                                                               | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.3/repo/non-oss/
    13 | repo-oss                                     | Dépôt principal                                                                             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/distribution/leap/15.3/repo/oss/
    16 | repo-source                                  | Source Repository                                                                           | No      | ----      | ----    | http://download.opensuse.org/source/distribution/leap/15.3/repo/oss/
     7 | repo-backports-update                        | Update repository of openSUSE Backports                                                     | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.3/backports/
     6 | repo-backports-debug-update                  | Update repository with updates for openSUSE Leap debuginfo packages from openSUSE Backports | No      | ----      | ----    | http://download.opensuse.org/update/leap/15.3/backports_debug/
    18 | repo-update-non-oss                          | Dépôt de mises à jour (Non-OSS)                                                             | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.3/non-oss/
    17 | repo-update                                  | Dépôt principal de mise à jour                                                              | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.3/oss
    15 | repo-sle-update                              | Update repository with updates from SUSE Linux Enterprise 15                                | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.3/sle/
     1 | ftp.gwdg.de-openSUSE_Leap_$releasever        | Packman Repository                                                                          | Yes     | (r ) Yes  | Yes     | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_15.3/
     5 | opensuse-guide.org-openSUSE_Leap_$releasever | Libdvdcss Repository                                                                        | Yes     | (r ) Yes  | Yes     | http://opensuse-guide.org/repo/openSUSE_Leap_15.3/
     2 | home_Sauerland_hardware                      | Hardware (openSUSE_Leap_15.3_Update)                                                        | Yes     | (r ) Yes  | No      | https://download.opensuse.org/repositories/home:/Sauerland:/hardware/openSUSE_Leap_15.3_Update/
     3 | https-download.opensuse.org-8facad13         | openSUSE:Backports:SLE-15-SP3                                                               | Yes     | (r ) Yes  | Yes     | https://download.opensuse.org/repositories/openSUSE:/Backports:/SLE-15-SP3/standard/
    Code:
    is@localhost:~> LANG=C zypper search -s rtl8821 rtw88
    Repository 'Update repository with updates from SUSE Linux Enterprise 15' is out-of-date. You can run 'zypper refresh' as root to update it.
    Loading repository data...
    Warning: Repository 'openSUSE:Backports:SLE-15-SP3' appears to be outdated. Consider using a different mirror or server.
    Reading installed packages...
    
    S  | Name                           | Type       | Version                            | Arch   | Repository
    ---+--------------------------------+------------+------------------------------------+--------+-------------------------------------
       | rtl8821ae-firmware             | package    | 0.7.git20208019-lp153.2.1          | noarch | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821ce                      | srcpackage | git20210529-lp153.3.1              | noarch | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-blacklist-rtw_8821ce | package    | git20210529-lp153.3.1              | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtl8821ce-kmp-default          | package    | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821ce-kmp-preempt          | package    | git20210529_k5.3.18_59.5-lp153.3.1 | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu                      | srcpackage | 20210527-lp153.3.1                 | noarch | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu-kmp-default          | package    | 20210527_k5.3.18_59.5-lp153.3.1    | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
       | rtl8821cu-kmp-preempt          | package    | 20210527_k5.3.18_59.5-lp153.3.1    | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
       | rtw88                          | srcpackage | git20210618-lp153.2.1              | noarch | Hardware (openSUSE_Leap_15.3_Update)
    i+ | rtw88-kmp-default              | package    | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Hardware (openSUSE_Leap_15.3_Update)
       | rtw88-kmp-preempt              | package    | git20210618_k5.3.18_59.5-lp153.2.1 | x86_64 | Hardware (openSUSE_Leap_15.3_Update)

  10. #10

    Default Re: AW: Wifi problem with Asus M415D

    Quote Originally Posted by Sauerland View Post
    So this one should work:

    Both rtl8821ce packages can be deleted:


    After this restart your Computer.
    I deleted theses packages and restarted the computer, but unfortunately I don't see any ssid. Maybe I forgot something. Thanks for your help.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •