Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: FreeCAD AppImage startet nicht mehr

  1. #1

    Default FreeCAD AppImage startet nicht mehr

    Hallo,

    seit einem Betriebssystem Update am 05.06.21 startet das FreeCAD AppImage nicht mehr, aus der Konsole gestartet bekomme ich diese Fehlermeldung:

    Code:
      libGL error: MESA-LOADER: failed to open radeonsi: /tmp/.mount_FreeCA7xBXDh/usr/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/dri/radeonsi_dri.so) (search paths /usr/lib64/dri)libGL error: failed to load driver: radeonsilibGL error: MESA-LOADER: failed to open radeonsi: /tmp/.mount_FreeCA7xBXDh/usr/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/dri/radeonsi_dri.so) (search paths /usr/lib64/dri)libGL error: failed to load driver: radeonsilibGL error: MESA-LOADER: failed to open swrast: /tmp/.mount_FreeCA7xBXDh/usr/bin/../lib/libstdc++.so.6: version `GLIBCXX_3.4.29' not found (required by /usr/lib64/dri/swrast_dri.so) (search paths /usr/lib64/dri)libGL error: failed to load driver: swrast
    Ich erhalte die Fehlermeldungen mit allen FreeCAD Appimages, auch solchen die vor dem oben genannten Update problemlos gelaufen sind.

    Kann ich mit Tumbleweed auf frühere Pakete "downgraden" ? Ein Update auf die Kernel Module aus dem Sauerland Repo hat nichts gebracht...

    Die Datei die nach der GLIBCXX_3.4.29 sucht ist zwar Bestandteil des AppImages (wenn ich die Fehlermeldung richtig deute...), aber bis zu oben genanntem Datum funktionierte ja alles.

    Falls jemand eine andere Idee hat als "zurücksetzen", - bitte sagen...

  2. #2
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,995

    Default Re: FreeCAD AppImage startet nicht mehr

    Quote Originally Posted by herbk View Post
    Falls jemand eine andere Idee hat als "zurücksetzen", - bitte sagen...
    Code:
    3400G:~ # zypper in freecad 
    Loading repository data... 
    Reading installed packages... 
    'freecad' not found in package names. Trying capabilities. 
    'FreeCAD' providing 'freecad' is already installed. 
    Resolving package dependencies... 
    Nothing to do. 
    3400G:~ #
    
    
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  3. #3

    Default Re: FreeCAD AppImage startet nicht mehr

    Quote Originally Posted by karlmistelberger View Post
    Code:
    3400G:~ # zypper in freecad 
    Loading repository data... 
    Reading installed packages... 
    'freecad' not found in package names. Trying capabilities. 
    'FreeCAD' providing 'freecad' is already installed. 
    Resolving package dependencies... 
    Nothing to do. 
    3400G:~ #
    
    
    Hallo Karl,

    ich kann nicht nachvollziehen was Du mir damit sagen willst, - sorry...

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: FreeCAD AppImage startet nicht mehr

    'FreeCAD' providing 'freecad' is already installed.
    Code:
    zypper in FreeCAD

  5. #5

    Default Re: FreeCAD AppImage startet nicht mehr

    Falls Ihr mit den hingeworfenen Brocken meint ich soll FreeCAD aus dem Repo laden... , - das habe ich.
    Das AppImage bietet nur einen höheren Funktionsumfang, - weshalb ich überhaupt erst dazu gewechselt habe.

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: FreeCAD AppImage startet nicht mehr

    Falls Ihr mit den hingeworfenen Brocken meint ich soll FreeCAD aus dem Repo laden... , - das habe ich.
    Das hättest du dann erwähnen können, dann hätten wir dir solche Brocken nicht hinwerfen müssen.......

    Was sagt:
    Code:
    strings /usr/lib64/libstdc++.so.6 | grep GLIBCXX

  7. #7
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,995

    Default Re: FreeCAD AppImage startet nicht mehr

    Quote Originally Posted by herbk View Post
    Falls Ihr mit den hingeworfenen Brocken meint ich soll FreeCAD aus dem Repo laden... , - das habe ich. Das AppImage bietet nur einen höheren Funktionsumfang, - weshalb ich überhaupt erst dazu gewechselt habe.
    Du könntest etwas netter sein und uns das bereits im ersten Post mitteilen.Welche Versionsnummern haben deine AppImages?
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  8. #8
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,495

    Default AW: FreeCAD AppImage startet nicht mehr

    Zusätzlich:
    Wenn ich den Download richtig interpretiere wird das mit eingebauter glibc2.12 gebaut.
    https://github.com/FreeCAD/FreeCAD/r...86_64.AppImage

    Tumbleweed hat 2.33.

    Also solltest du einmal bei FreeCad nachfragen......

  9. #9

    Default Re: FreeCAD AppImage startet nicht mehr

    Hallo Karl,

    die Frage "hast Du FreeCAD aus dem Repo auch installiert" hätte ich verstanden...
    Aber sollen Appimages nicht eigenständig laufen? Ich habe da keinen zusammenhang gesehen, deshalb habe ich das nicht erwähnt...

    Im Moment betrifft das alle FreeCAD Appimages, die für die 0.19er (stable) und die 0.20er (devl), komplette aktuelle Versionsnummer der "develop" ist Version: 0.20.25065.

    strings /usr/lib64/libstdc++.so.6 | grep GLIBCXX
    ergbibt diese Ausgabe:

    Code:
    GLIBCXX_3.4
    GLIBCXX_3.4.1
    GLIBCXX_3.4.2
    GLIBCXX_3.4.3
    GLIBCXX_3.4.4
    GLIBCXX_3.4.5
    GLIBCXX_3.4.6
    GLIBCXX_3.4.7
    GLIBCXX_3.4.8
    GLIBCXX_3.4.9
    GLIBCXX_3.4.10
    GLIBCXX_3.4.11
    GLIBCXX_3.4.12
    GLIBCXX_3.4.13
    GLIBCXX_3.4.14
    GLIBCXX_3.4.15
    GLIBCXX_3.4.16
    GLIBCXX_3.4.17
    GLIBCXX_3.4.18
    GLIBCXX_3.4.19
    GLIBCXX_3.4.20
    GLIBCXX_3.4.21
    GLIBCXX_3.4.22
    GLIBCXX_3.4.23
    GLIBCXX_3.4.24
    GLIBCXX_3.4.25
    GLIBCXX_3.4.26
    GLIBCXX_3.4.27
    GLIBCXX_3.4.28
    GLIBCXX_3.4.29
    GLIBCXX_DEBUG_MESSAGE_LENGTH
    
    
    Die gleiche Abfrage auf die libstd++.so.6 des (entpackten) Appimages geht nur bis GLIBCXX3.4.28. Das Verzeichnis /usr/lib64/ enthält auch eine libstd++.so.6.0.29, im Appimage ist es nur eine libstd++.so.6.0.28.

    Wenn ich die libstd++.so.6 im Appimage durch die aus usr/lib64/ ersetze startet das Appimage wieder, so viel habe ich Gestern noch herausgefunden...

  10. #10

    Default Re: AW: FreeCAD AppImage startet nicht mehr

    Quote Originally Posted by Sauerland View Post
    Zusätzlich:
    Wenn ich den Download richtig interpretiere wird das mit eingebauter glibc2.12 gebaut.
    https://github.com/FreeCAD/FreeCAD/r...86_64.AppImage

    Tumbleweed hat 2.33.

    Also solltest du einmal bei FreeCad nachfragen......
    Ja, aber sollte da nicht eine wenig abwärtskompatibilität da sein?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •