Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: upgrade from 15.2 - no GUI

  1. #1

    Default upgrade from 15.2 - no GUI

    Today I upgraded my second computer to Leap15.3 (no problems with the first one). This is an old Dell Edge server with 2 GB Ram and XGI Technology Inc. (eXtreme Graphicc Innovation Z7/Z9 (XG20 core). Install ran without any problems but with the first boot I got the following error messages [192.973364] blk_update_request: I/O error, dev fd0, sector 0 op 0x0: (READ) flags 0x0 phys_seg 1 prio class 0 .
    (The number in the square bracket change each time that message comes).
    Then the screen stays black with the text "login:" I loged in as root and did a zypper up and got the following message:
    patch SUSE-2021-1526-1.noarch problems conflicts with readline-doc < 7.0-19.3.1 provided by readline-doc-7.0-17.83.noarch

    As root I tried the startx command and the computer went into the GUI. So the graphics support there looked OK. I logged off again and typed this on my Tumbleweed computer. Any support is appreciated.
    Cheers
    Uli

  2. #2

    Default Re: upgrade from 15.2 - no GUI

    OK a few more infos:
    Code:
    uli@fft:~> systemctl get-default
    graphical.target
    I edited the GRUB menu - added nomodeset and the computer booted into the GUI. There I received the message "Software update You have 1 new update" When I started the update I got: "Software update patch:SUSE-2021-1526-1.noarch conflicts with readline-doc".

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,271
    Blog Entries
    3

    Default Re: upgrade from 15.2 - no GUI

    Quote Originally Posted by fuerstu View Post
    When I started the update I got: "Software update patch:SUSE-2021-1526-1.noarch conflicts with readline-doc".
    That has been reported as Bug 1186879

    I suggest you use only
    Code:
    zypper up
    at the root command line for updating. Other ways of updating are being confused by patches which seem to be intended for SLE only and not for openSUSE.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4

    Default Re: upgrade from 15.2 - no GUI

    Thanks, nrickert, any idea how to get the GUI back? Or should I add the nomodeset permanently to GRUB?

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,271
    Blog Entries
    3

    Default Re: upgrade from 15.2 - no GUI

    I'm not a graphics card expert. There's a good chance that somebody who is familiar with that card will be able to help.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  6. #6
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,020
    Blog Entries
    1

    Default Re: upgrade from 15.2 - no GUI

    I have a Gigabyte server motherboard with this IGP:
    Code:
    0a:03.0 VGA compatible controller: XGI Technology Inc. (eXtreme Graphics Innovation) Z7/Z9 (XG20 core) (prog-if 00 [VGA controller])
    	Subsystem: Gigabyte Technology Co., Ltd Device 0020
    	Flags: 66MHz, medium devsel
    	BIST result: 00
    	Memory at dc000000 (32-bit, prefetchable) [size=32M]
    	Memory at de000000 (32-bit, non-prefetchable) [size=256K]
    	I/O ports at 6400 [size=128]
    	Expansion ROM at <unassigned> [disabled]
    	Capabilities: [40] Power Management version 2
    	Kernel modules: xgifb
    I installed an accessory graphics card in it years ago because there was no satisfactory Linux driver support for the XGI regardless of distro. This is a common situation with GPUs not made by AMD, Intel or NVidia. IIRC the only way to run Xorg on it was with the VESA or FBDEV Xorg driver. Both these two drivers are unaccelerated and limited in support for resolutions above 1024x768. Whether optimal configuration requires nomodeset or not I cannot recall. It's been quite some years since I tried to use it.
    Reg. Linux User #211409 *** multibooting since 1992
    Primary: 15.2, +TW, 15.3, 15.1 & 13.1 on Haswell
    Secondary: eComStation (OS/2) &15.2 on i965P w/ Radeon
    Tertiary: Mageia,Fedora,Debian,more on Kaby Lake,iQ45,iQ43,iG41,iG3X,i965G,AMD,NVidia&&&&&

  7. #7

    Default Re: upgrade from 15.2 - no GUI

    Thank you, mrmazda, I know the graphics card is hopeless. But this computer has little use, mainly for scanning and if I ever need Windows it still has an old WinXP system there which I haven't used for years. The error message I wrote in my first post here comes from the old floppy drive and I disabled the floppy now in the BIOS. For now I have added the nomodeset and now I have enough for today. Tomorrow I will try to see if the VESA or FBDEV drivers are present. May be someone has a bright idea by then....

  8. #8
    Join Date
    Sep 2012
    Posts
    6,633

    Default Re: upgrade from 15.2 - no GUI

    Quote Originally Posted by fuerstu View Post
    Tomorrow I will try to see if the VESA or FBDEV drivers are present.
    That is what you get with "nomodeset" option.

  9. #9

    Default Re: upgrade from 15.2 - no GUI

    Quote Originally Posted by nrickert View Post
    That has been reported as Bug 1186879

    I suggest you use only
    Code:
    zypper up
    at the root command line for updating. Other ways of updating are being confused by patches which seem to be intended for SLE only and not for openSUSE.
    Good tip, same error and it worked with the zypper update from command line

  10. #10

    Default Re: upgrade from 15.2 - no GUI

    Thanks, arvidjaar, I didn't know to which driver it will revert back with the nomodeset command - all I understand is that it will refer back to a generic driver.. But if it worked somehow reasonably before with LEAP15.2 right down to version 9.2 (I have this computer since 2004) why doesn't it work after the upgrade?

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •