Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Wayland not listed by the login manager after installing OS

  1. #1

    Question Wayland not listed by the login manager after installing OS

    Hey guys,
    I have a Opensuse Tumbleweed x86_64 with Gnome and I already have gnome-session-wayland installed but wayland isn't listed by the login manager.
    When I enter "echo $XDG_SESSION_TYPE" I get "x11" and also my display manager "/etc/alternatives/default-displaymanager -> /usr/lib/X11/displaymanagers/gdm".
    I have my Nvidia graphics card driver up to date.
    Kernel: "5.12.4-1-default"
    DE: "GNOME 40.0"

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,718
    Blog Entries
    15

    Default Re: Wayland not listed by the login manager after installing OS

    Quote Originally Posted by devmahdish View Post
    Hey guys,
    I have a Opensuse Tumbleweed x86_64 with Gnome and I already have gnome-session-wayland installed but wayland isn't listed by the login manager.
    When I enter "echo $XDG_SESSION_TYPE" I get "x11" and also my display manager "/etc/alternatives/default-displaymanager -> /usr/lib/X11/displaymanagers/gdm".
    I have my Nvidia graphics card driver up to date.
    Kernel: "5.12.4-1-default"
    DE: "GNOME 40.0"
    Hi and welcome to the forum
    It is the default, eg GNOME, only (if like me) want to switch to Xorg or other...... you can verify via;

    Code:
    echo $XDG_SESSION_TYPE
    
    or
    
    loginctl show-session <number> -p Type
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Arrow Re: Wayland not listed by the login manager after installing OS

    Code:
    echo $XDG_SESSION_TYPE
    
    Output:
    x11
    
    loginctl show-session <number> -p Type
    
    Command "loginctl show-session 1 -p Type" output:
    Type=x11

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    31,718
    Blog Entries
    15

    Default Re: Wayland not listed by the login manager after installing OS

    Hi
    If using nvidia also need to edit /etc/gdm/custom.conf to disable Wayland for gdm and use Xorg....
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  5. #5

    Default Re: Wayland not listed by the login manager after installing OS

    Quote Originally Posted by malcolmlewis View Post
    Hi
    If using nvidia also need to edit /etc/gdm/custom.conf to disable Wayland for gdm and use Xorg....
    But I want to have Wayland.

    There is no Wayland as you can see.


  6. #6

    Arrow Re: Wayland not listed by the login manager after installing OS

    First config:
    Code:
    # GDM configuration storage
    #
    # Note: settings from /etc/sysconfig/displaymanager have a higher priority
    #
    
    
    [daemon]
    # Uncomment the line below to force the login screen to use Xorg
    WaylandEnable=true
    
    
    [security]
    
    
    [xdmcp]
    
    
    [chooser]
    
    
    [debug]
    # Uncomment the line below to turn on debugging
    #Enable=true

    Second config:
    Code:
    # GDM configuration storage
    #
    # Note: settings from /etc/sysconfig/displaymanager have a higher priority
    #
    
    
    [daemon]
    # Uncomment the line below to force the login screen to use Xorg
    WaylandEnable=false
    
    
    [security]
    
    
    [xdmcp]
    
    
    [chooser]
    
    
    [debug]
    # Uncomment the line below to turn on debugging
    #Enable=true

    Third config:
    Code:
    # GDM configuration storage
    #
    # Note: settings from /etc/sysconfig/displaymanager have a higher priority
    #
    
    
    [daemon]
    # Uncomment the line below to force the login screen to use Xorg
    #WaylandEnable=false
    
    
    [security]
    
    
    [xdmcp]
    
    
    [chooser]
    
    
    [debug]
    # Uncomment the line below to turn on debugging
    #Enable=true
    None of these three cases worked.

  7. #7
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,345

    Default AW: Wayland not listed by the login manager after installing OS

    Post:
    Code:
    zypper se -si wayland

  8. #8

    Arrow Re: AW: Wayland not listed by the login manager after installing OS

    The output of the command "zypper se -si wayland" is:
    Code:
    Loading repository data...
    Reading installed packages...
    
    
    S | Name                  | Type    | Version    | Arch   | Repository
    --+-----------------------+---------+------------+--------+----------------------
    i | gnome-session-wayland | package | 40.1.1-1.1 | x86_64 | Main Repository (OSS)
    i | libQt5WaylandClient5  | package | 5.15.2-4.1 | x86_64 | Main Repository (OSS)
    i | libgstwayland-1_0-0   | package | 1.18.4-3.2 | x86_64 | Main Repository (OSS)
    i | libwayland-client0    | package | 1.19.0-1.3 | x86_64 | Main Repository (OSS)
    i | libwayland-cursor0    | package | 1.19.0-1.3 | x86_64 | Main Repository (OSS)
    i | libwayland-egl1       | package | 1.19.0-1.3 | x86_64 | Main Repository (OSS)
    i | libwayland-server0    | package | 1.19.0-1.3 | x86_64 | Main Repository (OSS)
    i | xwayland              | package | 21.1.1-1.1 | x86_64 | Main Repository (OSS)

  9. #9
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,345

    Default AW: Wayland not listed by the login manager after installing OS

    I have installed gnome-session-wayland and must use the second gnome entry in my sddm displaymanager:

  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,313
    Blog Entries
    1

    Default Re: AW: Wayland not listed by the login manager after installing OS

    Quote Originally Posted by Sauerland View Post
    I have installed gnome-session-wayland and must use the second gnome entry in my sddm displaymanager:
    +1 from me. The entries can be renamed (to be more meaningful) if desired.
    openSUSE Leap 15.3; KDE Plasma 5

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •