Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Kmail smtp timeout

  1. #1
    Join Date
    Aug 2014
    Location
    Hyderabad, India
    Posts
    58

    Default Kmail smtp timeout

    Dear All,

    I am in need of help in sending emails from kmail.
    It is showing SMTP timeout, though I am able to recieve mails through imap but sending is failed as it is saying connection timout.

    smtp settings are: smtp.myorg.name port: 587 security: STARTTLS

    I am also getting same problem on latest mozilla thunderbird(78.x on windows10), though send mail is working fine in thunderbird 68.10.0(ubuntu 18.04) on a different machine.

    It seems some issue of TLS version. How can I solve these two problems ?

    Thank You

  2. #2
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    556

    Default Re: Kmail smtp timeout

    See this page for trying SMTP from the command prompt:

    https://halon.io/blog/how-to-test-sm...-command-line/

    What do you see if you follow the Test TLS section?

  3. #3
    Join Date
    Aug 2014
    Location
    Hyderabad, India
    Posts
    58

    Default Re: Kmail smtp timeout

    Quote Originally Posted by marel View Post
    See this page for trying SMTP from the command prompt:

    https://halon.io/blog/how-to-test-sm...-command-line/

    What do you see if you follow the Test TLS section?
    Following above link when I ran commands as below on my Leap 15.2 system, I got below

    Code:
    ➜  ~ nc smtp.myorg.name 587
    ➜
    ➜  ~ openssl s_client -connect smtp.myorg.name:587 -starttls smtp
    140060886372800:error:0200206E:system library:connect:Connection timed out:crypto/bio/b_sock2.c:110:
    140060886372800:error:2008A067:BIO routines:BIO_connect:connect error:crypto/bio/b_sock2.c:111:
    connect:errno=110
    ➜  ~ openssl version
    OpenSSL 1.1.1d  10 Sep 2019
    ➜  ~
    Interestingly, I happened to change my Internet provider from Broadband to 4G Hotspot, and re ran commands, and look everything worked smoothly

    Code:
    ➜  ~ nc smtp.myorg.name 587                                    
    220 smtp.myorg.name ESMTP
    
    ➜  ~ openssl s_client -connect smtp.myorg.name:587 -starttls smtp
    CONNECTED(00000003)
    depth=2 C = US, O = DigiCert Inc, OU = www.digicert.com, CN = DigiCert Global Root CA
    verify return:1
    depth=1 C = US, O = DigiCert Inc, CN = RapidSSL TLS DV RSA Mixed SHA256 2020 CA-1
    verify return:1
    depth=0 CN = *.myorg.name
    verify return:1
    ---
    Certificate chain
     0 s:CN = *.myorg.name
       i:C = US, O = DigiCert Inc, CN = RapidSSL TLS DV RSA Mixed SHA256 2020 CA-1
     1 s:C = US, O = DigiCert Inc, CN = RapidSSL TLS DV RSA Mixed SHA256 2020 CA-1
       i:C = US, O = DigiCert Inc, OU = www.digicert.com, CN = DigiCert Global Root CA
    ---
    Now I am even able to send mail successfully thorough Kmail in Leap15.2

    Does it really related to Internet service provider ?? If its really the case, How can I solve for my existing service provider?

  4. #4
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    556

    Default Re: Kmail smtp timeout

    I see no other likely possibility then blaming the ISP connection.

    You could try using a VPN and see if then things work.

  5. #5
    Join Date
    Aug 2014
    Location
    Hyderabad, India
    Posts
    58

    Default Re: Kmail smtp timeout

    Quote Originally Posted by marel View Post
    I see no other likely possibility then blaming the ISP connection.

    You could try using a VPN and see if then things work.
    Though I can use Opera(free VPN) for browsing, how can use for email ? Any other free VPN alternatives available ?
    Thanks

  6. #6
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,894

    Default Re: Kmail smtp timeout

    Quote Originally Posted by tapassaini View Post
    Dear All,

    I am in need of help in sending emails from kmail.
    It is showing SMTP timeout, though I am able to recieve mails through imap but sending is failed as it is saying connection timout.

    smtp settings are: smtp.myorg.name port: 587 security: STARTTLS

    I am also getting same problem on latest mozilla thunderbird(78.x on windows10), though send mail is working fine in thunderbird 68.10.0(ubuntu 18.04) on a different machine.

    It seems some issue of TLS version. How can I solve these two problems ?

    Thank You
    When my internet service provider made TLS mandatory sending mail through smtp failed. I referred to their documentation, made the changes required (TLS, authentication) and smtp was great again: https://www.m-net.de/fileadmin/Servi...stellungen.pdf You may try to proceed accordingly.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

  7. #7
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    556

    Default Re: Kmail smtp timeout

    There are free VPN's available and for a test that is not a bad idea.

    In the document of @karlmistelberger I see settings are quite different over different e-mail clients, surprising...


  8. #8
    Join Date
    Aug 2014
    Location
    Hyderabad, India
    Posts
    58

    Default Re: Kmail smtp timeout

    Quote Originally Posted by karlmistelberger View Post
    When my internet service provider made TLS mandatory sending mail through smtp failed. I referred to their documentation, made the changes required (TLS, authentication) and smtp was great again: https://www.m-net.de/fileadmin/Servi...stellungen.pdf You may try to proceed accordingly.

    Thanks for the document, but it's in Non-English, still going through I could intepret that doc suggest to use port 587(which I have already set). I am using STARTTLS with plain authentication.
    As already said, Its working smoothly on my personal 4G hotspot, but not on my home broadband provider. I feel my home internet provider is using older technologies for Internet distribution, or may be blocking some TLS port(sorry for my ignorance).
    Thanks

  9. #9
    Join Date
    Oct 2014
    Location
    Rotterdam
    Posts
    556

    Default Re: Kmail smtp timeout

    My take from the document is that different email programs need different settings. KMail is not listed so I would try all different settings.

  10. #10
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    2,894

    Default Re: Kmail smtp timeout

    Quote Originally Posted by tapassaini View Post
    Thanks for the document, but it's in Non-English, still going through I could intepret that doc suggest to use port 587(which I have already set). I am using STARTTLS with plain authentication.
    As already said, Its working smoothly on my personal 4G hotspot, but not on my home broadband provider. I feel my home internet provider is using older technologies for Internet distribution, or may be blocking some TLS port(sorry for my ignorance).
    Thanks
    • Kmail sends mail with: server requires authentication, starttls, plain.
    • 'openssl s_client -connect mail.mnet-online.de:587 -starttls smtp' readily connects to the server.


    Thus I think you need to talk to their support.
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), AMD Ryzen 5 3400G (2020), openSUSE Tumbleweed, KDE Plasma 5

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •